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2 Help 

There are many ways to get help with the use of Studio. RWS offers a 
large number of different help facilities to the freelance translator. 
Most of them are collected on the Help ribbon, available in all views: 

 
Most of this is self-explanatory. The Studio Blog gives access to various 
blog posts related to Studio 2022, including Paul Filkin’s invaluable 
multifarious blog, to the posts of which I link in many places in this 
manual. The RWS Community option is described extensively below. 
However, you should note that with the new “cloud capabilities” (re-
placing Trados Live Essential), there are also new Help texts. For the 
individual translator, using Studio Freelance or Studio Professional, 
there are Help texts for working in the cloud in two places: both in the 
Studio help described below, and the cloud capabilities help, referenced 
later on p. 541. There is a problem in that while a major part of both 
is identical, parts of relevant Help texts are only found in one or the 
other of the two places. 
You may have noticed that RWS offers a large number of related prod-
ucts, and there is Help documentation for everything. There is the hub 
for all of it which looks like this: 
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Direct access 
to Studio  
settings  
windows 

 

Overview 
Because of the copious amount of Studio help and support material – 
both RWS generated and third party-generated – that is now available, 
I’ve tried to structure it and arrived at this overview. 
“Internal” Studio material 
• Direct access to Studio settings windows via the Tell me function 

• The online Help 

• Other directly Studio-related material (such as PDFs and videos): 
links in the Welcome view, documentation, Useful Tips, various 
video sources 

Material on the RWS sites 
• The Studio Trados site 

• RWS Support 

• RWS Community (in particular a number of discussion forums 
but also a large number of other resources) 

Third party material 
• Discussion groups 

• Blogs 

“Internal” Studio material 

This direct access to settings windows is often very helpful. It works via 
the Tell me function: Click the Tell me what you want to do tab on top in 
the Studio window, at right (or press Alt+Q): 
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3 The RWS AppStore 

The RWS AppStore feature is by now such an established and valuable 
resource that it rates its own chapter in this manual even though the 
specific applications are not included in the Studio package. But the 
Software Development Kit (SDK) is. 

Basic advice on, and descriptions of, the APIs (Application Program-
ming Interface) that are available as part of Studio is given by Paul Fil-
kin in his blog post Tinkering with tradition… APIs in Studio 2015 SR2. 
In particular, he talks about the APIs used for the AppStore plugins 
Export to Excel (see p. 372) and TermExcelerator (p. 484), created in 
part as demonstration material for interested developers. 

You will note that this manual mentions a large number of plug-ins 
which I have found interesting and possibly useful to you. These de-
scriptions are mainly based on the 2021 versions (and in a few cases it 
may even be that they are not – yet – available for Studio 2022). I will 
update this information in the coming updates of the manual. 

Viewing and installing AppStore applications (plug-ins) 

Note: As of Studio 2022, the AppStore functions seem to be in a con-
stant flux because of problems with the integrated AppStore. Thus, 
while I have been writing this (spring, 2023), several changes have been 
made which have meant that I have had to revise the text. Therefore, 
expect further changes which mean that the following text may not 
always be consistent with what you may actually encounter. Still, that 
should not deter you from exploring this extremely worthwhile fea-
ture. 

There is an excellent starting point for all AppStore matters inside Stu-
dio itself:  

• In the Welcome view, click RWS AppStore in the Navigation pane.  

• In any view, go to Add-Ins > RWS AppStore. 

• In the QuickAccess toolbar, click the RWS AppStore icon . 
The RWS AppStore window opens, with the following options: 

- Installed plug-ins 
- AppStore 

However, the first time you do this, you may be surprised – particularly 
if you are used to previous versions of Studio – to find that neither of 
these options have content. Fortunately, this is easily remedied. Simply 

3 

http://multifarious.filkin.com/2016/03/02/tinkering-with-tradition-apis-in-studio-2015-sr2/
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26 The Editor view 

Terminology 
There is some confusion regarding the terminology in the Editor view 
in Studio. This is what I try to stick to: 
 A segment is either a source string or a target (translated) string. The 

short form is simply “source" and “target”. 
 A row is what you work with in the Editor pane, consisting of a 

source segment, its corresponding target segment, a row number, 
status indicator, and a structure designation; see p. 205. (Hence the 
term often used for numbering, “segment number”, really ought to 
be called “row number”.) 

 A translation unit (TU) is the combination of source segment, target 
segment and all associated information, such as field data. TUs occur 
only in translation memories. 

 

Overview: The Editor view 

Ribbons 

In the Editor view, there are four specific ribbons: Home, Review, 
Advanced, and View:  
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Description 

This is a typical example of the Editor view. 
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Navigation pane Home rib-
bon 

 Editor pane Function-specific panes Tabs for 
other panes  

 

The left-hand function-specific pane by default shows the Translation 
Results, i.e. the results of the automatic lookup in the TM(s); see p. 
250. Note that the same pane can also show the results of the Concord-
ance Search (p. 259), any Comments (p. 328), and Messages (p. 339). 
Use the tabs at the bottom of the pane. Like the in the “old” Trados, 
the Concordance pane is updated with possible hits in the TM when a 
new source segment is opened. The Translation Results pane shows not 
only the best TM hit (if any), but also all other hits above the threshold 
(see p. 256) you have set. It may be a good idea to move either of those 
panes in order to make it bigger; see below. 

The right-hand function-specific pane by default shows the Term 
Recognition, i.e. the results of lookups – automatic or manual – in the 
termbase(s). The same pane can also show the Termbase Search facility 
(p. 275). 

Note: Many Studio users testify to the fact that Find & Replace as 
well as Auto-propagation in big files works much faster if the term 
recognition is turned off. In the Term Recognition pane, click the 

Project Termbase Settings icon  and uncheck the Enabled box(es) 
in the Project Settings dialog box that opens. 

You can switch between the panes and the open documents with 
Ctrl+Tab and Ctrl+Shift+Tab, which opens this window (with the first 
command you step downwards in the window, with the second up-
wards): 
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27 Segment handling 

Segment navigation and manipulation 
You can quickly get access to many commands for segment handling by 
right-clicking in the segment. This gives you the following options 
(note also the shortcuts). Which options are available depends on the 
situation. 
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The basic editing functions familiar from Word and other Office pro-
grams have the same shortcuts in Studio; e.g. Cut/Copy/Paste, cursor 
movement, select/delete a word, change case: Shift+F3 [SDLX: Ctrl+F11] for 
toggling between: all minor case, capitalization of first character, all cap-
itals – you can also go to Advanced > Formatting > , which opens this 
pane: 

 
Also select text until end of paragraph/segment (use Ctrl+Shift+Down), 
select text until beginning of paragraph/segment (use Ctrl+Shift+Up), etc. 
See also the Edit menu and the shortcut lists in Annex A and Annex B. 

Note: The default paste function means that if you paste a word 
which does not include leading and/or trailing spaces, you have to 
add those by hand as required. As of SR1, however, there is a func-
tion for “smart” cut and paste which provides automatic adjustment 
of that: Go to File > Options >Editor and select Smart cut and paste. 

As for Cut/Copy/Paste: If you prefer the alternative standard shortcuts us-
ing the Ctrl and Shift keys, you will discover that – inexplicably – it is not 
possible to assign the Shift+Insert combination (used for Paste). There is a 
solution, however; see my blog post Ctrl/Shift shortcuts for cut, copy and 
paste at tradosstudiomanual.com. 

 Copy source to target: Press Ctrl+Insert or Alt+Ins [SDLX: F4]. Any text 
in the target segment will be overwritten. 

 Copy all sources to targets: Press Alt+Shift+Insert [SDLX: Shift+F4]. 
Only empty target segments are affected. Note that you can elect to 
have this done every time you open a document for the first time. Go 
to File > Options > Editor. In the right-hand pane, there is this option: 

 

This option should be used with care, however. For instance, if you are 
translating a WorldServer (p. 56) document which contains already 
translated segments, this option will overwrite those segments with the 
corresponding source content. 

 Clear the target segment: Press Alt+Del. 
 Clear all target segments: Select all segments (see below) and press 

Alt+Del. 
 Clear draft segments: Press Alt+Shift+Del. 
 Toggle between source and target: Press F6. 

 Delete to end of row: Press Ctrl+D. 

http://tradosstudiomanual.com/?p=305
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 Delete to next tag: Press Ctrl+Shift+D. 

 Lock segment: One segment: Press Ctrl+L. A locked segment cannot 
be changed in any way. (The same command unlocks a locked seg-
ment.) Several segments: Select them – see below – and press Ctrl+L. 
They all get the same locked/unlocked status, determined by the last 
selected segment: if it is unlocked, all selected segments will be locked, 
and vice versa. This is regardless of whatever status the individual seg-
ments have. 

 Manipulate text as in MS Word: There are some Microsoft Word 
functions, such as highlighting, automatic correction of TWo initial 
capitals, Word-style Autotext, which you may miss. These and a num-
ber of other helpful functions – such as the lookup of a selected term 
in several web sites via this option in the right-click menu 
– are included in the AppStore application Wordbird. This image gives 
an indication of its many additional features: 

 
After installation, its Settings and Help icons are found on the Add-Ins 
ribbon.  

When it comes to highlighting there is also a powerful 
AppStore plugin called Wordlight. Its icon is found on the 
Home tab, and with it, you can: 

- Select from 15 colours (the same as in Microsoft Word). 
- Highlight selected text with 1 click or a single keyboard shortcut. 
- Change the colour in 2 clicks. 

https://appstore.rws.com/Plugin/116
https://appstore.rws.com/Plugin/94
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28 Advanced manipulation 
of files and segments 
 

This is a catch-all chapter for some AppStore applications which allows 
you to do useful things with files and segments but which are difficult 
to fit into the structure of this manual. 

Xliff Previewer 
The freeware application Xliff Previewer is related to the Bilingual 
Searcher (see previous page), and it is not primarily a find & replace 
application; its main purpose is quickly to let you preview an .xliff, 
.sdlxliff, .mxliff, .ttx or .tmx file – just right-click the file name in your 
file organizer and select Preview with Xliff Previewer. This is what the re-
sult may look like: 

 

However, you can also perform searches in the result by filling in the 
search field and selecting S (In source), T (In target), or R (Use regular 
expressions) and pressing  (Apply). (  stands for Show only 
comments, and  stands for Clear.) 
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Integrated Segment Actions 
Integrated Segment Actions is an AppStore plugin which is accessed 
from the Project or Files view – select one or more projects or files, 
right-click and select Segment Actions. This window opens: 

https://appstore.rws.com/Plugin/64
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31 Recognized tokens 

“Recognized tokens” (including tags); special 
characters; whitespace characters 

A recognized token – previously called “placeable” (in the Help texts 
they are sometimes still called that, and also “recognizers”) – is “a short 
piece of text, enclosed in a segment, that a TM treats as a single word 
because it is a defined format”. The following are simply inserted into 
the target segment just as they are, provided you have enabled the cor-
responding auto-substitution; see p. 295: 

• Inline tags 

• Acronyms 

• URLs 

• Alphanumeric strings 

• Variables 

Alphanumeric strings are any strings made up of combinations of let-
ters, number, underscores, dashes, and full stops; e.g. NAME_4001a. They 
must not start or end with underscores, dashes or full stops, must not 
contain both dashes and full stops, and must contain at least one num-
ber and one letter. But you can handle also those alphanumeric strings 
which do not follow these rules by using the AppStore plugin Regex 
Match AutoSuggest Provider; see p. 309. 

Note 1: The recognition of alphanumeric strings is activated by de-
fault. You can deactivate it in the Project Settings window under Language 
Pairs > [the language pair in question] > Translation Memory and Automated 
Translation > Auto-substitution and check Alphanumeric strings.  

Note 2: For existing TMs you need first to enable the corresponding 
setting. In the Translation Memories view, select the TM in question 
and press Alt, H, G (or go to Home > Tasks > Settings, or right-click the 
TM name and select Settings). In the Translation Memory Settings win-
dows which opens, select, in the right-hand pane, the Alphanumeric 
strings option. After that, you need to re-index the TM: In the same 
Settings window, select (in the left-hand pane) Performance and 
Tuning and click the Re-index Translation Memory button. (However, 
if you have many TMs where this needs to be done, it can take some 
time. For this reason, the RWS Community Developers have pro-
vided the very practical AppStore plugin TM Lifting, which sits on 
your desktop. You simply drag the files to be reindexed into the top 
half of its interface window and press the Re-index button. (Instead 

31 

https://appstore.rws.com/Plugin/153
https://appstore.rws.com/Plugin/153
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of dragging the files, you can load all TMs which are open in the 
Translation Memories pane in the Translation Memories view; to do 
that you just select the Load Studio TMs checkbox at the bottom of 
the window.) In the bottom half you can follow the progress. 

Before starting the reindexing, you should close Studio, since the 
changes to the TMs are normally not effected until upon restart. 

For more instructions, see the wiki entry. 

You can read more about this feature in Paul Filkin’s blog post The 
future is bright… it’s not Java!, under the heading “Automatic recogni-
tion of Alphanumeric characters”. 

Some may be easily “transformed” (localized) to the target segment 
according to specific rules. They are indicated either by being coloured 

 or by a blue square-bracket underline . They, too re-
quire enabling of auto-substitution (p. 295) and are as follows: 

• Dates 

• Times 

• Numbers (in numerals) 

• Measurements 

As for the localization of the tokens, again see p. 295. 

Tags (containing information about formatting, structuring and place-
holding) are a special case of recognized tokens in that they are not part 
of the textual content. They are shown as coloured fields and their han-
dling is described on p. 288. 

Inserting recognized tokens 

There are several ways to insert recognized tokens (always at the place 
of the cursor in the target segment): 
 Keyboard: Press Ctrl+[comma] or Ctrl+Alt+DownArrow. (Note that the 

last combination – as well as the one for stepping between tokens; 
see below – may result instead in changing the screen. If so, you need 
to deactivate the Windows hotkeys: right-click anywhere on the 
screen, select Graphic options [or the corresponding option in your 
language] > Hot Keys [or Shortcuts] > Disable.) A QuickPlace list of the 
“candidates” in the source segment opens.  

 
Note that for every option that you go to – with DownArrow – the 
affected text in the source segment will be highlighted. Select the 
required option and insert it by pressing Return or tab. 

By pressing Ctrl+Alt+RightArrow/LeftArrow, you step between the 
recognized tokens (but not the numbers) in the source segment, for-
wards or backwards; each token is highlighted in turn. When you 

https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/3268/tm-lifting
http://multifarious.filkin.com/2014/11/18/the-future-is-bright-its-not-java/
http://multifarious.filkin.com/2014/11/18/the-future-is-bright-its-not-java/
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32 Automatic handling of 
certain types of  
expressions –  
Auto-substitution and 
Auto-localization 

There are certain types of expressions which are preferably handled 
automatically, in particular in cases where they occur often. Examples: 
trade names (do not translate The Guardian but translate “the guard-
ian”), acronyms (do not translate), numbers (decimal separators!), dates 
(the many different formats are a well-known problem), measurement 
units and currency names and symbols (where to place them and what 
separators to use, if any). 

These matters are handled in Studio by Auto-substitution and Auto-
localization. The former means that when studio recognises a TU in a 
TM which is identical to the source segment in question except for an 
expression of a type mentioned above, Studio will use that TU but sub-
stitute the source expression for the one in the TU. In certain cases (e.g. 
acronyms) that expression will be transferred unchanged into the target 
segment, in other cases (e.g. a number) it will be auto-localized into the 
corresponding target language version. 

In principle, this may sound simple. But, to use a Swedish expres-
sion, you may think it is uncomplicated, but wait until I have explained 
it. 

In fact, there are indications in the Help texts of the complexity of 
these matters. They are handled on 16 different pages, and while the 
term for these types of expressions used to be “placeables” they are 
now called “recognized tokens” – and “placeables”, and also “recogniz-
ers”. I shall stick to the first variant (and sometimes just say “tokens”).  

To complicate things further, Studio uses different ways of auto-
localization depending on whether it is a matter of TM matches or not, 
such as when there is no TM match – in which case QuickPlace sugges-
tions are shown – and during machine translation (or, as it is called in 
Studio, Automatic Translation) if the segment only contains the recog-
nizable token and there is no TM match. This is how a QuickPlace 
suggestion could look, based on the corresponding setting in the TM’s 
language resources: 

32 
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The default auto-localization formats that Studio suggests during auto-
substitution are based on the formats available in your TM matches or 
in the Windows regional settings (for more about which, see Under-
standing Regional Settings by Barry Dysert). You may want to change 
or edit these default formats when (in the words of the Help text) 

• your source text contains non-standard formats for numbers, 
dates, times, measurements or currency amounts and Studio can-
not correctly identify them as placeables, 

• the translation units in your TM use incorrect or inconsistent for-
mats for placeables and you do not want to use these for your 
new translations, 

• you do not want to use the default localization formats in Quick-
Place suggestions and Automated Translation results but have 
your own instead. 

You make such changes in the language resources settings (p. 401); the 
context for them will be explained below. 

And as you may have surmised – or indeed already know from ex-
perience – there is a large number of such settings, in several places. 
But in order for anything at all to happen, the corresponding auto-sub-
stitution must be enabled, so we shall start with that. 

Note: If the following explanations are not sufficiently clear (or con-
fusing…), you should read Paul Filkin’s account, Short term memo-
ries. Or visit it anyway. 

Auto-substitution 
You will find the types of expressions available for auto-substitution 
(and thus, with some of them, also for auto-localization) in the Auto-
substitution settings. As usual, where you make the settings depends on 
what level you are aiming at: default or the active project (cf. p. 136). 
Here, there is the additional option of the project template settings. 
Thus: 

• for the default settings for the creation of a project/opening a new 
document (open the Options dialog box: select File > Options or 
Alt/F10, F, T), or 

• for the settings for the active project (open the Project Settings 
dialog box: select Project > Project Settings [or Alt/F10, H, S]), or 

• for the settings for a project template (open the Project Templates 
dialog box – select File > Setup > Project Templates (or Alt/F10, U, P) 
– then select the desired template and click Edit). 

Then select Language Pairs and after that select the TM for the required 
language combination and then Auto-substitution (this option is not 
available for All Language Pairs). 

https://windows.tips.net/T012171_Understanding_Regional_Settings.html
https://windows.tips.net/T012171_Understanding_Regional_Settings.html
https://multifarious.filkin.com/2021/01/07/short-term-memories/
https://multifarious.filkin.com/2021/01/07/short-term-memories/
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33 AutoSuggest 

AutoSuggest is a new function whereby Studio, by detecting the first 
few characters that you type, makes suggestions based on expressions 
in the selected termbases and in specific AutoSuggest dictionaries (p. 
306), and on expressions that you have entered into an AutoText list 
(p. 310) for the target language in question. The symbol to the left of 
the suggestion indicates its source (the picture below illustrates an Au-
toText hit). 

The more characters you type, the more specific the suggestions will 
be. 

 

Make your selection with the Up/DownArrow and press Enter. If you want 
to close the list without using any of the suggestions, press 
Right/LeftArrow. Or just go on typing, ignoring the list. 

An AutoSuggest dictionary contains words and phrases extracted 
from a TM. 

You will find some detailed discussions of AutoSuggest sources – 
including the use of termbases – in Paul Filkin’s blog post The ins and 
outs of AutoSuggest. 

Note: A somewhat similar function is offered by the Autocomple-
tion feature (p. 322). The difference is that not only do you have to 
“plan ahead” for the expressions in question, you also have to re-
member the abbreviations that you have programmed. 

Setting up AutoSuggest 
 Enable AutoSuggest and select “providers” of AutoSuggest en-

tries: Open File > Options (or Alt/F10, F, T) and select AutoSuggest in the 
navigation pane: 
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http://multifarious.filkin.com/2015/01/01/autosuggest/
http://multifarious.filkin.com/2015/01/01/autosuggest/
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The provider options Termbases, AutoSuggest Dictionaries and AutoText 
are self-explanatory. The Translation Memory and Automated Translation 
option means you can get matches from TMs, machine translation re-
sources and concordance searches, with these symbols: 

 
This is a new and very useful feature, which is described in detail by 
Nora Díaz in her blog post Studio 2015: AutoSuggest Gets Even better 
(with a video, too). If you want to use it, make sure that the Editor > 
Automation settings (in the File > Options dialog box) has Apply best match 
after successful lookup deselected (it is selected by default); also your 
settings of the minimum match values for TM lookup and concordance 
lookup (p. 254 and 259, respectively) should be set sufficiently low for 
hits to appear. 
As for the settings of which number of suggestions to show and their 
number of characters, you should experiment. But you probably do not 
want a large number of suggestions – which might happen, even if the 
suggestions are based on the source context –, nor will you want very 
short expressions to be suggested. This Help text has some concrete 
suggestions. 

 Hide suggestions which have already been used means “used before in 
the current segment”; i.e. the word/phrase already exists in the cur-
rent target segment. 

 Case sensitive – if you uncheck this, AutoSuggest will not only find 
results regardless of case, it will also adapt the hits accordingly (i.e. 
if the term you start to type starts with a lower-case letter, then the 

http://noradiaz.blogspot.se/2015/06/studio-2015-autosuggest-gets-even-better.html
https://docs.sdl.com/LiveContent/content/it-IT/SDL%20Trados%20Studio%20Help-v4/GUID-E81F738B-8A0C-470F-AF5C-90072E5CF52A
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Settings 

34 Auto-propagation 

Auto-propagation means that the translation of a segment is copied to 
all other target segments with identical source content in the same doc-
ument. It takes place when you confirm the translation. A target seg-
ment which is translated via auto-propagation will be given this status: 

, and the colour – which does not change if the translation is 
confirmed – indicates the difference from a “normal” 100% match (

). And since auto-propagation does not require a TM, it can be 
used even if no TM is specified. 

Open File > Options (or Alt/F10, F, T). Select Editor in the navigation tree 
and then Auto-Propagation. Make settings as follows (the figure shows 
the default settings): 

 

Explanations: 
 Enable/disable: Under General: Select/unselect the check-box 

Enable Auto-propagation. 
 Matching requirement: Under General: Select a 100% minimum 

match value or lower (hardly advisable). Note that you do not have 
the choice of “context match”, i.e. 101%. 

Note that you can select a specific background colour for autopropa-
gated segments; see p. 209. 
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 Auto-propagate exact matches to confirmed segments: If you 
make a change to a target segment with matching source text else-
where in the document, the change will be propagated also to those 
segments which are already translated and confirmed. In my expe-
rience, this is a very useful option. 

 Confirm segment after auto-propagating an exact match will 
probably save time. If you have set the matching requirement – see 
above – to less than 100%, any such propagated “lesser matches” 
will not be confirmed. 

 The whole document or only “below” the current segment: 
Select as Starting Position either First segment or Next segment in 
document. (Obviously, you cannot propagate “upwards” only.) 

 Prompt for confirmation: Select whether you want to be warned 
for every segment to which the translation or change is propagated (Al-
ways), or not at all (Never), or conditionally when the matching segment 
has been translated differently, and/or the matching segment has no 
translation, and/or the matching segment is confirmed. The latter option 
is of course available only when auto-propagation to confirmed seg-
ments has been selected. The warning looks like this: 

 
Note 1: Auto-propagated segments with tags missing from the tar-
get segments will get a ‘missing tag’ penalty. 

Note 2: The Auto-propagation function can sometimes be tricky 
and may give unwanted results with numbers. Discussions in TW_us-
ers (see p. 22) indicate that some experimenting with the settings 
may be required to get satisfactory results. One particular problem 
is that when a numerical range is given using the en dash instead of 
the “short dash” (often called hyphen-minus), e.g. 350–500 instead 
of 350-500 – which is very common in many languages – the Auto-
propagation does not recognise this but autopropagates only the 
first number; also it substitutes the short dash for the en dash. 

Note 3: If you use the filtering function (p. 228), it may happen that 
the auto-propagation function does not work properly. Therefore, 
it is probably safer not to combine them. 

About Translation Quality Assessment, see p. 338. 

 

 

https://groups.yahoo.com/neo/groups/TW_users/info
https://groups.yahoo.com/neo/groups/TW_users/info
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48 Producing new TMs 
from translated  
documents: Alignment 

You can “align” the source and the target file of a translation to produce 
a translation memory. The alignment tool was new in Studio 2014 and 
replaces the old Trados WinAlign tool. It produces a set of TUs which 
can then be imported into a new or existing TM for use directly in 
Studio. There is also the option of producing an intermediate file in the 
new .sdlalign format for editing before import into the TM. 

The alignment function supports all file formats which are sup-
ported by Studio. If necessary, you can create new file types as appro-
priate before starting the actual alignment process. And in general, it is 
not necessary that the target and source files have the same formats. 

There are extensive instructions in the Help, of course (available 
also here: Aligning Existing Translated Files). You can align one or sev-
eral file pairs, and you can do it with or without “review” of an inter-
mediate .sdlalign file, i.e. with or without editing the resulting TU:s 
before they are sent to the selected TM. Or you can send them there 
directly, in which case no intermediate .sdlalign file is produced.  

You can also open the alignment result (the .sdlalign file) for (re)ed-
iting at a later time. 

Note: When later you use the aligned TUs during translation, any 
hits in such TUs will have a 1% penalty, so that they will never be 
100%. (This can of course be changed; see p. 256 about the Penalties 
pane.) They will be signified in the Translation Results window with 

a  symbol, and the origin will be given as Automatically Aligned 
(when you point to the Status field). 

There are also other ways to edit the alignment results. After they have 
been imported into a TM, you can edit them there in the Translation 
Memory view. You can also export the .sdlalign file into .sdlxliff format 
and edit that in the usual Editor view. 

If you have a Word document which contains a table with the source 
text in one column and the target text in another (with one row for 
each pair of source and target text), it is of course quite easy to split it 
into two documents and then use the Alignment function. However, 
Roger Sjölander has written a macro which uses the table as it is and 
converts it into a TM file in text format. The macro and more 
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One file pair 

instructions can be found in this Tradosstudiomanual blog post: Creat-
ing a TM file from a Word table with source + target. 

Not surprisingly, Paul Filkin has written a blog post, Working with 
Studio Alignment, about this. It includes a 17 minutes long video tuto-
rial! You should note, however, that while it is generally correct in de-
scribing the basic principles, it is based on an older version of the align-
ment function and therefore is not in agreement with all of the current 
workings. 

A few other tips: Before alignment, open source and target docu-
ments and compare to make sure there are no amendments in the latter 
which will throw the whole thing out of kilt. Remove all images and 
formatting (if you want to be really certain of getting rid of possibly 
disturbing elements, save both files in .txt format). 

Alignment with or without review 
By default every alignment ends with the resulting .sdlalign file being  

 saved with the name of [name of source file]_[name of target 
file].sdlalign (however, sometimes the default name, inexplicably, is 
just [name of source file].sdlalign); you can of course assign another 
name,  

 saved in %UserProfile%/My Document/Studio 2015/Alignment Re-
sults, but you can change that address at the start of the alignment 
process (see below), 

 opened in the Alignment view. 

Note: Each TU generated from the alignment will have three custom 
fields (about fields, see p. 391): Quality, Source File and Target File. 
About Quality, see p. 427. 

Alignment with review 
If you have only one file pair to align, the Align Single File Pair is slightly 
quicker to set up than the alternative Align Multiple Files, which can of 
course be used also for the alignment of a single pair. 

 Align Single File Pair: In any view, press Ctrl+Shift+M (the correspond-
ing button  is found on the Home tab in the Welcome view, the 
Translation Memories view and the Alignment view). The Align 
Documents wizard starts with the Select a translation memory and the 
documents to align dialog box. 

http://tradosstudiomanual.com/?p=555
http://tradosstudiomanual.com/?p=555
http://multifarious.filkin.com/2014/05/21/studio_aligning/
http://multifarious.filkin.com/2014/05/21/studio_aligning/
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49 Translation Units 
maintenance 

The Translation Memories view 

Ribbons 

The Home and View ribbons are – as always – specific (some of the op-
tions are not visible until you have opened a TM):  

 

 

 

Description 

The Translation Memories view is where you edit the TUs stored in 
your TMs; i.e. change texts, formatting, field values, etc. – in fact much 
like you work with the segments when translating; one difference being 
that you can also edit the source segments; another that you also have 
field values to manipulate (if you have defined custom fields). The view 
typically looks like this (as usual, you can customize it by moving any 

pane which has a  symbol in its title list; see p. 42). (Note 
that the Field Values and System Fields pane is not shown 
until you click the vertical Field Values tab far right in the 
view, or the corresponding button: View > Information > 

.) 
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Navigation pane Menus and groups Search Details pane 

 

 
TM side-by-side editor Field Values and System Fields pane 

 Custom Fields (in the Field Values pane) are fields which are not 
standard (system) fields but have been added by a user.  

 System Fields are automatically generated, e.g. creation and modifi-
cation dates (p. 391). 

 Open a TM: Double-click its name in the Navigation pane (or use 
Alt+Shift+O, but then of course you have to locate it in the usual Open 
window). You can have several TMs open, but only one can be active. 
If you have several TMs open, you go between them by clicking the 
tabs on top of the Editor pane. If you have really many open, you can 
use the  symbol in the top right-hand corner; a list of all the open 
TMs is shown. 

If you have a .tmx file that you need to edit, there is now an 
AppStore application, File type definition for TMX, which makes it pos-
sible for you to open it as a translatable file without converting it into 
an .sdltm. 

 Close a TM: As usual, click the × in top right hand corner of the Editor 
pane. If you have made any (pending) changes (see p. 442), you will be 
asked whether to commit them or discard them. 

 Remove a TM: In the navigation pane, right-click the TM to be re-
moved and select Remove From List.  

 

https://appstore.sdl.com/language/app/file-type-definition-for-tmx/317/#95840
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The side-by-side Editor pane 
TM name tabs Source language segments Target language segments 

  
TU status Document structure 

(not visible here) 
Custom field val-
ues 

(Note that the document structure and custom field values columns are 
visible only when at least one TU contains such information.) A TM 
will normally take up several pages in the Editor pane. The number of 
TUs per page is set in the box on the Home ribbon (Alt/F10, H, T2) and 
can be up to 1000. The default number is set with File > Options (or 
Alt/F10, F, T), select Translation Memories view and then set the Number 
of translation units per page as necessary. To go between pages, press Alt 
+ Right/Left arrow, or click the Home > Navigation icons. You can also go 
to a specific page in the Page: box (or press Alt/F10, H, Z). 

Some explanations: 

 TU status: 

 
Edited: Some change(s) has been made 

 
To be deleted 

 
Invalid: Some error (e.g. one segment is empty) was detected 
during verification (when the cursor was moved to another 
TU) 

The status is also reflected in the background colours of the TU: 
 White or grey: No pending changes. 
 Yellow: Pending changes. 
 Pink: Marked for deletion. 
 Blue: Currently selected. 

These colours may be customized; see p. 207. 

 Document structure: The same as for segments in the translation ed-
itor pane; see Annex E. 

 Custom field values: Reflects the field values shown in the Custom 
Fields pane (where you make any changes). 
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52 MultiTerm 
and termbases 

The use of MultiTerm is integrated in the use of Studio, where you can 
search for, edit and create termbase entries. For more radical termbase 
management – such as advanced searches, and the creation of new 
termbases – you have to start and use MultiTerm itself. Here I will just 
cover the basic uses plus the basic settings and the shortcuts (see An-
nexes N–R). As with Studio, you may find that it pays to study them in 
order to get a view of the functions available. There is an interesting blog 
post by Paul Filkin, Is MultiTerm really that hard to learn? in his multi-
farious blog. And another one, Multitudinous terminology!, where he 
explains the reasons for the complexities of this application. 

Studio 2022 is compatible with termbases created in MultiTerm 
2017 and later. You can also use termbases in the format used in Mul-
tiTerm 2007 (version 7.5) and previous 7.x releases, as well as Mul-
tiTerm iX (version 6.x). Such termbases will be automatically upgraded 
to the MultiTerm 2022 *.sdltb format. Furthermore, you can connect 
to server-based termbases in Trados GroupShare 2017 and later. 

MultiTerm 2022 runs alongside any version of MultiTerm 2021. To 
access .tmw files you need the Trados Compatibility and Migration 
Power Pack. MultiTerm 2022 supports termbases created in MultiTerm 
6.x to 2007, and termbases created in MultiTerm 2009, 2011, 2014, 
2015, and 2017 are completely compatible with MultiTerm 2022 
termbases. 

However, it may happen when you open a 2011 termbase that you 
are told that it needs to be reorganised. How to do this is well explained 
by Nora Díaz in her blog post Reorganize your Termbase to Improve 
Term Recognition in Trados Studio. 

An interesting addition to the MultiTerm termbase function is the 
possibility to use simple Excel glossaries (with up to three columns) 
directly in Studio, i.e. accessible via Studios interface. This is possible 
with the AppStore plug-in TermExcelerator; see below on p. 484. 

Note: There is a standalone AppStore application, Tb-Scout, which 
allows you to make searches in various ways – i.a. for duplicate en-
tries – which is not possible in MultiTerm (or in the Studio interface) 
and which may be useful in situations when you need to look up 
relevant termbase entries without opening MultiTerm. See p. 486.  
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http://multifarious.filkin.com/2013/01/30/imrthtl/
http://multifarious.filkin.com/
http://multifarious.filkin.com/
http://multifarious.filkin.com/2014/03/04/multitudinous/
https://appstore.rws.com/plugin/102/
https://appstore.rws.com/plugin/102/
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The basic settings 
The basic settings available via File > Options (or Alt/F10, F, T) are quite 
few and easily illustrated by screenshots: 

 

 

 

 

The MultiTerm window 
The ribbons can be customised in the same way as in Studio (see p. 35). 

The Terms view – ribbons 
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54 MT basics 

There are a large number of optional MT resources, and they are pro-
liferating as we speak. The main ones are described in the next chapter. 

The information on the cloud-based resources (the Studio Cloud 
Capabilities) is presented in chapters of their own – the termbase func-
tions are covered in chapter 54, and how to translate in the cloud in 
Part 9. 

The use of any MT services is recorded in the .sdlxliff bilingual file 
during translation. Segments where MT is used are indicated with the 

 (for Neural Machine Translation – see below – which all MT 
now is) icon in the status column, but you should note that this icon is 
also used to indicate a translation based on an existing TU where some 
parts (such as dates) have been auto-substituted (see p. 295). 

And don’t forget: If you use MT, you can set the AutoSuggest func-
tion (p. 303) so that it presents you with any fragment (sub-segment) 
hits it finds in the MT provider’s data; just select the Translation Memory 
and Automated Translation option. 
If you want an almost state-of-the-art description of MT, you can 
hardly do better than reading the book Maschinelle Übersetzung für 
Übersetzungsprofis, edited by Jörg Porsiel; I have written a review of it 
here. Despite its German title, more than half of it is in English, and the 
price is quite reasonable (€37 for 384 pages). Mr Porsiel is also the 
editor of a previous book, Machine Translation – all in English – which 
is still to large extents up-to-date (and reviewed by myself here). 

An interesting overview of the current (2022) situation with regard to 
how translators view, and work with, MT is given by Michael Farrell 
in his article Do translators use machine translation and if so, how? 
Results of a survey held among professional translators. And the same 
expert has written a very useful handbook for translators using MT, A 
guide to machine translation for today’s professional translator; well 
worth its price. Another report worth studying is Trados’ own Trans-
lation Technology Insights 2023, “exploring the role of technology 
within the translation industry and how it might shape the future of the 
industry.” 

Furthermore, Paul Filkin, in his multifarious blog, gives a lot of useful 
advice and suggestions about the uses of machine translation in the post 
There’s more than one way to skin a CAT.  

There are of course any number of interesting web sites for discussions 
of MT; some of my favourites are eMpTy Pages, RWS’ own Neural MT 
Weekly and SLATOR (with an excellent newsletter). 

54 

http://tradosstudiomanual.com/?p=1567
http://tradosstudiomanual.com/?p=1567
http://tradosstudiomanual.com/?p=1425
https://www.researchgate.net/publication/368363793_Do_translators_use_machine_translation_and_if_so_how_Results_of_a_survey_held_among_professional_translators?channel=doi&linkId=63e4901864252375639b75d7&showFulltext=true&fbclid=IwAR3OUxjZGo4k1_Nz03dvZV_9TsEZtYzEuM7FEUnZv-s_vOFjmYHA9-AiOGg
https://www.researchgate.net/publication/368363793_Do_translators_use_machine_translation_and_if_so_how_Results_of_a_survey_held_among_professional_translators?channel=doi&linkId=63e4901864252375639b75d7&showFulltext=true&fbclid=IwAR3OUxjZGo4k1_Nz03dvZV_9TsEZtYzEuM7FEUnZv-s_vOFjmYHA9-AiOGg
https://www.trados.com/download/translation-technology-insights-2023-report/215294/
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General discussions  
Confidentiality 

The use of an “outside” MT provider – such as Google Cloud Transla-
tion Provider, MyMemory, Microsoft Translator Provider or similar 
online translation services – may violate the non-disclosure agreement 
(if any) that you have with your client. However, the privacy declara-
tion that they make, and that I refer to in the respective presentation 
here, may be enough for most confidentiality requirements. I have writ-
ten an expose on this topic, discussing mainly the confidentiality/pri-
vacy of the various paid services on offer. Furthermore, if you do jobs 
for countries in the European Union, and they contain any kind of per-
sonal data, you have to take into account EU’s new General Data Pro-
tection Regulation, GDPR. (I touch upon this as well in the blog post.) 

RWS certifies that they do not make public any material they re-
ceive/send, nor can it be retrieved without their knowledge. As for the 
cloud-based resources and Language Weaver Provider, no target text is 
ever sent back from you, and the source text is only held in memory 
long enough for a translation to be provided; then it is discarded. (RWS 
Language Cloud Privacy Policy: “To provide the services ordered: RWS 
represents that during the machine translation process none of the 
source material will be needed, stored or used in RWS's translation en-
gines, except for term dictionaries, which will be stored securely.”) 

Regardless of what security is promised by the provider of the ma-
chine translation, it does not change the fact that whatever you send or 
receive via the internet may be compromised during that process. 

One method of improving the confidentiality is to pre-edit the text sent 
for translation, and such a feature is built-in in a few of the MT plugins 
mentioned below. A more comprehensive way of protecting data during 
translation – whether MT is used or not – is offered by the very impressive 
AppStore plugin Trados Data Protection Suite. Using plain text or regular 
expressions you can convert sensitive data (which could for instance mean 
data – such as email addresses – which must not by mistake be changed when 
transferred to the target segments) into tags before the translation starts (this 
is sometimes called “redaction”). During and after the translation, those seg-
ments thus anonymised are stored in your TM. When everything is finalised, 
you “unprotect” your target files before sending them to the client. The re-
spective commands are found on the Batch Tasks list, and right-clicking a 
project gives access to Project Anonymizer Help. But don’t miss reading the 
instructions in the RWS Community wiki. 

Should you feel the need for anonymizing a TM or SDLXLIFF after trans-
lation, there are three AppStore plugins for that: the Trados Batch Anony-
mizer, TM Anonymizer and SDLXLIFF Anonymizer (both from Localix.biz); 
see p. 510. 

It may help you to abide by the GDPR requirements if you anonymise the 
TU system field data, such as your name (Created by) and even the Windows 
domain you were logged into when translating the segment. Such anony-
mization functions are offered by the AppStore plugin Trados Batch Anon-
ymizer, which allows you to anonymise usernames and related data, TMs, 
and also the evidence of the use of machine translation, all in one click. You 

https://eugdpr.org/
https://eugdpr.org/
https://www.rws.com/legal/privacy/language-cloud-privacy-policy/
https://www.rws.com/legal/privacy/language-cloud-privacy-policy/
https://appstore.rws.com/Plugin/39
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/3199/sdl-project-anonymizer
https://appstore.rws.com/Plugin/38
https://appstore.rws.com/Plugin/38
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can read about it in a wiki entry and in particular in Paul Filkin’s blog post 
Badass…. 

There are other, similar plugins, which however do not allow you to “anon-
ymize” the use of MT. Other than that, I have not compared them in depth. 

TM Anonymizer, which is placed on the View navigation field after installa-
tion. Using the app for one file at a time is free; for multiple files (in 
one go) you need to buy a license. 

 

And from the same developer as TM Anonymizer comes the AppStore 
plugin SDLXLIFF Anonymizer, providing the same service for .sdlxliff 
files: 

 

Again, for multiple files in one go you need to buy a license. 

Paul Filkin has written about the matter of data protection and confi-
dentiality in his blog post Data Protection, where he also mentions the 
three applications above as well as SDLTmConvert (see also p. 395). 

Neural machine translation 

Up until the arrival of ChatGPT and other so-calles large language models, 
there was a lot of talk (and a lot of hype) about Neural Machine Translation 
(NMT) as opposed to the previous Rule-based (RBMT) and Statistical 
(SMT), or its subcategory Phrase-Based (statistical) machine translation 
(PBMT). And the fact is that despite all the brouhaha over GPT, it is   still 
NMT which dominates MT. This is not the place to discuss such more the-
oretical aspects (read this brief article by Arle Lommel for a good description 
of NMT), but since several applications offer the choice between NMT and 
SMT (or PBMT) as a first lookup instance, I think the following reflec-
tion by Jost Zetzsche (in his Tool Box Journal, issue 278, September 
2017) is still very much worth considering: 

“I have long maintained that the most effective way of using MT for 
the majority of applicable projects is to use it as a repository for frag-
ments rather than suggestions for whole segments that can and need to 
be edited. Especially in the statistical phrase-based machine translation 
scenario, the individual fragments or phrases are actually made up of 
translations that you and I have delivered over the years. They might 
be wrongly chosen by the machine translation program for the purpose 
of the current translation, but if they fit, they fit -- and potentially save 
you from a lot of typing. 

https://community.rws.com/product-groups/trados-portfolio/rws-appstore/w/wiki/5249/trados-batch-anonymizer
https://multifarious.filkin.com/2020/04/16/badass/
https://appstore.rws.com/Plugin/98
https://appstore.rws.com/Plugin/97
https://multifarious.filkin.com/2018/05/27/data-protection/
http://www.tcworld.info/e-magazine/translation-and-localization/article/neural-machine-translation-offers-significant-advances-with-remaining-challenges/
http://www.tcworld.info/e-magazine/translation-and-localization/article/neural-machine-translation-offers-significant-advances-with-remaining-challenges/
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55 MT providers 

This chapter contains descriptions of MT providers which can be used 
from within Studio. Two of them are provided by RWS, one of which 
is built-in and one which requires an AppStore plugin.  

There is a very large number of providers which can be accessed via 
AppStore plugins – either directly via the plugin, or via the plugin as an 
intermediary. A few of them are described in the following; I have se-
lected some which I find reasonably priced (note that some are classi-
fied as Paid and others as Free; “Free” means that the app is free – 
which is mostly the case also with the “paid” apps – but almost always 
you have to pay for the actual MT service), and which are general 
enough to be useful for most freelancers. Obviously I have missed many 
services which fulfil both criteria, and I am grateful for any suggestions. 

Note that you can only use the MT providers in Studio locally, not 
in the Online Editor (except when they are available in the form of add-
ons; see p. Fel! Bokmärket är inte definierat.). But you can set up a 
local project with a number of MT providers and, if you need, migrate 
it to the cloud. Then, when you work on it locally, you can use your 
selected MT providers (and local TMs) – you can, for instance, pre-
translate using MT, and then whenever you like go to the Online Editor 
and continue to work there. And go back and forth between Studio and 
Online as you find suitable. 

Connecting to a built-in MT provider:  
Cloud-based resources  

To connect to a built-in MT provider, you need first to add a connec-
tion to the server in question. 
 For the default project settings: Open the Options dialog box by se-

lecting File > Options (or Alt/F10, F, T). 
 For the settings of the active project/document: Open the Project 

Settings dialog box by selecting Home > Project > Project Settings (or 
Alt/F10, H, S1). 

 For the settings of a project template: Open the Project Template 
Settings dialog box. (Select File > Setup > Project Templates [or Alt/F10, 
F, U, P[. The Project Templates dialog box opens; select the template 
in question and click Edit.) 

In the dialog box that you open, you will add the server either under 
All Language Pairs (in the navigation pane) or under a specific language 
pair (e.g. if you want to use different servers for different language 
pairs). 
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Click the Use button  in the right-hand pane and select an op-
tion. The built-in options for machine translation (MT) – also called, 
in the RWS documentation, “automated translation” – in Studio are 
these two: 
 Cloud-based resources (see below),  
 Language Weaver Machine Translation. 

The latter option opens a dialog for you to choose an AppStore plugin 
for either Language Weaver, which provides access to the Language 
Weaver Provider (p. 527), or Language Weaver Edge, which is mainly 
intended for corporations. It is a paid resource which requires specific ac-
counts. 

With Cloud-based resources and Language Weaver Provider you 
can use some of the cloud-based MT resources offered by RWS from 
within Studio. This is different from using the Cloud Capabilites (p. 
540) for working with projects in the cloud, whether from within Stu-
dio or using the online editor. 

Finally, RWS offers a service called Language Weaver Cloud, which 
is used directly on-line, separately from Studio; it is described on p. 
598. 

Settings in Cloud-based resources 

When you select Cloud-based resources, this dialog opens: 

  

 
Select to use Machine Translation or Translation Engines – or both, one at 
a time. In the former you will get to select an NMT model (see p. 557) 
included in your Language Weaver subscription and defined for the 
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56 Trados Studio  
Cloud Capabilities 

 
RWS, the owner of Trados, provides a host of translation services on their 
Language Cloud platform. Thus the Cloud Capabilities (CC) that are in-
cluded in Studio are in fact aimed at a much larger audience than the Studio 
user, which partly explains the differences in concepts and methods between 
what we are used to in Studio and what we encounter in the CC. 

Using the Studio Cloud Capabilities (in some places called the Freelance 
Cloud Capabilities) means that you work with projects which are handled 
completely online, using your browser – the Online Editor. You can access 
your project from wherever you are and from any device (including 
Mac computers and smart phones). And as you work, all changes are 
stored in RWS’s secure cloud system. 

However, you can also work with the same project in your locally 
installed    Studio. You can switch between the two editors for one and 
the same online project. Whenever you make such a switch, the target 
file will be updated with the changes made in the previous place. (But 
note that if you make changes to the termbases, you still have to arrange 
that “synchronisation” yourself.) 

Both methods have their advantages. In the cloud, your project is 
continually stored in a safe way, you can work on any device wherever 
you are and regardless of operating system, and you can share the work 
with others. Also, at least RWS believes that working in the cloud will 
be, to a large extent, the future of the translation industry. 

Locally, you have access to any of your TMs and termbases as you 
please (with the possibility of easily changing the project setup), you 
can use PerfectMatch plus any one(s) of the many MT providers offered 
via the apps in the AppStore. (The Cloud Capabilities also offer MT, 
but only some half-dozen providers.) 

The benefits are described more in detail here. 
And if you want to keep track of the continuing development of the 

online features, these Release Notes are updated as the changes are 
made. 

Users’ reactions 

Experienced user Emma Goldsmith describes some other interesting 
features which may add to the attraction:  
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• Optional horizontal source-target display, practical when revising, 
to easily spot mistranslations and omissions; 

• Find and Replace panel (called Navigation, mirroring MS Word 
terminology and display) with a visual display far superior to Stu-
dio's Find and Replace box; 

• QA with filtering by error type; 

• Lookups filtered by blur or hide mismatches – fuzzy hits adapt as 
you type into the target segment or are hidden altogether; 

• Target file previews for a wide range of file types, tucked neatly 
beside or below the translation pane; 

• Light-on-dark option, a welcome novelty for translators who like 
night themes. (This option is now also available in the Studio edi-
tor.) 

Meanwhile, here are some good sources of information if you decide 
to try it out (and why not; it is after all part of your Studio purchase). 
While not completely up to date, they give a good general idea of the 
workings of the new facilities. (Note that the designation Trados Live 
has now been replaced with Trados Cloud or Studio Cloud Capabili-
ties, depending on where you look.) 

• Nora Díaz’ excellent starter SDL Trados Live: A New Way of Work-
ing!… 

• …as well as her video Why I work in the cloud; 

• Emma Goldsmith’s informative overview SDL Trados Live; 

• The 12 minute video How to use SDL Trados Live (also reached 
via the link in the Welcome view under Working with Cloud Pro-
jects). 

• A “Package information” detailing the cloud capabilities included 
in the Freelance and Professional packages (among other things, 
the number of translated words per year, languages per project, 
etc.). Scroll down a bit. 

Documentation 

There is ample documentation in the form of Help texts. As I have said 
before, parts of the information are duplicated in the Cloud Capabili-
ties and the Studio documentation (see below). In some cases there are 
differences, and then you should stick to the former. 

• General information on the work with cloud projects: See the sec-
tion Welcome to the Trados Studio cloud capabilities documenta-
tion. 

• Specific information on how to work with Trados Online Editor: 
See the section Working with Trados Online Editor. To a large ex-
tent, the same information is found in the Studio documentation 
in the section Trados Studio integration workflows. However, you 
should note that although they cover the same topics, there are 
some sub-sections in the one that are not found in the other, and 
vice versa. (This is probably not intentional but a consequence of 

https://noradiaz.blogspot.com/search?q=sdl+trados+live
https://noradiaz.blogspot.com/search?q=sdl+trados+live
https://www.youtube.com/watch?v=sY57DkZ0c7o
https://signsandsymptomsoftranslation.com/2020/08/17/sdl-trados-live/
https://sdl-marketing.dist.sdlmedia.com/distributions/?o=2AD69D8B-BE46-4BFB-A8E0-D001C737CC82
https://www.trados.com/products/trados-studio/cloud-capabilities/
https://docs.rws.com/812699/805890/trados-studio-cloud-capabilities/welcome-to-the-------------trados-studio-cloud-capabilities-documentation
https://docs.rws.com/812699/805890/trados-studio-cloud-capabilities/welcome-to-the-------------trados-studio-cloud-capabilities-documentation
https://docs.rws.com/812699/503929/trados-studio-cloud-capabilities/working-with-------------trados-online-editor
https://docs.rws.com/980998/604752/trados-studio-2022/trados-studio-integration-workflows
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58 Creating a cloud project 

This chapter is only about the project creation process. Project man-
agement is a much more comprehensive topic and is handled in the 
next chapter. 

There are three ways to create a cloud project: 

• From a browser 
• From Studio 
• Migrating a local project to the cloud 

Note that when you create a project from Studio, you cannot create 
project resources nor configure project settings; see the previous chap-
ter on how to make the necessary preparations. 

Creating a cloud project from a browser 
Extensive instructions on this topic is provided in the Help documen-
tation Creating projects from Trados Studio cloud capabilities. For the 
time being, I shall restrict myself to the basic functions while pointing 
out more specific features and giving references to the corresponding 
help texts. 

 Log in to your Cloud Capabilities account – either via Studio as de-
scribed on p. 542 or directly from your browser. 

 

 Select Projects on the menu and click + New Project. The General page 
opens: 

58 

https://docs.rws.com/812699/710082/trados-studio-cloud-capabilities/creating-projects-from-------------trados-studio-cloud-capabilities
https://languagecloud.sdl.com/lc/login


Creating a cloud project Creating a cloud project from a browser 

572 Trados Studio 2022 – THE MANUAL 

 
You must fill in project Name, Due date, and Location (as for the latter, 
see p. 558). Also Project Template, Source and Target Languages, plus 
File Type Configuration. Options for Project Template and File Type 
Configuration are provided via your selection of Location. (You can 
add more languages than those provided by the project template.) If 
you only have one project template defined, it will be selected automat-
ically. Note that you cannot here create new locations, project tem-
plates or file type configurations; they must have been defined in ad-
vance. See chapter 57. 

 Then add your project files. (You can create the project without adding 
files, but you cannot then start it. However, you can add files at any 
time.) The source file may consist of a project package (an .sdlppx file), 
whereby its contents will be extracted automatically. You can add 
.sdlxliff files if they are created in Studio 2021 or later, and their file 
type settings must be identical in Studio and in the cloud environment. 

Once you have added your files, this is what you see (the default view): 

 

(The Advanced view with  is for multi-source project templates.)  

Note that you can edit USAGE by pointing to it and selecting the pen 
icon. If you need to change the usage for a file or remove it, select it: 
then buttons for Change usage and Remove will appear. 

 Once you are done, click Next. The Translation Engine window opens: 
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Here you can select TM(s), Machine Translation Model(s) (see p. Fel! 
Bokmärket är inte definierat.), and termbase(s). You can also delete ex-
isting ones and/or create new ones. 

When you are done, click Create & Start. The new project will be entered 
in the Projects view: 

 
You will be notified of its creation via email and in the Notifications 
panel in Studio. But even after that, a final act of creation remains: 

 On the top menu, select Inbox and then click Refresh. A view like this 
opens: 
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59 Cloud project  
management 

The management of cloud projects is handled in some 40 windows in 
your online Trados account. This chapter is an attempt at presenting 
the various management actions in a systematic way (which is a huge 
task, so don’t expect perfection.) 

Projects overview; the Dashboard 
Here is the starting page, the Dashboard (first of several; see below), 
which gives an overview of the general work situation: 

• The number of projects created, by month and year 
• The amount of work processed (number of words) 
• Currently active projects 
• Currently active “tasks” (see below) 

Plus one button for adding customers and one for starting a 10 minutes’ 
video which gives a speed introduction to the Cloud Capabilities. 
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There is another view available which gives much more detailed infor-
mation on the projects. On the Dashboard, select Projects on the main 
menu. Below is a sample of the result. (The “75% – or 73% – PRO-
GRESS” refers to the number of workflow tasks performed, not how 
much has been translated; this is yet another aspect of the online work 
which is geared towards large-scale operators, not freelance transla-
tors.) 

 

A few notes: 

• Once you have opened the view of a specific project from the 
Dashboard (as described below), the way to open this particular 
view is to click Projects on the main menu in that specific view. 
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60 The Online Editor 

Opening a cloud project in the Online Editor 
 Log in to your Cloud Capabilities account – either via Studio as de-

scribed on p. 542 or directly from your browser. You arrive at the Dash-
board (normally your Projects Created and Words Processed diagrams 
will look different from this view): 

 
From here on, there are many ways to open your file. However, the 
following is the most standard one. 

Select the project you are going to work on. The Projects > Dashboard 
view opens, looking something like this (the “75% PROGRESS” refers to 
the number of workflow tasks performed, not how much has been 
translated): 
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 On the menu in this view, select Stages (by default, the Filter pane is 

not shown): 

 
 Select the file(s) you want to work with and select Open in Online Edi-

tor. (As you see, you can also select to work in Studio.) 

Opening a cloud project in Studio 
Opening from the Online Editor 

 Go to the Dashboard and click on the project in question. The Pro-
jects > Dashboard view opens. 

 Select either Stages or Files. 
 Select the file(s) in question and click on Open in Studio. 
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 

Opening from Studio 

In the Project view, either select (if the project has not yet been down-
loaded, which is indicated by the  icon and the status Not Down-
loaded) Cloud Projects > Download Cloud Projects, or (if it has been down-
loaded but is not yet available in Studio) select Cloud Projects > Refresh. 
Then open the project and its file(s) as usual. You will have access to 
the Translation Engine specified for the project. 

Switching between the two Editors 
From Studio to the Online Editor 

In order to have the Online Editor synchronised with the changes made 
in the Studio Editor view, you must of course confirm the segments in 
question but you must also either close the document, saving the 
changes, or save it while it is open (Ctrl+S). 

Then go to the Projects view (you don’t need to close the Editor view) 

and select Cloud Projects > Open in Cloud . Your online account 
opens, however not – as might be expected – with the Online Editor 
but with the Projects > Dashboard view of your project. From there, se-
lect Files and the file in question. Then click Open in the Online Editor. 

From the Online Editor to Studio 

In the Files view, open the file(s) in question. You should now receive 
a message “Synchronize changes”, telling you that the local version(s) 
in Studio conflicts with the version stored in the cloud, and do you 
want to overwrite the former with the latter? You should choose Yes, 
of course. 

Interestingly enough, any changes made in the Cloud Editor while you 
still have the document open in Studio will be reflected in the TM 
lookup results in the Studio Editor view once you have clicked the Re-
fresh button in the Projects view. This is because of the fact that you are 
using the same translation engine (and thus the same TM) in both 
places. And it works both ways: Any confirmed change in the Studio 
Editor will be reflected in the Studio Editor as a 100% TC match in the 
Show Lookups Panel (see below), and by double-clicking that new 
lookup result you can insert it into the document. 

Using the Online Editor 
The Editor view 

In the Editor view, there are three specific ribbons: Home, Review, and 
View: 
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INDEX 
Note that if you have Studio open in front of you, rather than 
using this index it might be better to use Studio’s Tell Me 
feature (p. 13) – the appropriate “hit” there will take you 
directly to the window that you need. 

(AppStore) TM Lifting, 281 
.autoCorrect files, edit, 323 
.csv and tab delimited text documents 

source file comments in, 331 
.doc to .docx files, batch conversion, 328 
.lng (filetype), 606 
.mtf.xml (file format), 473 
.pdf converter, 380 
.pdf file, deliver .pdf translation as, 382 
.sdlretrofit file, open, 374 
:Text to speech proofreading: worth a try! (blog 

post), 365 
…and the winner is? (blog post), 467 
100% match 

definition, 253 
ignore during spell checking, 317 

3 Ways to Keep a Window Always on Top on 
Windows 10 (tip), 236 

A 
 

A business resolution for 2019 (blog post), 21 
A clean editing environment? (blog post), 290 
A Collection of Regular Expressions for the Regex 

Match AutoSuggest Provider (blog post), 309 
A competitive edge (blog post), 606 
A couple of little known gems in SDL Trados Studio 

(blog post), 606 
A file with a view (blog post), 245 
A private AppStore (blog post), 28 
abbreviation list (in Langugage Resources), 401 
About Translation (blog), 22 
accept all tracked changes in document, 378 
accept tracked change 

and go to next, 378 
but do not go to next one, 378 

Access Rights (translation memories), 406 
account information, SDL Trados Live, 543 
Account Settings (Language Weaver), 600 
acronyms 

definition, 296 
Action (word check in QA Checker), 347 
Actions (Batch Edit Script page), 444 
Actions on segments (in Community Advanced 

Display Filter), 233 
Activate option (for character display during TM 

display), 252 

activate translate to fuzzy, 223 
Active Document Settings 

Languages dialog, 216 
Active segment background color (Editor pane), 207 
Active Spell Checker, 317 
Adapt 

font sizes, 209 
text colors, 209 

Adapted Language Pairs (Language Weaver), 602 
adapting the text colour contrast, Online Editor, 

596 
add 

all project files in a folder, 99 
as new translation, 69 
AutoText entries, 309 
comment, 328 
customers, 101 
files to the current project, 126 
files/folders to project, 126 
folders to the current project, 126 
individual project files, 99 
new batch script for TM, 444 
new folder to the project (in Files view), 126 
new target languages to projects, 128 
new translation units (in Translation Memory 

Updates), 164, 269 
project to projects list, 125 
Segmentation Rule window, 402 
server connection (for server-based TMs), 452 
server-based TM, 453, 454 
spell checking dictionary, 319 
target language, 98 
termbase entry, 478 
termbases, 128 
TMs in projects, 127 
translation as duplicate, 223 
translation memory (TMX Import Options), 412 
word check action in QA Checker, 347 

Add alignment metadata, 433 
Add AutoText Entry dialog, 309 
Add Comment dialog, 328 
Add comment to all filtered segments, 79 
Add Condition dialog (filtering TUs), 448 
Add Condition pane (for filtering), 257 
Add Condition window (new AutoSuggest 

dictionary), 307 
Add Copy (edit termbase entry), 475 
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