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2 Help 

There are many ways to get help with the use of Studio. RWS offers a 
large number of different help facilities to the freelance translator. 
Most of them are collected on the Help ribbon, available in all views: 

 
Most of this is self-explanatory. The Studio Blog gives access to various 
blog posts related to Studio 2021, including Paul Filkin’s invaluable 
multifarious blog, to the posts of which I link in many places in this 
manual. The RWS Community option is described extensively below. 
However, you should note that with the offering also of the new cloud 
services, Trados Live (Live Essential and Live Team), there are also new 
Help texts. For the individual translator, using Studio Freelance or Stu-
dio Professional, and subscribing to Live Essential (which is free for the 
time being for upgraders from Studio 2019; see p. 7) there are Help 
texts for Live Essential in two places: both in the Studio help described 
below, and the Live Essential help, referenced later on p. 563. There is 
a problem in that while a major part of both are identical, large parts 
of relevant Help texts are only found in one or the other of the two 
places.  

Overview 
Because of the copious amount of Studio help and support material – 
both RWS generated and third party-generated – that is now available, 
I’ve tried to structure it and arrived at this overview. 
“Internal” Studio material 
• Direct access to Studio settings windows via the Tell me function 

• The online Help 

• Other directly Studio-related material (such as PDFs and videos): 
links in the Welcome view, documentation, Useful Tips, various 
video sources 

Material on the RWS sites 
• The Studio Trados site 

• RWS Support 

• RWS Community (in particular a number of discussion forums 
but also a large number of other resources) 

Third party material 
• Discussion groups 
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Direct access 
to Studio  
settings  
windows 

• Blogs 

“Internal” Studio material 

This direct access to settings windows is often very helpful. It works via 
the Tell me function: Click the Tell me what you want to do tab on top in 
the Studio window, at right (or press Alt+Q): 

 

This pane opens (with default options as shown): 

 
and here is the result when I want to (perhaps) adjust my AutoSuggest 
settings: 

 
Each of these options directly opens a corresponding window for Au-
toSuggest. In addition to the categories shown here – Commands and 
Options – you may also get results in the form of Settings.  

This is very handy, and note: If you are looking for information on 
commands, options and settings in this manual, you may of course use 
the index at the back – but even better, if you have Studio open in front 
of you, you can use the Tell Me feature to arrive directly at the corre-
sponding window. 

In addition, there is a useful AppStore plugin called Trados Quick-
Info, which provides various types of information, such as unit 

https://appstore.sdl.com/language/app/sdl-quickinfo/938/
https://appstore.sdl.com/language/app/sdl-quickinfo/938/
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3 The SDL/RWS AppStore 

The SDL/RWS AppStore (yes, there is a confusion of names here; pre-
sumably the “SDL” handle will eventually be replaced by “RWS” every-
where) feature is by now such an established and valuable resource that 
it rates its own chapter in this manual even though the specific applica-
tions are not included in the Studio package. But the Software Devel-
opment Kit (SDK) is, and if you feel like contributing, check out the 
SDL AppStore Developer Hub, where you will find lots of information 
and where you can offer your own enhancement applications.. 

Basic advice on, and descriptions of, the APIs (Application Program-
ming Interface) that are available as part of Studio is given by Paul Fil-
kin in his blog post Tinkering with tradition… APIs in Studio 2015 SR2. 
In particular, he talks about the APIs used for the AppStore plugins 
Export to Excel (see p. 373) and TermExcelerator (p. 489), created in 
part as demonstration material for interested developers. 

You will note that this manual mentions a large number of plug-ins 
which I have found interesting and possibly useful to you. These de-
scriptions are mainly based on the 2019 versions (and in a few cases it 
may even be that they are not – yet – available for Studio 2021). I will 
update this information in the coming updates of the manual. 

Viewing and installing applications (plug-ins) 
There is an excellent starting point for all AppStore matters inside Stu-
dio itself:  

• In the Welcome view, click RWS AppStore in the Navigation pane.  

• In any view, go to Add-Ins > RWS AppStore. 

• In the QuickAccess toolbar, click the RWS AppStore icon . 
The SDL AppStore window opens, with the following options: 

- Installed plug-ins 
- AppStore 

The Installed plug-ins option opens a list of installed plugins with the 
options to update or uninstall them.  

The AppStore option opens this page: 

3 

https://appstore.sdl.com/language/developers/
http://multifarious.filkin.com/2016/03/02/tinkering-with-tradition-apis-in-studio-2015-sr2/
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Here you can view all apps available for Studio 2021 and sort the by 
categories (to the left) and also by Most Downloaded, Most reviewed and 
Top Rated (click Sort by on top of the list). Download and install an app 
by clicking the  icon to the right in the app name row. Once the 
download is done, the message “Download complete. Restart Trados 
Studio to finish installing the plug-ins” is dispalyed above the apps list. 
You need to do that before you can use the plug-ins. 

For some apps, other icons are shown:  
 downloads the installation files sdwithout installing them; the 

reason is that the installation is configurable. After the download, 
click the link “Download complete. Go to your AppStore 
Downloads folder and launch the app” on top of the app column.  

 redirects you to the AppStore web page, because the app is not 
hosted by RWS and requires separate installation. Some of them will 
be listed on the Windows Start menu under Trados Studio 2021 
Apps, others will have their own menu entries. Those that you plan 
to use often may merit their own shortcuts on the Desktop. 
Note that in both these cases, the app list in the AppStore window 
is not updated to Installed status. 

These plug-ins, too, require a restart of Studio to be activated. And the 
more plugins you have, the longer it will take to start Studio. 

The Settings option opens this useful pane, with a number of self-
explanatory options: 
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26 The Editor view 

Terminology 
There is some confusion regarding the terminology in the Editor view 
in Studio. This is what I try to stick to: 
 A segment is either a source string or a target (translated) string. The 

short form is simply “source" and “target”. 
 A row is what you work with in the Editor pane, consisting of a 

source segment, its corresponding target segment, a row number, 
status indicator, and a structure designation; see p. 205. (Hence the 
term often used for numbering, “segment number”, really ought to 
be called “row number”.) 

 A translation unit (TU) is the combination of source segment, target 
segment and all associated information, such as field data. TUs occur 
only in translation memories. 

 

Overview: The Editor view 

Ribbons 

In the Editor view, there are four specific ribbons: Home, Review, 
Advanced, and View:  
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Description 

This is a typical example of the Editor view. 

Navigation pane Home rib-
bon 

 Editor pane Function-specific panes Tabs for 
other panes  
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The left-hand function-specific pane by default shows the Translation 
Results, i.e. the results of the automatic lookup in the TM(s); see p. 
248. Note that the same pane can also show the results of the Concord-
ance Search (p. 257), any Comments (p. 326), and Messages (p. 337). 
Use the tabs at the bottom of the pane. Like the in the “old” Trados, 
the Concordance pane is updated with possible hits in the TM when a 
new source segment is opened. The Translation Results pane shows not 
only the best TM hit (if any), but also all other hits above the threshold 
(see p. 254) you have set. It may be a good idea to move either of those 
panes in order to make it bigger; see below. 

The right-hand function-specific pane by default shows the Term 
Recognition, i.e. the results of lookups – automatic or manual – in the 
termbase(s). The same pane can also show the Termbase Search facility 
(p. 273). 

Note: Many Studio users testify to the fact that Find & Replace as 
well as Auto-propagation in big files works much faster if the term 
recognition is turned off. In the Term Recognition pane, click the 

Project Termbase Settings icon  and uncheck the Enabled box(es) 
in the Project Settings dialog box that opens. 

You can switch between the panes and the open documents with 
Ctrl+Tab and Ctrl+Shift+Tab, which opens this window (with the first 
command you step downwards in the window, with the second up-
wards): 

 

Note: A much easier method for switching between these particular 
panes (which you probably need to do all the time) is to assign 
shortcuts to the panes (for how to do that, see p. 44). In the Editor 
shortcut list there are shortcut options for these panes: 
 Translation Results 
 Fragment Matches 
 Term Recognition 
 Termbase Search 
 Concordance Search 
 TQAs 

To get back to the active segment in the Editor, press Ctrl+O. For 
more on this, read here in the Release Notes. 

And with HotKey (p. 323), you can construct a script to jump to 
the Concordance window, move the cursor to the target segment, 

https://docs.sdl.com/813470/802733/sdl-trados-studio-2021-sr1/extended-keyboard-support-in-the-editor-view
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copy the whole segment and paste it in the active target segment – 
all in a single shortcut. 

You may want to shuffle the panes around (see p. 41). For one thing, 
it may be practical to have the Concordance Search pane open all the 
time, if you have the space for it (a big screen, or two screens). In fact, 
if you have the space you may find it practical to move also the Trans-
lation Results pane and the Term Recognition pane, thus freeing a lot 
of space in the Studio window for viewing the source and target docu-
ments. (It is easy to change back.) If you need more space, you can also 
minimize the navigation pane. 

You can expand the Editor pane to the whole screen – with the other 
panes represented by tabs – using F11. To go back, press F11 again. 

With the Windows key together with the arrow keys, you can cycle 
the Studio window through different positions/sizes on your screen(s). 
(This takes a bit of experimentation.) 

On the far right is the Preview tab (see p. 356). 

Note: When you close the last file which is open in the Editor view, 
that view closes and you return to the Files view. 

At the bottom right is the status bar, where you can see 

- the active display filter (see p. 227); here: All segments 
- writing mode: INSert or OVR (overwrite); as usual you select this 

with the Insert key 
- the last expression (if any) searched for in the filtering function; 

here: “rights” 
- the percentage of non-translated words (or characters, or seg-

ments; see below) 
- the percentage of draft translations (words, characters, or seg-

ments; see below) 
- the percentage of confirmed translations (words, characters, or 

segments; see below) 
- the number of characters in the target segment (sorry – no corre-

sponding function for the source segment) 
- accumulated penalty points compared to the number of penalty 

points allowed in the Translation Quality Assessment (TQA) con-
figuration (see p. 336) 

- source and target languages  (by pointing to them, you will see 
the complete language name, i.e. including language variant). 

The measurement of the amount of non-translated/translated text can 
be customized: Double-click either and the Display Settings dialog box 
opens: 

 
 Display Units are: Words, Characters or Segments. 
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27 Segment handling 

Segment navigation and manipulation 
You can quickly get access to many commands for segment handling by 
right-clicking in the segment. This gives you the following options 
(note also the shortcuts). Which options are available depends on the 
situation. 
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The basic editing functions familiar from Word and other Office pro-
grams have the same shortcuts in Studio; e.g. Cut/Copy/Paste, cursor 
movement, select/delete a word, change case: Shift+F3 [SDLX: Ctrl+F11] for 
toggling between: all minor case, capitalization of first character, all cap-
itals – you can also go to Advanced > Formatting > , which opens this 
pane: 

 
Also select text until end of paragraph/segment (use Ctrl+Shift+Down), 
select text until beginning of paragraph/segment (use Ctrl+Shift+Up), etc. 
See also the Edit menu and the shortcut lists in Annex A and Annex B. 

Note: The default paste function means that if you paste a word 
which does not include leading and/or trailing spaces, you have to 
add those by hand as required. As of SR1, however, there is a func-
tion for “smart” cut and paste which provides automatic adjustment 
of that: Go to File > Options >Editor and select Smart cut and paste. 

As for Cut/Copy/Paste: If you prefer the alternative standard shortcuts us-
ing the Ctrl and Shift keys, you will discover that – inexplicably – it is not 
possible to assign the Shift+Insert combination (used for Paste). There is a 
solution, however; see my blog post Ctrl/Shift shortcuts for cut, copy and 
paste at tradosstudiomanual.com. 

 Copy source to target: Press Ctrl+Insert or Alt+Ins [SDLX: F4]. Any text 
in the target segment will be overwritten. 

 Copy all sources to targets: Press Alt+Shift+Insert [SDLX: Shift+F4]. 
Only empty target segments are affected. Note that you can elect to 
have this done every time you open a document for the first time. Go 
to File > Options > Editor. In the right-hand pane, there is this option: 

 

This option should be used with care, however. For instance, if you are 
translating a WorldServer (p. 56) document which contains already 
translated segments, this option will overwrite those segments with the 
corresponding source content. 

 Clear the target segment: Press Alt+Del. 
 Clear all target segments: Select all segments (see below) and press 

Alt+Del. 
 Clear draft segments: Press Alt+Shift+Del. 
 Toggle between source and target: Press F6. 

 Delete to end of row: Press Ctrl+D. 

http://tradosstudiomanual.com/?p=305
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Confirm a 
translation 
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 Delete to next tag: Press Ctrl+Shift+D. 

 Lock segment: One segment: Press Ctrl+L. A locked segment cannot 
be changed in any way. (The same command unlocks a locked seg-
ment.) Several segments: Select them – see below – and press Ctrl+L. 
They all get the same locked/unlocked status, determined by the last 
selected segment: if it is unlocked, all selected segments will be locked, 
and vice versa. This is regardless of whatever status the individual seg-
ments have. 

 Manipulate text as in MS Word: There are some Microsoft Word 
functions, such as highlighting, automatic correction of TWo initial 
capitals, Word-style Autotext, which you may miss. These and a few 
other helpful functions are included in the AppStore application Word-
bird (although unfortunately any highlighting of text is not carried over 
into the final target translation version, and in the bilingual export for 
review it is visible only as highlighting tags). After installation, its Set-
tings and Help icons are found on the Add-Ins ribbon. (For highlighting 
text you can also use the QuickInsert function Apply Highlight Color; see 
p. 284.) 

However, when it comes to highlighting there is now a powerful 

AppStore plugin called Wordlight. Its icon  is found on the Home 
tab, and with it, you can: 

- Select from 15 colours (the same as in Microsoft Word). 
- Highlight selected text with 1 click or a single keyboard shortcut. 
- Change the colour in 2 clicks. 
- Highlight in any filetype, not just the ones supported by Quick 

Insert. 
A highlighting is removed with Ctrl+Space. And if the source document 
is a Word or PDF file, your target file will retain and display the high-
lights. There are user instructions in the corresponding wiki entry (but 
strangely, those instructions do not mention the fact that you also get 
the option Highlight Word if you right-click a selection). And in Paul Fil-
kin’s blog post The Story of “Studio” Colours you will find useful in-
formation on the use of QuickInsert for this, as well as more facts about 
this plugin and information on the new highlighting functionalities of 
the powerful Advanced Display Filter 2.0 (which is now included in 
Studio and not a plugin, as Paul says). 

A translated segment is confirmed when you finalize it with Ctrl+Enter 
[Trados: Alt+(num)+]. The translation unit is then entered into the TM 
and the next unconfirmed segment is activated. (All locked segments are 
ignored regardless of translation source.) The confirmed status is indi-

cated in the status column by the  symbol, but the match percentage 
indication remains what it was. (If you go to next row by simply press-
ing the down arrow key, the translation will remain unconfirmed and 
nothing will be entered into the TM.) 

Sometimes you need to confirm the translation and just go to the 
next segment. If so, press Ctrl+Alt+Enter. (It may happen that the ribbon 
shortcut letters and digits are activated, which may cause problems. 

https://appstore.sdl.com/language/app/wordbird/890/
https://appstore.sdl.com/language/app/wordbird/890/
https://appstore.sdl.com/language/app/wordlight/1026/
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/5091/wordlight
https://multifarious.filkin.com/2019/10/05/the-story-of-studio-colours/
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28 Advanced manipulation 
of files and segments 
 

This is a catch-all chapter for some AppStore applications which allows 
you to do useful things with files and segments but which are difficult 
to fit into the structure of this manual. 

Xliff Previewer 
The freeware application Xliff Previewer is related to the Bilingual 
Searcher (see previous page), and it is not primarily a find & replace 
application; its main purpose is quickly to let you preview an .xliff, 
.sdlxliff, .mxliff, .ttx or .tmx file – just right-click the file name in your 
file organizer and select Preview with Xliff Previewer. This is what the re-
sult may look like: 

 

However, you can also perform searches in the result by filling in the 
search field and selecting S (In source), T (In target), or R (Use regular 
expressions) and pressing  (Apply). (  stands for Show only 
comments, and  stands for Clear.) 
 

28 
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Integrated Segment Actions 
Integrated Segment Actions is an AppStore plugin which is accessed 
from the Project or Files view – select one or more projects or files, 
right-click and select Segment Actions. This window opens: 

https://appstore.sdl.com/language/app/integrated-segment-actions/530/#99550
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31 Recognized tokens 

“Recognized tokens” (including tags); special 
characters; whitespace characters 

A recognized token – previously called “placeable” (in the Help texts 
they are sometimes still called that, and also “recognizers”) – is “a short 
piece of text, enclosed in a segment, that a TM treats as a single word 
because it is a defined format”. The following are simply inserted into 
the target segment just as they are, provided you have enabled the cor-
responding auto-substitution; see p. 294: 

• Inline tags 

• Acronyms 

• URLs 

• Alphanumeric strings 

• Variables 

Alphanumeric strings are any strings made up of combinations of let-
ters, number, underscores, dashes, and full stops; e.g. NAME_4001a. They 
must not start or end with underscores, dashes or full stops, must not 
contain both dashes and full stops, and must contain at least one num-
ber and one letter. But you can handle also those alphanumeric strings 
which do not follow these rules by using the AppStore plugin Regex 
Match AutoSuggest Provider; see p. 308. 

Note 1: The recognition of alphanumeric strings is activated by de-
fault. You can deactivate it in the Project Settings window under Language 
Pairs > [the language pair in question] > Translation Memory and Automated 
Translation > Auto-substitution and check Alphanumeric strings.  

Note 2: For existing TMs you need first to enable the corresponding 
setting. In the Translation Memories view, select the TM in question 
and press Alt, H, G (or go to Home > Tasks > Settings, or right-click the 
TM name and select Settings). In the Translation Memory Settings win-
dows which opens, select, in the right-hand pane, the Alphanumeric 
strings option. After that, you need to re-index the TM: In the same 
Settings window, select (in the left-hand pane) Performance and 
Tuning and click the Re-index Translation Memory button. (However, 
if you have many TMs where this needs to be done, it can take some 
time. For this reason, the RWS Community Developers have pro-
vided the very practical AppStore application TM Lifting, which sits 
on your desktop. You simply drag the files to be reindexed into the 
top half of its interface window and press the Re-index button. 

31 

http://translator-banks.blogspot.se/2014/11/regex-match-autosuggest-provider-plug.html
http://translator-banks.blogspot.se/2014/11/regex-match-autosuggest-provider-plug.html
https://appstore.sdl.com/language/app/reindex-tms/419/#85626
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(Instead of dragging the files, you can load all TMs which are open 
in the Translation Memories pane in the Translation Memories view; 
to do that you just select the Load Studio TMs checkbox at the bottom 
of the window.) In the bottom half you can follow the progress. 

Before starting the reindexing, you should close Studio, since the 
changes to the TMs are normally not effected until upon restart. 

For more instructions, see the wiki entry. 

You can read more about this feature in Paul Filkin’s blog post The 
future is bright… it’s not Java!, under the heading “Automatic recogni-
tion of Alphanumeric characters”. 

Some may be easily “transformed” (localized) to the target segment 
according to specific rules. They are indicated either by being coloured 

 or by a blue square-bracket underline . They, too re-
quire enabling of auto-substitution (p. 294) and are as follows: 

• Dates 

• Times 

• Numbers (in numerals) 

• Measurements 

As for the localization of the tokens, again see p. 294. 

Tags (containing information about formatting, structuring and place-
holding) are a special case of recognized tokens in that they are not part 
of the textual content. They are shown as coloured fields and their han-
dling is described on p. 287. 

Inserting recognized tokens 

There are several ways to insert recognized tokens (always at the place 
of the cursor in the target segment): 
 Keyboard: Press Ctrl+[comma] or Ctrl+Alt+DownArrow. (Note that the 

last combination – as well as the one for stepping between tokens; 
see below – may result instead in changing the screen. If so, you need 
to deactivate the Windows hotkeys: right-click anywhere on the 
screen, select Graphic options [or the corresponding option in your 
language] > Hot Keys [or Shortcuts] > Disable.) A QuickPlace list of the 
“candidates” in the source segment opens.  

 
Note that for every option that you go to – with DownArrow – the 
affected text in the source segment will be highlighted. Select the 
required option and insert it by pressing Return or tab. 

By pressing Ctrl+Alt+RightArrow/LeftArrow, you step between the 
recognized tokens (but not the numbers) in the source segment, for-
wards or backwards; each token is highlighted in turn. When you 

https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/3268/tm-lifting
http://multifarious.filkin.com/2014/11/18/the-future-is-bright-its-not-java/
http://multifarious.filkin.com/2014/11/18/the-future-is-bright-its-not-java/
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32 Automatic handling of 
certain types of  
expressions –  
Auto-substitution and 
Auto-localization 

There are certain types of expressions which are preferably handled 
automatically, in particular in cases where they occur often. Examples: 
trade names (do not translate The Guardian but translate “the guard-
ian”), acronyms (do not translate), numbers (decimal separators!), dates 
(the many different formats are a well-known problem), measurement 
units and currency names and symbols (where to place them and what 
separators to use, if any). 

These matters are handled in Studio by Auto-substitution and Auto-
localization. The former means that when studio recognises a TU in a 
TM which is identical to the source segment in question except for an 
expression of a type mentioned above, Studio will use that TU but sub-
stitute the source expression for the one in the TU. In certain cases (e.g. 
acronyms) that expression will be transferred unchanged into the target 
segment, in other cases (e.g. a number) it will be auto-localized into the 
corresponding target language version. 

In principle, this may sound simple. But, to use a Swedish expres-
sion, you may think it is uncomplicated, but wait until I have explained 
it. 

In fact, there are indications in the Help texts of the complexity of 
these matters. They are handled on 16 different pages, and while the 
term for these types of expressions used to be “placeables” they are 
now called “recognized tokens” – and “placeables”, and also “recogniz-
ers”. I shall stick to the first variant (and sometimes just say “tokens”).  

To complicate things further, Studio uses different ways of auto-
localization depending on whether it is a matter of TM matches or not, 
such as when there is no TM match – in which case QuickPlace sugges-
tions are shown – and during machine translation (or, as it is called in 
Studio, Automatic Translation) if the segment only contains the recog-
nizable token and there is no TM match. This is how a QuickPlace 
suggestion could look, based on the corresponding setting in the TM’s 
language resources: 

32 
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The default auto-localization formats that Studio suggests during auto-
substitution are based on the formats available in your TM matches or 
in the Windows regional settings (for more about which, see Under-
standing Regional Settings by Barry Dysert). You may want to change 
or edit these default formats when (in the words of the Help text) 

• your source text contains non-standard formats for numbers, 
dates, times, measurements or currency amounts and Studio can-
not correctly identify them as placeables, 

• the translation units in your TM use incorrect or inconsistent for-
mats for placeables and you do not want to use these for your 
new translations, 

• you do not want to use the default localization formats in Quick-
Place suggestions and Automated Translation results but have 
your own instead. 

You make such changes in the language resources settings (p. 404); the 
context for them will be explained below. 

And as you may have surmised – or indeed already know from ex-
perience – there is a large number of such settings, in several places. 
But in order for anything at all to happen, the corresponding auto-sub-
stitution must be enabled, so we shall start with that. 

Note: If the following explanations are not sufficiently clear (or con-
fusing…), you should read Paul Filkin’s account, Short term memo-
ries. Or visit it anyway. 

Auto-substitution 
You will find the types of expressions available for auto-substitution 
(and thus, with some of them, also for auto-localization) in the Auto-
substitution settings. As usual, where you make the settings depends on 
what level you are aiming at: default or the active project (cf. p. 134). 
Here, there is the additional option of the project template settings. 
Thus: 

• for the default settings for the creation of a project/opening a new 
document (open the Options dialog box: select File > Options or 
Alt/F10, F, T), or 

• for the settings for the active project (open the Project Settings 
dialog box: select Project > Project Settings [or Alt/F10, H, S]), or 

• for the settings for a project template (open the Project Templates 
dialog box – select File > Setup > Project Templates (or Alt/F10, U, P) 
– then select the desired template and click Edit). 

Then select Language Pairs and after that select the TM for the required 
language combination and then Auto-substitution (this option is not 
available for All Language Pairs). 

https://windows.tips.net/T012171_Understanding_Regional_Settings.html
https://windows.tips.net/T012171_Understanding_Regional_Settings.html
https://multifarious.filkin.com/2021/01/07/short-term-memories/
https://multifarious.filkin.com/2021/01/07/short-term-memories/
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33 AutoSuggest 

AutoSuggest is a new function whereby Studio, by detecting the first 
few characters that you type, makes suggestions based on expressions 
in the selected termbases and in specific AutoSuggest dictionaries (p. 
305), and on expressions that you have entered into an AutoText list 
(p. 310) for the target language in question. The symbol to the left of 
the suggestion indicates its source (the picture below illustrates an Au-
toText hit). 

The more characters you type, the more specific the suggestions will 
be. 

 

Make your selection with the Up/DownArrow and press Enter. If you want 
to close the list without using any of the suggestions, press 
Right/LeftArrow. Or just go on typing, ignoring the list. 

An AutoSuggest dictionary contains words and phrases extracted 
from a TM. 

You will find some detailed discussions of AutoSuggest sources – 
including the use of termbases – in Paul Filkin’s blog post The ins and 
outs of AutoSuggest. 

Note: A somewhat similar function is offered by the Autocomple-
tion feature (p. 321). The difference is that not only do you have to 
“plan ahead” for the expressions in question, you also have to re-
member the abbreviations that you have programmed. 

Setting up AutoSuggest 
 Enable AutoSuggest and select “providers” of AutoSuggest en-

tries: Open File > Options (or Alt/F10, F, T) and select AutoSuggest in the 
navigation pane: 
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The provider options Termbases, AutoSuggest Dictionaries and AutoText 
are self-explanatory. The Translation Memory and Automated Translation 
option means you can get matches from TMs, machine translation re-
sources and concordance searches, with these symbols: 

 
This is a new and very useful feature, which is described in detail by 
Nora Díaz in her blog post Studio 2015: AutoSuggest Gets Even better 
(with a video, too). If you want to use it, make sure that the Editor > 
Automation settings (in the File > Options dialog box) has Apply best match 
after successful lookup deselected (it is selected by default); also your 
settings of the minimum match values for TM lookup and concordance 
lookup (p. 253 and 257, respectively) should be set sufficiently low for 
hits to appear. 
As for the settings of which number of suggestions to show and their 
number of characters, you should experiment. But you probably do not 
want a large number of suggestions – which might happen, even if the 
suggestions are based on the source context –, nor will you want very 
short expressions to be suggested. This Help text has some concrete 
suggestions. 

 Hide suggestions which have already been used means “used before in 
the current segment”; i.e. the word/phrase already exists in the cur-
rent target segment. 

 Case sensitive – if you uncheck this, AutoSuggest will not only find 
results regardless of case, it will also adapt the hits accordingly (i.e. 
if the term you start to type starts with a lower-case letter, then the 

http://noradiaz.blogspot.se/2015/06/studio-2015-autosuggest-gets-even-better.html
https://docs.sdl.com/LiveContent/content/it-IT/SDL%20Trados%20Studio%20Help-v4/GUID-E81F738B-8A0C-470F-AF5C-90072E5CF52A
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34 Auto-propagation 

Auto-propagation means that the translation of a segment is copied to 
all other target segments with identical source content in the same doc-
ument. It takes place when you confirm the translation. A target seg-
ment which is translated via auto-propagation will be given this status: 

, and the colour – which does not change if the translation is 
confirmed – indicates the difference from a “normal” 100% match (

). And since auto-propagation does not require a TM, it can be 
used even if no TM is specified. 

Open File > Options (or Alt/F10, F, T). Select Editor in the navigation tree 
and then Auto-Propagation. Make settings as follows (the figure shows 
the default settings): 

 

Explanations: 
 Enable/disable: Under General: Select/unselect the check-box 

Enable Auto-propagation. 
 Matching requirement: Under General: Select a 100% minimum 

match value or lower (hardly advisable). Note that you do not have 
the choice of “context match”, i.e. 101%. 

Note that you can select a specific background colour for autopropa-
gated segments; see p. 208. 
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38 Comments 

In the Editor pane, you can add comments (but only in source seg-
ments) on three levels: the word/phrase level (select it), the segment 
level and the document level (select the document name tag – but there 
is a trick: strangely enough, double-clicking it normally doesn’t work, 
and you have to select it from left to right!). You can add several com-
ments to the same phrase/segment/document, and you can assign a se-
verity level to each comment. You can also extract them – i.e. retain 
them in the target document – for most source document formats (or, 
to be specific, .doc, .docx, .ppt, .pptx, .xls, .xlsx, .rtf, .pdf, .csv, tab delimited 
.txt, and Java Properties files). 

Furthermore, you can handle comments in source files (provided 
they are Microsoft Word 2007-2013 .docx files) in different ways; see 
below. 

This means that if you have a .doc file, you may want to convert it 
into .docx format before you start to work. If you have many such files, 
conversion may be an onerous task. It may then be worth your while 
to take a look at Emma Goldsmith’s blog post entry How to batch con-
vert .doc files to .docx. 

And an excellent run-through of comments handling, including the 
various options for different file types, is given by Paul Filkin in his 
blog post Comments... chapter and verse!. 

 Add a comment: Press Ctrl+Shift+N, or right-click and select Add 
Comment. The Add Comment dialog box opens: 

 

The Scope is Current Selection (if there is one), Current Segment or Current 
File.  

The commented text is highlighted with different colours depending 
on their severity; the default colours are pale yellow for information, 
pale orange for warning, pale red for error. (Like all other colours, they 
can be changed in the Options dialog box.) When a comment is present, 
it will be shown when you point to the segment text. A comment on 
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the document level is indicated by a  symbol in the status column in 
the document title row and will be shown when you point to the target 
title tag. (If you want to comment a particular word, and that word is 
not in the dictionary and therefore marked with the wavy red line, you 
have to use the shortcut; the right-click action does not work.) 

Note: If you add a segment-level comment (Current Segment) in a 
.docx file and that segment contains tags, a subsequent Save as Target 
action may fail. Test it; if it does fail, you can instead make a Current 
Selection comment on the whole segment text. 

 View all comments: Click the Comments tab at the bottom of the 
Translation Results pane, or select View > Information > Comments (or 
Alt/F10, V, M). The Comments pane opens: 

 

By clicking the severity level tabs (Errors, Warnings, etc.), you will be 
shown the comments in the respective level. (Strange things happen 
when you then click the comments themselves, but that is a minor prob-
lem.) 

The severity of the comments are indicated by icons in the first column: 

 Information  

 Warning  

 Error  

 S/T: Source/target, with symbols  and , respectively. 

 Version number: If you make more than one comment on a segment 
or document, they are given version numbers. You can edit or delete 
any version in the Edit Comments dialog box (see below). When you 
click the latest version, it will ”expand” and show all previous versions 
below it; their icons are indented. See the figure above. 

 ID: The ID numbers are given sequentially (with the same ID for all 
versions of a comment).  

 View comments for all open documents: In the Comments pane, 
de-activate the tab Show Comments of Active Document Only. 

 Filter comments depending on whether they are source or target com-
ments: Select as appropriate in the list box to the right: 

 

 Edit a comment: In the Comments pane, or in the document, right-
click in the comment row (in the pane) or the commented segment 
(document) and select Edit comment; or click the Edit comment button 
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48 Producing new TMs 
from translated  
documents: Alignment 

You can “align” the source and the target file of a translation to produce 
a translation memory. The alignment tool was new in Studio 2014 and 
replaces the old Trados WinAlign tool. It produces a set of TUs which 
can then be imported into a new or existing TM for use directly in 
Studio. There is also the option of producing an intermediate file in the 
new .sdlalign format for editing before import into the TM. 

The alignment function supports all file formats which are sup-
ported by Studio. If necessary, you can create new file types as appro-
priate before starting the actual alignment process. And in general, it is 
not necessary that the target and source files have the same formats. 

There are extensive instructions in the Help, of course (available 
also here: Aligning Existing Translated Files). You can align one or sev-
eral file pairs, and you can do it with or without “review” of an inter-
mediate .sdlalign file, i.e. with or without editing the resulting TU:s 
before they are sent to the selected TM. Or you can send them there 
directly, in which case no intermediate .sdlalign file is produced.  

You can also open the alignment result (the .sdlalign file) for (re)ed-
iting at a later time. 

Note: When later you use the aligned TUs during translation, any 
hits in such TUs will have a 1% penalty, so that they will never be 
100%. (This can of course be changed; see p. 255 about the Penalties 
pane.) They will be signified in the Translation Results window with 

a  symbol, and the origin will be given as Automatically Aligned 
(when you point to the Status field). 

There are also other ways to edit the alignment results. After they have 
been imported into a TM, you can edit them there in the Translation 
Memory view. You can also export the .sdlalign file into .sdlxliff format 
and edit that in the usual Editor view. 

If you have a Word document which contains a table with the source 
text in one column and the target text in another (with one row for 
each pair of source and target text), it is of course quite easy to split it 
into two documents and then use the Alignment function. However, 
Roger Sjölander has written a macro which uses the table as it is and 
converts it into a TM file in text format. The macro and more 
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One file pair 

instructions can be found in this Tradosstudiomanual blog post: Creat-
ing a TM file from a Word table with source + target. 

Not surprisingly, Paul Filkin has written a blog post, Working with 
Studio Alignment, about this. It includes a 17 minutes long video tuto-
rial! You should note, however, that while it is generally correct in de-
scribing the basic principles, it is based on an older version of the align-
ment function and therefore is not in agreement with all of the current 
workings. 

A few other tips: Before alignment, open source and target docu-
ments and compare to make sure there are no amendments in the latter 
which will throw the whole thing out of kilt. Remove all images and 
formatting (if you want to be really certain of getting rid of possibly 
disturbing elements, save both files in .txt format). 

Alignment with or without review 
By default every alignment ends with the resulting .sdlalign file being  

 saved with the name of [name of source file]_[name of target 
file].sdlalign (however, sometimes the default name, inexplicably, is 
just [name of source file].sdlalign); you can of course assign another 
name,  

 saved in %UserProfile%/My Document/Studio 2015/Alignment Re-
sults, but you can change that address at the start of the alignment 
process (see below), 

 opened in the Alignment view. 

Note: Each TU generated from the alignment will have three custom 
fields (about fields, see p. 393): Quality, Source File and Target File. 
About Quality, see p. 430. 

Alignment with review 
If you have only one file pair to align, the Align Single File Pair is slightly 
quicker to set up than the alternative Align Multiple Files, which can of 
course be used also for the alignment of a single pair. 

 Align Single File Pair: In any view, press Ctrl+Shift+M (the correspond-
ing button  is found on the Home tab in the Welcome view, the 
Translation Memories view and the Alignment view). The Align 
Documents wizard starts with the Select a translation memory and the 
documents to align dialog box. 

http://tradosstudiomanual.com/?p=555
http://tradosstudiomanual.com/?p=555
http://multifarious.filkin.com/2014/05/21/studio_aligning/
http://multifarious.filkin.com/2014/05/21/studio_aligning/
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49 Translation Units 
maintenance 

The Translation Memories view 

Ribbons 

The Home and View ribbons are – as always – specific (some of the op-
tions are not visible until you have opened a TM):  

 

 

 

Description 

The Translation Memories view is where you edit the TUs stored in 
your TMs; i.e. change texts, formatting, field values, etc. – in fact much 
like you work with the segments when translating; one difference being 
that you can also edit the source segments; another that you also have 
field values to manipulate (if you have defined custom fields). The view 
typically looks like this (as usual, you can customize it by moving any 

pane which has a  symbol in its title list; see p. 41). (Note 
that the Field Values and System Fields pane is not shown 
until you click the vertical Field Values tab far right in the 
view, or the corresponding button: View > Information > 

.) 
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Navigation pane Menus and groups Search Details pane 

 

 
TM side-by-side editor Field Values and System Fields pane 

 Custom Fields (in the Field Values pane) are fields which are not 
standard (system) fields but have been added by a user.  

 System Fields are automatically generated, e.g. creation and modifi-
cation dates (p. 393). 

 Open a TM: Double-click its name in the Navigation pane (or use 
Alt+Shift+O, but then of course you have to locate it in the usual Open 
window). You can have several TMs open, but only one can be active. 
If you have several TMs open, you go between them by clicking the 
tabs on top of the Editor pane. If you have really many open, you can 
use the  symbol in the top right-hand corner; a list of all the open 
TMs is shown. 

If you have a .tmx file that you need to edit, there is now an 
AppStore application, File type definition for TMX, which makes it pos-
sible for you to open it as a translatable file without converting it into 
an .sdltm. 

 Close a TM: As usual, click the × in top right hand corner of the Editor 
pane. If you have made any (pending) changes (see p. 445), you will be 
asked whether to commit them or discard them. 

 Remove a TM: In the navigation pane, right-click the TM to be re-
moved and select Remove From List.  

The side-by-side Editor pane 
TM name tabs Source language segments Target language segments 

https://appstore.sdl.com/language/app/file-type-definition-for-tmx/317/#95840
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TU status Document structure 

(not visible here) 
Custom field val-
ues 

(Note that the document structure and custom field values columns are 
visible only when at least one TU contains such information.) A TM 
will normally take up several pages in the Editor pane. The number of 
TUs per page is set in the box on the Home ribbon (Alt/F10, H, T2) and 
can be up to 1000. The default number is set with File > Options (or 
Alt/F10, F, T), select Translation Memories view and then set the Number 
of translation units per page as necessary. To go between pages, press Alt 
+ Right/Left arrow, or click the Home > Navigation icons. You can also go 
to a specific page in the Page: box (or press Alt/F10, H, Z). 

Some explanations: 

 TU status: 

 
Edited: Some change(s) has been made 

 
To be deleted 

 
Invalid: Some error (e.g. one segment is empty) was detected 
during verification (when the cursor was moved to another 
TU) 

The status is also reflected in the background colours of the TU: 
 White or grey: No pending changes. 
 Yellow: Pending changes. 
 Pink: Marked for deletion. 
 Blue: Currently selected. 

These colours may be customized; see p. 207. 

 Document structure: The same as for segments in the translation ed-
itor pane; see Annex E. 

 Custom field values: Reflects the field values shown in the Custom 
Fields pane (where you make any changes). 

Customizing the Translation Memories view 

You can customize some of the viewing characteristics here. Go to 
Home > Tasks group and select the dialog box launcher in the lower 
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52 MultiTerm 
and termbases 

The use of MultiTerm is integrated in the use of Studio, where you can 
search for, edit and create termbase entries. For more radical termbase 
management – such as advanced searches, and the creation of new 
termbases – you have to start and use MultiTerm itself. Here I will just 
cover the basic uses plus the basic settings and the shortcuts (see An-
nexes N–R). As with Studio, you may find that it pays to study them in 
order to get a view of the functions available. There is an interesting blog 
post by Paul Filkin, Is MultiTerm really that hard to learn? in his multi-
farious blog. And another one, Multitudinous terminology!, where he 
explains the reasons for the complexities of this application. 

MultiTerm 2021 supports termbases created in MultiTerm 6.x to 
2007, and termbases created in MultiTerm 2009, 2011, 2014, 2015, 
and 2017 are completely compatible with MultiTerm 2021 termbases. 

However, it may happen when you open a 2011 termbase that you 
are told that it needs to be reorganised. How to do this is well explained 
by Nora Díaz in her blog post Reorganize your Termbase to Improve 
Term Recognition in Trados Studio. 

An interesting addition to the MultiTerm termbase function is the 
possibility to use simple Excel glossaries (with up to three columns) 
directly in Studio, i.e. accessible via Studios interface. This is possible 
with the AppStore plug-in TermExcelerator; see below on p. 489. 

Note: There is a standalone AppStore application, Tb-Scout, which 
allows you to make searches in various ways – i.a. for duplicate en-
tries – which is not possible in MultiTerm (or in the Studio interface) 
and which may be useful in situations when you need to look up 
relevant termbase entries without opening MultiTerm. See p. 491.  

The basic settings 
The basic settings available via File > Options (or Alt/F10, F, T) are quite 
few and easily illustrated by screenshots: 
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The MultiTerm window 
The ribbons can be customised in the same way as in Studio (see p. 35). 

The Terms view – ribbons 
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53 Language Cloud / 
Trados Live – 
Terminology 

Language Cloud is now Trados Live, although this name change has 
not penetrated all places in Studio/RWS, which is why I shall stick to 
“Language Cloud” (and LC). For the terminology work in Studio, you 
have the possibility of adding dictionaries both to the Language Cloud 
MT service and for use in Studio itself, dictionaries which you can ex-
tend and edit (in the LC site or in Studio) as you like. With the paid 
subscription version, you can also share termbases, which is of course 
an advantage if you co-operate with other translators on a project. All 
this is described in more detail below (including the advantages of hav-
ing dictionaries included here compared to simply opening them in Stu-
dio). 

But why would you use a cloud-based termbase instead of (or in 
addition to) one – or several – in your local computer? There are some 
advantages: 

• If you use the Trados Live Essential online editor for working in 
the cloud, this is the only option for terminology work. 

• If you want to share termbases in real-time, this is the only way 
(but it requires Trados Live Team). 

• In addition, there are some settings for cloud termbases which are 
not available for stationary ones (and vice versa, of course). 

In this section I shall describe the terminology functions of LC, but to 
use them you may need to familiarize yourself with the basics of LC – 
see chapter 54. 

Getting started 
In the Studio Welcome view, click Language Cloud and Trados Live, or in 
any view, click the top right Sign In “button”. You will be asked to log 
in (with your RWS account details). (Once you are logged in, that but-
ton will be replaced by a button with your name.) Then the Sign In 
dialog opens: 
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54 MT basics 

The default options for machine translation (MT) – also called, in the 
SDL documentation, “automated translation” – in Studio are these two: 
 SDL Language Cloud (see p. 537),  
 SDL Machine Translation (Enterprise) (see p. 518),  

But there are a large number of other, optional, resources, and they are 
proliferating as we speak. The main ones are described below. 

And since the Language Cloud is now both a part of the interesting 
new service Trados Live Essential and also offers the basic parts of that 
service for use in Studio, the corresponding information on the latter 
in this manual has been moved to chapters of their own – the termbase 
functions are coveren in chapter 54, and the MT functions in chapter 
57. 

The use of any MT services is recorded in the .sdlxliff bilingual file 
during translation. Segments where MT is used are indicated with the 

 icon in the status column, but you should note that the AT icon 
is also used to indicate a translation based on an existing TU where 
some parts (such as dates) have been auto-substituted (see p. 294). 

And don’t forget: If you use MT, you can set the AutoSuggest func-
tion (p. 302) so that it presents you with any fragment (sub-segment) 
hits it finds in the MT provider’s data; just select the Translation Memory 
and Automated Translation option. 
If you want an almost state-of-the-art description of MT, you can 
hardly do better than reading the book Maschinelle Übersetzung für 
Übersetzungsprofis, edited by Jörg Porsiel; I have written a review of it 
here. Despite its German title, more than half of it is in English, and the 
price is quite reasonable (€37 for 384 pages). Mr Porsiel is also the 
editor of a previous book, Machine Translation – all in English – which 
is still to large extents up-to-date (and reviewed by myself here). 

Furthermore, Paul Filkin, in his multifarious blog, gives a lot of useful 
advice and suggestions about the uses of machine translation in the post 
There’s more than one way to skin a CAT.  

General discussions  
Confidentiality 

The use of an “outside” MT provider – such as Google Cloud Transla-
tion API, MyMemory, Microsoft Translator Text API or similar online 
translation services – may violate the non-disclosure agreement (if any) 
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that you have with your client. However, the privacy declaration that 
they make, and that I refer to in the respective presentation here, may 
be enough for most confidentiality requirements. I have written an ex-
pose on this topic, discussing mainly the confidentiality/privacy of the 
various paid services on offer – see this blog post at the manual’s home 
page. (It may be a bit dated, but I try to update it as necessary.) Fur-
thermore, if you do jobs for countries in the European Union, and they 
contain any kind of personal data, you have to take into account EU’s 
new General Data Protection Regulation, GDPR. (I touch upon this as 
well in the blog post.) 

RWS certifies that they do not make public any material they re-
ceive/send, nor can it be retrieved without their knowledge. As for SDL 
Language Cloud and SDL Machine Translation (Enterprise), no target 
text is ever sent back, and the source text is only held in memory long 
enough for a translation to be provided; then it is discarded. (“SDL 
Language Cloud Machine Translation never stores or shares your 
source material, and translates over a secure, encrypted connection en-
suring complete confidentiality.” (I’d give the source except the SDL 
web site recently was taken over by SDL’s new owner, RWS, and is 
now to a large extent a shambles; the previous source is therefore lost.) 

Regardless of what security is promised by the provider of the ma-
chine translation, it does not change the fact that whatever you send or 
receive via the internet may be compromised during that process. 

One method of improving the confidentiality is to pre-edit the text sent 
for translation, and such a feature is built-in in a few of the MT plugins 
mentioned below. A more comprehensive way of protecting data during 
translation – whether MT is used or not – is offered by the very impressive 
AppStore plugin Trados Data Protection Suite. It contains the plugins pro-
jectAnonymizer (also separately available) and SDLTM Anonymizer. Using 
plain text or regular expressions you can convert sensitive data into tags 
before the translation starts (this is sometimes called “redaction”). During 
and after the translation, those segments thus anonymised are stored in your 
TM. When everything is finalised, you “unprotect” your target files before 
sending them to the client. The respective commands are found on the Batch 
Tasks list, and right-clicking a project gives access to Project Anonymizer 
Help. But don’t miss reading the instructions in the RWS Community wiki. 

Should you feel the need for anonymizing a TM or SDLXLIFF after trans-
lation, there are three AppStore plugins for that: the Trados Batch Anony-
mizer, TM Anonymizer and SDLXLIFF Anonymizer (both from Localix.biz); 
see p. 512. 

The plugin Translation Workflow Automation Package (formerly RyS 
Translation Workflow Automation Package 2018 in the AppStore; the 
presentation there is probably still relevant) – which I haven’t yet tried 
– includes a redaction feature which is said to work with any MT pro-
vider. Because of its many other features (see also pp. 472 and 236), it 
is fairly expensive – $290. And again, note the observation concerning 
user instructions and payment for the RyS plugins (see p. 522). 

This is the settings pane for pre- and post-editing. It may give you some 
idea of the functionalities involved. 

http://tradosstudiomanual.com/?p=1448
https://eugdpr.org/
https://appstore.sdl.com/language/app/sdl-data-protection-suite/936/
https://appstore.sdl.com/language/app/projectanonymizer/895/
https://appstore.sdl.com/language/app/projectanonymizer/895/
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/3199/sdl-project-anonymizer
http://www.rycat.cn/products/refdict.htm
https://appstore.sdl.com/language/app/rys-term-extractor-translation-tweaker-and-batch-search-replace/822/
https://appstore.sdl.com/language/app/rys-term-extractor-translation-tweaker-and-batch-search-replace/822/
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Perhaps surprisingly, this package also seems to contain a function for term 
extraction (in advance of the translation, so that you can prepare a tailor-
made termbase with appropriate translations).  

It may help you to abide by the GDPR requirements if you anonymise the 
TU system field data, such as your name (Created by) and even the Windows 
domain you were logged into when translating the segment. Such anony-
mization functions are offered by the AppStore plugin Trados Batch Anon-
ymizer, which allows you to anonymise usernames and related data, TMs, 
and also the evidence of the use of machine translation, all in one click. You 
can read about it in a wiki entry and in particular in Paul Filkin’s blog post 
Badass…. 

There are other, similar plugins, which however do not allow you to “anon-
ymize” the use of MT. Other than that, I have not compared them in depth. 

TM Anonymizer, which is placed on the View navigation field after installa-
tion. Using the app for one file at a time is free; for multiple files (in 
one go) you need to buy a license. 

 

And from the same developer as TM Anonymizer comes the AppStore 
plugin SDLXLIFF Anonymizer, providing the same service for .sdlxliff 
files: 

 

https://appstore.sdl.com/language/app/sdl-batch-anonymizer/1072/
https://appstore.sdl.com/language/app/sdl-batch-anonymizer/1072/
https://multifarious.filkin.com/2020/04/16/badass/
https://appstore.sdl.com/language/app/tm-anonymizer/898/
https://appstore.sdl.com/language/app/sdlxliff-anonymizer/580/
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55 MT providers 

Below you will first find descriptions of MT providers which are build-
in; of the two only Language Cloud presumably is of any interest to the 
freelance translator since the other one is mainly intended for compa-
nies. 

In addition to the built-in providers there is a very large number of 
providers which are accessed via AppStore plugins – either directly via 
the plugin, or via the plugin as an intermediary. A few of them are 
described in the following; I have selected some which I find reasonably 
priced (note that some are classified as Paid and others as Free; “Free” 
means that the app is free – which is mostly the case also with the  
“paid” apps – but almost always you have to pay for the actual MT 
service), and which are general enough to be useful for most freelanc-
ers. Obviously I have missed many services which fulfil both criteria, 
and I am grateful for any suggestions. 

Connecting to a built-in MT provider  
To connect to a built-in MT provider, you need first to add a connec-
tion to the server in question. 
 For the default project settings: Open the Options dialog box by se-

lecting File > Options (or Alt/F10, F, T). 
 For the settings of the active project/document: Open the Project 

Settings dialog box by selecting Home > Project > Project Settings (or 
Alt/F10, H, S1). 

 For the settings of a project template: Open the Project Template 
Settings dialog box. (Select File > Setup > Project Templates [or Alt/F10, 
F, U, P[. The Project Templates dialog box opens; select the template 
in question and click Edit.) 

In the dialog box that you open, you will add the server either under 
All Language Pairs (in the navigation pane) or under a specific language 
pair (e.g. if you want to use different servers for different language 
pairs). 

Click the Use button  in the right-hand pane and select an op-
tion.  

 SDL Language Cloud: The Language Cloud offers a large number of 
advanced features and hence requires a chapter of its own, chapter 57.  

 SDL Machine Translation (Enterprise): Formerly SDL BeGlobal, 
this is a platform for machine translation. It is a paid resource which re-
quires specific accounts. It is completely secure: no-one else can gain access 

55 
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to your Enterprise resources, and the HTTPS protocol is used for commu-
nication. 

Connecting to MT providers via AppStore plugins 
In addition to the MT providers listed as default options in Studio, there are 
a large number (currently around 50) of plugins in the SDL AppStore which 
provide MT of various types and at various costs (some free of charge). Note 
that you can select to see only those on the AppStore site by selecting the 
category Automated Translation to the left on the page. The following ones 
seem to me to be particularly interesting. Some are MT providers on their 
own; some give value-added access to various such providers. 

For a fairly general and comprehensive list of MT providers (most of 
which are available via AppStore plugins), see the section Third-party MT 
Engines in this Memsource list. 

The providers are presented in alphabetical order. 

 Amazon Translate MT provider: If you can stomach patronizing this 
company, you may find that its translation service actually can be quite 
good. The price is $15 per million characters, but there is a free “tier” of 
2 mn  characters per month for 12 months. It supports 25 languages; see 
the Amazon Translate Features for this and other useful information. For 
information on how to set up an account, start at RWS’s wiki article. (This 
process is a bit complicated; the wiki article references an AWS Documen-
tation page where I found the section Configuring the AWS CLI particu-
larly useful.) As described in the wiki article – see under Other options – 
you can do both pre- and post-lookup find/replace, which can be very use-
ful.  

Note that you can use the Amazon provider also via the Intento 
AppStore plugin (see below) at a slight extra charge; on the other hand 
there is then the option of not having to create an Amazon account, which 
may be an attractive solution if you just want to try out this provider, or 
only use it occasionally. If so, however, you also abstain from the find/re-
place feature mentioned above. 

As for confidentiality, this is what Amazon says: 
“As a customer, you maintain ownership of your content, and you se-

lect which AWS services can process, store, and host your content. We do 
not access or use your content for any purpose without your consent. We 
never use customer content or derive information from it for marketing 
or advertising.” Read more at Data Privacy. 

 DeepL: This is a paid service covering 24 languages (May, 2021), which 
can be combined as you need. (There are some exceptions as to 
source/target language possibilities.) The list of languages included is a 
bit hard to find, but it is here. After the 30 days free trial, it costs, for 
an annual subscription, €5.99 per month (limited to 20 documents per 
month), (€19.99 per month (limited to 20 documents per month) or 
€39.99 per month (100 documents per month). For a purely monthly 
subscription, the corresponding prices are €8.99, €29.99, and €59.99. 
(See this page; scroll down a bit.) It has received much praise from many 
translators. For more information, see the presentation here. The confi-
dentiality conditions are formulated thus: 

“When using DeepL Pro, the texts you submit and their translations 
are never stored, and are used only insofar as it is necessary to create 

https://help.memsource.com/hc/en-us/articles/%20360012620459
https://appstore.sdl.com/language/app/amazon-translate-mt-provider/925/
https://aws.amazon.com/translate/details/
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/3315/amazon-translate-mt-provider
https://aws.amazon.com/compliance/data-privacy-faq/
https://appstore.sdl.com/language/app/deepl-translation-provider/847/
https://support.deepl.com/hc/en-us/articles/360019925219-Languages-included-in-DeepL-Pro
https://www.deepl.com/pro.html
https://www.deepl.com/pro-tool_integration.html
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56 Language Cloud &  
Trados Live –  
Introduction 

 
When you work in the cloud, the SDL/RWS resources are confusingly called 
both Language Cloud (LC) and Trados Live. You can either have whole 
projects which can be handled completely online, with or without the use 
of Studio – i.e. you can switch between the two for one and the same online 
project. This type of work – with SDL Online Editor in combination, or not, 
with Studio – will be covered in a future companion to this manual. A brief 
introduction is given in chapter 56.  

You can also work with “normal” – i.e. local – Studio projects using, 
in addition to your local assets, the machine translation functions and 
dictionaries offered “in the cloud”. The latter features are described in 
detail in chapters 53 and 57. 

The purpose of this chapter is to provide the information necessary 
if you want to use the LC resources for Studio projects; i.e. you don’t 
necessarily want to work with online projects, but you do want to use 
the terminology and machine translation resources that are part of the 
LC/Live Essential package. 

Below is a list showing what you get with the Trados Live Essential 
packages included for free the first year and afterwards for a subscrip-
tion fee or a one-off payment; it is taken from the Trados Live Essential 
presentation page (scroll down a bit).  

There is further information on LC online, in FAQ: Machine Trans-
lation Language Cloud. It’s a bit dated but presumably essentially cor-

rect. (And note that the video tutorial on the Help 
page Using Language Cloud is very much out of 
date.) 

Clearly, the Language Cloud is a very ambitious 
and far-reaching endeavour, intended for a much 
larger user group than just translators, as you used 
to be able to see in this demo video, and which in-
dicates – in the image at left, taken from that video 
– the different parties involved in the Language 
Cloud work. From the results I have seen, the MT 
translation quality is also quite impressive. 
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https://www.sdltrados.com/products/trados-live/essential/#170115
https://www.sdltrados.com/products/trados-live/essential/#170115
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/5498/faq-machine-translation-language-cloud
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/5498/faq-machine-translation-language-cloud
https://www.youtube.com/watch?v=jAmMe6uBenA
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INDEX 
Note that if you have Studio open in front of you, rather than 
using this index it might be better to use Studio’s Tell Me 
feature (p. 13) – the appropriate “hit” there will take you 
directly to the window that you need. 

.autoCorrect files, edit, 322 

.csv and tab delimited text documents 
source file comments in, 329 

.doc to .docx files, batch conversion, 326 

.lng (filetype), 566 

.mtf.xml (file format), 479 

.pdf converter, 382 

.pdf file, deliver .pdf translation as, 383 

.sdlretrofit file, open, 375 
:AdaptiveTM… what’s the score? (blog post), 551, 

552 
:Text to speech proofreading: worth a try! (blog 

post), 365 
…and the winner is? (blog post), 471 
100% match 

definition, 252 
ignore during spell checking, 316 

3 Ways to Keep a Window Always on Top on 
Windows 10 (tip), 235 

A 
 

A business resolution for 2019 (blog post), 21 
A clean editing environment? (blog post), 289 
A Collection of Regular Expressions for the Regex 

Match AutoSuggest Provider (blog post), 309 
A competitive edge (blog post), 566 
A couple of little known gems in SDL Trados Studio 

(blog post), 566 
A file with a view (blog post), 244 
A private AppStore (blog post), 28 
abbreviation list (in Langugage Resources), 404 
About Translation (blog), 22 
accept all tracked changes in document, 379 
accept tracked change 

and go to next, 379 
but do not go to next one, 379 

Access Rights (translation memories), 409 
account information, SDL Trados Live, 541 
acronyms 

definition, 295 
Action (word check in QA Checker), 345 
Actions (Batch Edit Script page), 447 
Actions on segments (in Community Advanced 

Display Filter), 232 
Activate option (for character display during TM 

display), 251 

activate translate to fuzzy, 222 
Active Document Settings 

Languages dialog, 216 
Active segment background color (Editor pane), 207 
Active Spell Checker, 316 
Adapt 

font sizes, 208 
text colors, 208 

adaptive models, manage, 551 
AdaptiveMT, 550 
AdaptiveMT Baseline 

in Analyze Files Report, 173 
AdaptiveMT Engine, create, 552 
AdaptiveMT impact 

in Analyze Files Report), 173 
AdaptiveMT Model, create, 551 
AdaptiveMT Trainer (AppStore plugin), 552 
AdaptiveMT with Learnings 

in Analyze Files Report, 173 
add 

all project files in a folder, 99 
as new translation, 69 
AutoText entries, 309 
comment, 326 
customers, 101 
files to the current project, 126 
files/folders to project, 126 
folders to the current project, 126 
individual project files, 98 
new batch script for TM, 447 
new folder to the project (in Files view), 126 
new target languages to projects, 128 
new translation units (in Translation Memory 

Updates), 162, 268 
project to projects list, 125 
Segmentation Rule window, 405 
server connection (for server-based TMs), 455 
server-based TM, 456 
spell checking dictionary, 318 
target language, 98 
termbase entry, 484 
termbases, 128 
TMs in projects, 127 
translation as duplicate, 222 
translation memory (TMX Import Options), 415 
word check action in QA Checker, 345 

Add alignment metadata, 436 


