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 

2 Help 

There are many ways to get help with the use of Studio. SDL offers a 

large number of different help facilities to the freelance translator. 

Most of them are collected on the Help ribbon, available in all views: 

 

Most of this is self-explanatory (but note that SDL Trados takes you 

to Studio’s homepage, whereas the SDL Home Page is of course exact-

ly that). The Studio Blog gives access to various blog posts related to 

Studio 2019, including Paul Filkin’s invaluable multifarious blog, to 

the posts of which I link in many places in this manual. The SDL 

Community option is described extensively below. 

Overview 

Because of the copious amount of Studio help and support material – 

both SDL generated and third party-generated – that is now available, 

I’ve tried to structure it and arrived at this overview. 

“Internal” Studio material 

 Direct access to Studio settings windows via the Tell me func-

tion 

 The online Help 

 Other directly Studio-related material (such as PDFs and vide-

os): links in the Welcome view, documentation, Useful Tips, 

various video sources 

Material on the SDL sites 

 The Studio Trados site 

 SDL Support 

 SDL Community (in particular a number of discussion forums 

but also a large number of other resources) 

Third party material 

 Discussion groups 

 Blogs 

A very rich overview of the SDL support (although not updated in all 

details) is given by Paul Filkin in a multifarious blog post: SDL suste-

nance. 

2 

http://multifarious.filkin.com/sdl-sustenance/
http://multifarious.filkin.com/sdl-sustenance/
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Direct access 

to Studio  

settings  

windows 

The online 

Help 

“Internal” Studio material 

This direct access to settings windows is often very helpful. It works 

via the Tell me function: Click the Tell me what you want to do tab on 

top in the Studio window, at right (or press Alt+Q): 

 

This pane opens (with default options as shown): 

 

and here is the result when I want to (perhaps) adjust my AutoSuggest 

settings: 

 

Each of these options directly opens a corresponding window for Au-

toSuggest settings. Very handy! 

It is also worth pointing out that if you agree to participate in the 

customer experience program (see p. 17), everything you ask for in 

Tell me will be reported to SDL, so that eventually the requests for 

which there are no hits (not unusual) will be provided with answers. 

 Accessing the Help site: The context-sensitive online Help is 

reached either by  pressing F1 anywhere or the Help button (or F1) in 

the settings windows. There is also a Help option at the bottom of the 

Tell me window shown above. And of course you can also search di-
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3 The SDL AppStore 

 

The SDL AppStore feature is by now such an established and valuable 

resource that it rates its own chapter in this manual even though the 

specific applications are not included in the Studio package. But the 

Software Development Kit (SDK) is, and if you feel like contributing, 

check out the Developer Program section of the AppStore site 

(appstore.sdl.com/developers), where you will find lots of information. 

Basic advice on, and descriptions of, the APIs (Application Pro-

gramming Interface) that are available as part of Studio is given by 

Paul Filkin in his blog post Tinkering with tradition… APIs in Studio 

2015 SR2. In particular, he talks about the APIs used for the AppStore 

plugins Export to Excel (see p. 340) and TermExcelerator (p. 452), 

created in part as demonstration material for interested developers. 

The SDL AppStore homepage (links all over the place in the Studio 

user interface) is where users can offer their own enhancement appli-

cations and, of course, download them. Perhaps because of its con-

tent-heaviness, its structure is not totally self-evident, so I have writ-

ten a brief introduction: The AppStore at SDL which may be helpful. 

In any case, don’t forget to read any reviews that may be posted, since 

they often provide interesting information. 

And now it’s even possible to be alerted to updates of the AppStore 

via Twitter or your web browser; see Paul Filkin’s blog post App No-

tifications. 

In addition, there is a special section in the SDL Community for 

discussing the AppStore applications called, of course, SDL AppStore Ap-

plications. Furthermore, a very useful new resource has been created 

in the form of an SDL AppStore wiki (below). Some of the apps on the 

list (left) link to this wiki in their presentation, others do not, so it 

may be a good idea to check it once in a while. 

3 

https://appstore.sdl.com/language/developers/
http://multifarious.filkin.com/2016/03/02/tinkering-with-tradition-apis-in-studio-2015-sr2/
http://multifarious.filkin.com/2016/03/02/tinkering-with-tradition-apis-in-studio-2015-sr2/
https://appstore.sdl.com/language/developers/
http://tradosstudiomanual.com/?p=1253
https://multifarious.filkin.com/2018/04/02/app-notifications/
https://multifarious.filkin.com/2018/04/02/app-notifications/
https://community.sdl.com/product-groups/translationproductivity/f/160
https://community.sdl.com/product-groups/translationproductivity/f/160
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/1310.sdl-appstore
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If your AppStore applications are developed by SDL, you will find 

them (and some others, too) in the navigation pane of the Welcome 

view. (And under Start > SDL Trados Studio 2019 Apps.) Other AppStore 

applications may end up elsewhere. Those which are really plugged-in 

into the Studio user interface – meaning that they get their own icons 

in a ribbon (p. 28), or in a context menu, or as file type in the project 

settings – can be found in the Plug-ins list on the Add-Ins ribbon as 

well as in the SDL Plugin Management window (see below). Those 

which are not plugged-in are normally placed on the desktop, with 

their own icons. You can simplify their access with the OE application 

Menu Maker (p. 35), with which you can add their names to the list in 

the navigation pane in the Welcome view. Unfortunately, though, the 

correspondence between the “official” names of the apps at the 

AppStore and the names on the Plug-Ins list as well as the names on 

the Plugin Management list is often confusingly bad. 

The Plug-ins list is also the default way of temporarily deactivating 

a plug-in without uninstalling it (but you will need to re-start Studio 

to have the deactivation – or activation, as the case may be – take 

place.) 

A more detailed view of the installed AppStore SDL plugins is giv-

en in the SDL Plugin Management window, which you access in the 

Navigation pane in the Welcome view. It can look like this: 
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5 Keyboard shortcuts 

Keyboard shortcuts are ergonomic and should be used as much as 

possible. And Trados lets you customize the shortcuts.  

There are shortcuts for the following categories: 

 Alignment 

 All Views (shortcuts common to all views) 

 Any TM 

 Bookmarks 

 Editor 

 Editor > QuickInsert Toolbar (which is really the QuickInsert 

group; for formatting and some special characters; see p. 263) 

 Editor > TM Window (for handling search results and TM match-

es) 

 Editor > Track Changes 

 Files (file handling; default state: no shortcuts) 

 Help 

 Language Cloud 

 Project Server 

 Projects 

 Reports 

 Symbols 

 Translation Memories 

 Window 

Note that when you add AppStore plugins, they usually add some 

shortcuts of their own. Furthermore, the shortcuts depend on which 

user profile (p. 84) you are using. There are slight differences be-

tween the default and the SDL Trados profile shortcuts; considerably 

more between the default and the SDLX shortcuts. In this manual, 

those differences are noted wherever they occur; they are also reflect-

ed in the shortcut lists in the annexes. 

Note: It is not possible to have shortcuts for moving to other 

panes or windows. For that you must use Ctrl+Tab and Ctrl+Shift+ 

Tab (see also p. 187). 

 View shortcuts: There are two ways to do this: 

 In the Welcome view, go to Home > Show shortcuts (or Alt/F10, H, H). 

A window opens where you can scroll through all shortcuts (in-

cluding the ones belonging to AppStore plugins), and for each one 

the corresponding icon is shown. You can also print this list. (And 

5 
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you can copy it into Word for easy searching.) Note that the cate-

gories are not in alphabetical order (they are if you use the method 

described next). 

 Open File > Options (or Alt/F10, F, T) and expand Keyboard Shortcuts. 

Note: All shortcuts (or shortcut possibilities) included in your 

AppStore applications are also shown.  

 Change, delete or create a shortcut: Open the shortcut window 

(File > Options (or Alt/F10, F, T) > Keyboard Shortcuts and select the de-

sired category. Locate the action in question and change/delete the ex-

isting key combination or add a new one. If you try to assign a 

shortcut which is already in use, the row will be highlighted in red 

and you will have to try another one. If you point to the red area, you 

will be told to which action that shortcut is assigned. (It is alright to 

use the same shortcut in different categories except for conflicts with 

All Views or conflicts between the three Editor tables.) 

Note 1: The specific shortcuts, using the Alt and F10 keys, for navi-

gation among the commands on the function ribbons (p. 32), are 

not listed in the Keyboard Shortcuts list that you open via Options 

(see above). This means that the combinations Alt/F10 plus the fig-

ures 1–4 and the letters A, D, E, F, H, R, and V, although they can 

be assigned, will not be functional for anything but these defaults. 

Furthermore, the shortcuts Shift+F10 and Ctrl+Shift+F10 are reserved 

for internal use and cannot be assigned. 

Note 2: If you want to have a function handy but for some reason 

have problems with assigning a shortcut, there is also the possibil-

ity of placing its icon at a suitable place on a ribbon using the Rib-

bon Customization feature; see p. 30. 

 Reset shortcuts: Click the Reset to Defaults button. This applies only 

to the category that is open. 

Specifically, the shortcut to close Studio is Alt+F4. 

In Annexes A–R of this manual you will find lists, sorted according to the 

above categories, of all functions to which shortcuts may be (or are) 

assigned, and with the default values given. You should in fact study 

these lists, because you are likely to find functions there that you did 

not even know existed. (Annex G lists all shortcuts already used in All 

views and the Editor view, which means that they are not immediately 

available if you want to create new shortcuts or change existing ones.) 

And if, like me, you prefer the shortcuts Ctrl+Del, Ctrl+Insert and 

Shift+Insert for cutting, copying and pasting, respectively (normally 

available in all Windows-based applications), then that can of course 

be arranged by changing them as described above – except that for no 

known reason it is not possible to assign Shift+Insert. However, Paul 

Filkin figured out how; you can read about it in the Tradosstudio-

manual blog post Ctrl/Shift shortcuts for cut, copy and paste. 

Note: Because of Windows quirkiness, Ctrl+Alt works like AltGr. 

This means that certain Ctrl+Alt combinations will give strange re-

sults if you assign them as shortcuts. Here are some common com-

binations that you should avoid, because (a) such a shortcut will 

result both in the required action and insertion of the correspond-

http://tradosstudiomanual.com/?p=305
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26 The Editor view 

Terminology 

There is some confusion regarding the terminology in the Editor view 

in Studio. This is what I try to stick to: 

 A segment is either a source string or a target (translated) string. 

The short form is simply “source" and “target”. 

 A row is what you work with in the Editor pane, consisting of a 

source segment, its corresponding target segment, a row number, 

status indicator, and a structure designation; see p. 189. (Hence 

the term often used for numbering, “segment number”, really 

ought to be called “row number”.) 

 A translation unit (TU) is the combination of source segment, tar-

get segment and all associated information, such as field data. TUs 

occur only in translation memories. 

 

Overview: The Editor view 

Ribbons 

In the Editor view, there are four specific ribbons: Home, Review, 

Advanced, and View:  

 

 

 

26 
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Description 

This is a typical example of the Editor view. 

Navigation pane Home 
ribbon 

Termbase 
viewer tab 

Editor pane Function-specific panes Preview tab 
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The left-hand function-specific pane by default shows the Translation 

Results, i.e. the results of the automatic lookup in the TM(s); see p. 

228. Note that the same pane can also show the results of the Con-

cordance Search (p. 237), any Comments (p. 302), and Messages 

(p. 313). Use the tabs at the bottom of the pane. Like the in the “old” 

Trados, the Concordance pane is updated with possible hits in the TM 

when a new source segment is opened. The Translation Results pane 

shows not only the best TM hit (if any), but also all other hits above 

the threshold (see p. 234) you have set. It may be a good idea to move 

either of those panes in order to make it bigger; see below. 

The right-hand function-specific pane by default shows the Term 

Recognition, i.e. the results of lookups – automatic or manual – in the 

termbase(s). The same pane can also show the Termbase Search facili-

ty (p. 253). 

Note: Many Studio users testify to the fact that Find & Replace as 

well as Auto-propagation in big files works much faster if the term 

recognition is turned off. In the Term Recognition pane, click the 

Project Termbase Settings icon  and uncheck the Enabled box(es) 

in the Project Settings dialog box that opens. 

You can switch between the panes and the open documents with 

Ctrl+Tab and Ctrl+Shift+Tab, which opens this window (with the first 

command you step downwards in the window, with the second up-

wards): 

 

You may want to shuffle the panes around (see p. 36). For one thing, 

it may be practical to have the Concordance Search pane open all the 

time, if you have the space for it (a big screen, or two screens). In fact, 

if you have the space you may find it practical to move also the Trans-

lation Results pane and the Term Recognition pane, thus freeing a lot 

of space in the Studio window for viewing the source and target doc-

uments. (It is easy to change back.) If you need more space, you can 

also minimize the navigation pane. 

You can expand the Editor pane to the whole screen – with the 

other panes represented by tabs – using F11. To go back, press F11 

again. 

With the Windows key together with the arrow keys, you can cycle 

the Studio window through different positions on your screen(s). 

On the far right is the Preview tab (see p. 332). 

Note: When you close the last file which is open in the Editor 

view, that view closes and you return to the Files view. 
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At the bottom right is the status bar, where you can see 

 

- the active display filter (see p. 207); here: All segments 

- writing mode: INSert or OVR (overwrite); as usual you select 

this with the Insert key 

- the last expression (if any) searched for in the filtering function; 

here: “rights” 

- the percentage of non-translated words (or characters, or seg-

ments; see below) 

- the percentage of draft translations (words, characters, or seg-

ments; see below) 

- the percentage of confirmed translations (words, characters, or 

segments; see below) 

- the number of characters in the target segment (sorry – no cor-

responding function for the source segment) 

- accumulated penalty points compared to the number of penalty 

points allowed in the Translation Quality Assessment (TQA) 

configuration (see p. 312) 

- source and target languages  (by pointing to them, you will see 

the complete language name, i.e. including language variant). 

The measurement of the amount of non-translated/translated text can 

be customized: Double-click either and the Display Settings dialog box 

opens: 

 

 Display Units are: Words, Characters or Segments. 

 Display Values are: Count, Percentage or Both.  

The character count includes recognized tokens but not tags or spaces. 

Customizing the Editor pane 

This is the Editor pane: 

Document window name 
tab 

Source language seg-
ments 

Target language  
segments 

Document navigation 
buttons 

 

Segment (row) num-
bers 

Document name 
tag 

 Segment status column Document structure column 
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27 Segment handling 

Segment navigation and manipulation 

You can quickly get access to many commands for segment handling 

by right-clicking in the segment. This gives you the following options 

(note also the shortcuts).  

 

The basic editing functions familiar from Word and other Office pro-

grams have the same shortcuts in Studio; e.g. Cut/Copy/Paste, cursor 

movement, select/delete a word, change case (Shift+F3 [SDLX: Ctrl+F11] 

for: all minor case, capitalization of first character, all capitals), select 

text until end of paragraph/segment (use Ctrl+Shift+Down), select text 

27 
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Confirm a 

translation 

 

until beginning of paragraph/segment (use Ctrl+Shift+Up), etc. See also 

the Edit menu and the shortcut lists in Annex A and Annex B. 

As for Cut/Copy/Paste: If you prefer the alternative standard shortcuts 

using the Ctrl and Shift keys, you will discover that – inexplicably – it is 

not possible to assign the Shift+Insert combination (used for Paste). There 

is a solution, however; see my blog post Ctrl/Shift shortcuts for cut, copy 

and paste at tradosstudiomanual.com. 

 Copy source to target: Press Ctrl+Insert or Alt+Ins [SDLX: F4]. Any 

text in the target segment will be overwritten. 

 Copy all sources to targets: Press Alt+Shift+Insert [SDLX: Shift+F4]. 

Only empty target segments are affected. Note that you can elect to 

have this done every time you open a document for the first time. Go 

to File > Options > Editor. In the right-hand pane, there is this option: 

 

This option should be used with care, however. For instance, if you 

are translating a WorldServer (p. 465) document which contains al-

ready translated segments, this option will overwrite those segments 

with the corresponding source content. 

 Clear the target segment: Press Alt+Del. 

 Clear all target segments: Select all segments (see below) and press 

Alt+Del. 

 Clear draft segments: Press Alt+Shift+Del. 

 Toggle between source and target: Press F6. 

 Delete to end of row: Press Ctrl+D. 

 Delete to next tag: Press Ctrl+Shift+D. 

 Lock segment: One segment: Press Ctrl+L. A locked segment cannot 

be changed in any way. (The same command unlocks a locked seg-

ment.) Several segments: Select them – see below – and press Ctrl+L. 

They all get the same locked/unlocked status, determined by the last 

selected segment: if it is unlocked, all selected segments will be 

locked, and vice versa. This is regardless of whatever status the indi-

vidual segments have. 

There are some Microsoft Word functions, such as highlighting, au-

tomatic correction of TWo initial capitals, Word-style Autotext, 

which you may miss. These and a few other helpful functions are in-

cluded in the AppStore application Wordbird. After installation, its 

Settings and Help icons are found on the Add-Ins ribbon. 

A translated segment is confirmed when you finalize it with Ctrl+Enter 

[SDL Trados: Alt+(num)+]. The translation unit is then entered into the 

TM and the next unconfirmed segment is activated. (All locked seg-

ments are ignored regardless of translation source.) The confirmed 

status is indicated in the status column by the  symbol, but the 

match percentage indication remains what it was. (If you go to next 

http://tradosstudiomanual.com/?p=305
https://appstore.sdl.com/language/app/wordbird/890/


Segment handling Segment navigation and manipulation  

202 SDL Trados Studio 2019 – THE MANUAL 

 

Confirm  

several  

translations 

row by simply pressing the down arrow key, the translation will re-

main unconfirmed and nothing will be entered into the TM.) 

Sometimes you need to confirm the translation and just go to the 

next segment. If so, press Ctrl+Alt+Enter. (It may happen that the rib-

bon shortcut letters and digits are activated, which may cause prob-

lems. You can avoid that by using AltGr+Enter instead – cf. p. 40 – or 

by pressing either Ctrl or Alt slightly before the other.) 

You can also confirm the translation and stay in the same segment: 

press Ctrl+Alt+Shift+Enter. 

If for some reason you have a segment pair which needs to be 

there but you don’t want to add to your TM (e.g. if the source sen-

tence must remain split in an unattractive way), the obvious action is 

to avoid confirming it. 

You “unconfirm” a translation by right-clicking in the row, select-

ing Change Segment Status and then selecting the appropriate status. 

Note, however, that the corresponding TU in the TM does not 

change even if you apply the status Not translated. 

You can deactivate the TM update upon manual confirmation: Go 

to File > Options (Alt/F10, F, T); select Editor and its Automation option; 

de-select Update translation memory under After Confirming Segments 

Manually. 

You can make a note to yourself that a particular translation needs 

to be checked by leaving the segment with Draft status. 

Sometimes the first activation of a segment in a document results – 

after a long time of searching the TM – in this error message: “An er-

ror has occurred whilst using the translation provider [TM]: The 

translation memory data file engine returned an error: The database 

file is locked. Database is locked.” A possible solution to this problem 

is given in the Tradosstudiomanual blog post Database is locked. 

(Why not here? Because I don’t want to use space on what is after all 

not a common problem.) 

You can use various methods, depending on whether you want to 

confirm some (unconfirmed) translations, all translations from a par-

ticular row until the end of the document, or all translations. There is 

of course also the method of filtering for unconfirmed or draft trans-

lations as described on p. 207 (but see Note 2 below). 

The standard Windows shortcuts for selecting – holding down Ctrl 

while selecting separate items, and holding down Shift while selecting 

the first and last items in a contiguous selection – can always be used 

in Studio even though they are not documented in the Studio help 

(chances are that you will find more such undocumented shortcut 

functions if you play around a bit). 

Note: You should be aware that these “bulk” confirmations only 

changes the status of the segments; no TMs are updated. To up-

date the TM you need to use the batch task Update Main Translation 

Memories or Update Project Translation Memories. To confirm a num-

ber of segments and update the TM at the same time, select text in 

the corresponding (contiguous) target segments (e.g. by pressing 

Ctrl+Shift+DownArrow repeatedly) and then pressing Ctrl+Enter.  

 Confirm more than one translation (see also the Note above): 

! 

http://tradosstudiomanual.com/?p=458
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Add as 

duplicate 

Navigate 

between 

rows 

Translate to 

fuzzy 

1. Select the corresponding row numbers – either by selecting 

them one by one while holding down the Ctrl key, or (if they are 

contiguous) by selecting the first and last one while holding 

down the Shift key. 

2. Right-click in a row number, select Change Segment Status and 

then the appropriate option.  

 Confirm all translations from one row until the end of the document 

(see also the Note above): 

1. Go to the last row (segment) number using the Shift key 

(Ctrl+Shift+ End). 

2. Press Ctrl-Enter. 

 Confirm all translations in one go (see also the Note above): 

1. Go to row (segment) number 1 (Ctrl+Home), then DownArrow. 

2. Go to the last row (segment) number using the Shift key 

(Ctrl+Shift+End). 

3. Press Ctrl-Enter. 

“Translate to fuzzy” is a function well-known to users of the “old” 

Trados. It means that the program steps through each row – including 

confirmed ones (except PerfectMatches) – inserting every 100% tar-

get match until it comes to a non-100% match (a “fuzzy” match, 

which may of course be 0%). If the TM hit is different from an exist-

ing target segment text, the process stops so you can edit if necessary. 

(About types of TM matches, see p. 232.) 

 Confirm and translate until next fuzzy match: Press Ctrl+Alt+F. 

 Stopping the translate to fuzzy process: Press Esc. 

More on this can be found in Paul Filkin’s SDL blog post Studio 2011 

Series: Translate to Fuzzy. 

When you confirm a translation, and there is already a TU with the 

same source text but a different target text, the new translation will 

overwrite the existing one. If instead you want to add the current 

translation as a duplicate of the existing one, press Ctrl+Shift+U [SDL 

Trados: Ctrl+Alt+Up] before you confirm the translation. 

When you place the cursor in a row, it automatically becomes active, 

which is indicated by a light blue-grey colour (which, like all colours, 

may be changed; see p. 190).  

You can disable this “implicit row activation”. Open File > Options 

(or Alt/F10, F, T) and select Editor. In the Side-by-side Editor area you 

will see the option Enable implicit row activation. If this function is disa-

bled, and you want to activate a row by clicking in it, you can manu-

ally activate it with Alt+Home. 

 Navigation commands: 

Go to functions: 

 Beginning of target segment: Press Ctrl+PageUp 

 End of target segment: Press Ctrl+PageDown 

http://blog.sdl.com/company/studio-2011-series-translate-to-fuzzy/
http://blog.sdl.com/company/studio-2011-series-translate-to-fuzzy/
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28 Advanced manipulation 

of files and segments 

 

This is a catch-all chapter for some AppStore applications which al-

lows you to do useful things with files and segments but which are 

difficult to fit into the structure of this manual. 

Xliff Previewer 

The freeware application Xliff Previewer is related to the Bilingual 

Searcher (see previous page), which is not primarily a find & replace 

application; its main purpose is quickly to let you preview an .xliff, 

.sdlxliff, .mxliff, .ttx or .tmx file – just right-click the file name in 

your file organizer and select Preview with Xliff Previewer. This is what 

the result may look like: 

 

However, you can also perform searches in the result by filling in the 

search field and selecting S (In source), T (In target), or R (Use regular 

expressions) and pressing  (Apply). (  stands for Show only 

comments, and  stands for Clear.) 

 

28 

http://translator-banks.blogspot.se/2014/08/xliff-previewer.html
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Integrated Segment Actions 

Integrated Segment Actions is an AppStore plugin which is accessed 

from the Project or Files view – select one or more projects or files, 

right-click and select Segment Actions. A window opens where you can 

select Segments to Perform Actions on (some 20 options) and Actions 

to Perform (change translation status, change lock status, change con-

tent [to Empty or Target same as source]). This application is created 

by the same people as the Toolkit (see below), and I believe it can be 

viewed as a simpler-to-use subset of the latter. 

The SDLXLIFF Toolkit 

The SDLXLIFF Toolkit is an AppStore application created by SDL In-

ternational. As usual, Paul Filkin has lots of information to give in a 

blog post (now updated extensively to cover recent improvements of 

the app: Revisiting the Toolkit). After installation, it is found on the Add-Ins 

tab with its own icon  (although not in the Welcome view). Here is 

my attempt at a brief description (there are no instructions). 

https://appstore.sdl.com/language/app/integrated-segment-actions/530/#99550
https://appstore.sdl.com/language/app/sdlxliff-toolkit/296/
https://multifarious.filkin.com/2017/01/14/revisiting-the-toolkit/
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Status  

selection  

criteria 

Actions The starting point is that you can define segment selection criteria or 

search criteria in many different ways, and then tell the application 

what to do with those segments. What you can do is for example: 

 Change status for a selected group of TUs and/or copy source to 

target for the same group (note that you cannot change transla-

tion status, lock status and copy source to target in one go; but 

it’s quite fast to do these things one after the other (if you need 

to): 

 

You can use this e.g. for locking Master Pages in PowerPoint, for 

marking comments in Word source segments as “translatable” 

(see p. 305), or for exporting segments with comments. 

 Clear all selected target segments. 

 Replace expressions in source or target segments in a group of 

files. 

 Create a new .sdlxliff file consisting of selections from a number 

of files, which you can then use to create a project and translate 

to produce translation units for a TM (useful for instance if 

you’re working together with other translators and want to pro-

vide them with “certified” TUs as a basis for further work). Such 

selection files cannot, however, be used to produce target files – 

but then it’s difficult to see that need. 

There are two particular advantages with this application. One is that 

you don’t need to open the files in Studio (as with SDL Batch Find 

and Replace; p. 216). The other is that the options for selection and 

search criteria are richer than anything you will find in Studio itself. 

Below is a view of all selection criteria on offer: 
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Clear the Con-

cordance  

Search pane 

Edit/delete 

TUs 

pane), and then the desired search will always be performed 

with F3. 

 Insert text from a concordance lookup: Make sure that the cursor is 

placed where you want the text to be inserted. Select, in the con-

cordance window, the text to insert. Press Ctrl+Alt+F3, or right-click 

in the selection and select Insert into document. Note that you can 

switch between the panes, including the concordance pane, with 

the keyboard shortcuts Ctrl+Tab and Ctrl+Shift+Tab (see p. 187). 

 Add new term from a concordance lookup: Select source and target 

terms and click the Add New Term button or the Quick Add New Term 

button (see p. 255 for the differences) on top of the pane (no 

shortcuts, though): 

 

 Search for an expression by typing it: Use the field above the con-

cordance pane. Enter the expression and select to search in the 

source or target text. Jump between occurrences with the arrows. 

 

Note: There are still some peculiarities concerning the con-

cordance lookup. One is its case sensitivity: it seems that an upper-

case word in the TU will be found only if you search for its lower 

case version but will not be found if you search for its (proper) up-

per case version. Another is that a compound expression, where 

the component words are separated by hyphens or slashes, some-

times can only be found if you search for it without the hy-

phens/slashes. 

You edit/delete TUs in the Concordance Search pane in the same was 

as you do in the Translation Results pane; see p. 229. 

You clear the Concordance Search pane by clicking the  button. 

 

upLIFT (fragment recall) 

upLIFT in essence means utilising translation unit fragments (“frag-

ment recall”, also called “subsegment matching”) if no 100% match is 

found. It could be described as an advanced concordance search 

where both the source and corresponding target words/ expressions 

are highlighted, only expressions with contiguous words are presented 

(i.e. no hits where the separate words in an expression are spread all 

over the text), and you can insert the suitable target expression with a 

shortcut. This picture should give a good idea: 
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Note that there are a number of TM preparations needed before you 

can use the upLIFT feature; see below. Also note that the upLIFT 

function includes finding “whole TUs” in the TM(s) which match 

some part of the source segment in question. This whole TU matching 

does not require preparation of the TM(s). 

As you see, upLIFT is somewhat similar to the use of AutoSuggest dic-

tionaries, but with a very important advantage: unlike the AutoSug-

gest dictionaries, the fact that upLIFT is TM-based means that it is 

always updated with the latest translated segment. Other differences is 

to the advantage of AutoSuggest dictionaries: For upLIFT to work, 

the TM must contain at least 1,000 TUs and should preferably con-

tain at least 5,000. In addition, the preparation of a TM for upLIFT 

(see below) can take some time if it is big: for 10,000 TUs it is a mat-

ter of minutes, but for really big TMs you may be better off setting 

aside a night or a weekend. (The computer will of course not be tied 

up during that time, but depending on its resources, it may be slowed 

down.) The good news is that the AppStore plugin Reindex TMs 

makes it possible for you to have several TMs being prepared in one 

go – and you’ll be able to use Studio during the process (even if 

slowed down), which is not the case if you do it using the built-in 

procedure. 

An interesting part of the upLIFT technology is that the fragment 

matching against a TM to be used is reflected in the project analysis 

(the Analyze Files Report; p. 158). This very banal example should 

give you an idea: 

 

And should you want another take on upLIFT than mine, you might 

try Emma Goldsmith’s blog post SDL Trados Studio 2017: fragment 

https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/
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Basic use 
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Suggest 

Activate  

fragment  

search 

recall and repair. For even more in-depth information, read Jesse 

Good’s description of the upLIFT Fragment Recall in his blog post 

Trados Studio 2017 Features and Buyer Guide. There is also a Begin-

ner’s Guide, published by SDL. And as if all that is not enough, Nora 

Dìaz has made a video showing how to use this feature. 

Settings 

For the fragment search to work, you have to make this setting, which 

is not done by default: Select Project settings (on top of the Transla-

tion Results pane or go to Home > Project Settings) and then select Lan-

guage Pairs > All Language Pairs > Search. Look here: 

 

TU fragment is selected by default. Minimum words for a match is ex-

actly that (you may need to experiment so that you do not get too 

many hits, for instance if you have large TMs, or too few); insignifi-

cant words are words like the, or and a (and corresponding words in 

other languages). You can go down to 1 if you want. 

An upLIFT match can consist of a whole or parts of a TU. The symbol 

between source and target indicates which: indicates a whole TU 

match; indicates a fragment match (and both are very obvious 

from the text itself; also any whole TU matches are presented first). 

The easiest way to insert the highligted target text (match) from the 

selected hit is to start typing it – it will then be presented as an 

AutoSuggest option (source indication: ). Alternatively, 

you can insert it with Ctrl+Alt+M. 

 Go to next match: You have to click it; the down arrow does not 

work. 

 Go to another match: Click it. Or, after you have clicked one hit, 

you can navigate between them with the up/down arrow keys. 

 Insert the highlighted terms in the default termbase: Right-click in 

either segment and select as appropriate (see p. 255 about the dif-

ferences): 

 

 Turning off/on the Fragment Matches display: Select File > Options 

and then Editor > Fragment Matches Window. The option Display re-

sults from the Fragment Matches window if the TM lookup returns no re-
sults is selected by default. (The AutoSuggest presentation works 

even if this window is not shown.)  

https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/
http://jessegood.github.io/translation/trados2017.html#uplift-fragment-recall-and-fuzzy-match-repair
https://www.sdl.com/download/uplift-beginners-guide/119129/
https://www.sdl.com/download/uplift-beginners-guide/119129/
https://www.youtube.com/watch?v=d6Pic4t--mM
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31 Recognized tokens 

“Recognized tokens” (including tags); special 

characters; whitespace characters 

A recognized token – previously called “placeable” – is “a short piece 

of text, enclosed in a segment, that a TM treats as a single word be-

cause it is a defined format”. The following are simply inserted into 

the target segment just as they are, provided you have enabled the 

corresponding auto-substitution; see p. 271: 

 Inline tags 

 Acronyms 

 URLs 

 Alphanumeric strings 

 Variables 

Alphanumeric strings are any strings made up of combinations of let-

ters, number, underscores, dashes, and full stops; e.g. NAME_4001a. 

They must not start or end with underscores, dashes or full stops, 

must not contain both dashes and full stops, and must contain at least 

one number and one letter. But you can handle also those alphanu-

meric strings which do not follow these rules by using the AppStore 

plugin Regex Match AutoSuggest Provider; see p. 283. 

Note 1: The recognition of alphanumeric strings is activated by de-

fault. You can deactivate it in the Project Settings window under 

Language Pairs > [the language pair in question] > Translation Memory and 

Automated Translation > Auto-substitution and check Alphanumeric strings.  

Note 2: For existing TMs you need first to enable the correspond-

ing setting. In the Translation Memories view, select the TM in 

question and press Alt, H, G (or go to Home > Tasks > Settings, or 

right-click the TM name and select Settings). In the Translation 

Memory Settings windows which opens, select, in the right-hand 

pane, the Alphanumeric strings option. After that, you need to re-

index the TM: In the same Settings window, select (in the left-

hand pane) Performance and Tuning and click the Re-index Translation 

Memory button. (However, if you have many TMs where this needs 

to be done, it can take some time. For this reason, the SDL Com-

munity Developers have provided the very practical AppStore ap-

plication TM Lifting, which sits on your desktop. You simply drag 

the files to be reindexed into the top half of its interface window 

31 

http://translator-banks.blogspot.se/2014/11/regex-match-autosuggest-provider-plug.html
https://appstore.sdl.com/language/app/reindex-tms/419/#85626
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and press the Re-index button. (Instead of dragging the files, you 

can load all TMs which are open in the Translation Memories pane 

in the Translation Memories view; to do that you just select the 

Load Studio TMs checkbox at the bottom of the window.) In the 

bottom half you can follow the progress. 

Before starting the reindexing, you should close Studio, since 

the changes to the TMs are normally not effected until upon re-

start. 

You can read more about this feature in Paul Filkin’s blog post The fu-

ture is bright… it’s not Java!, under the heading “Automatic recogni-

tion of Alphanumeric characters”. 

Some may be easily “transformed” (localized) to the target segment 

according to specific rules. They are indicated either by being col-

oured  or by a blue square-bracket underline . They, 

too require enabling of auto-substitution (p. 271) and are as follows: 

 Dates 

 Times 

 Numbers (in numerals) 

 Measurements 

As for the localization of the tokens, again see p. 271. 

Tags (containing information about formatting, structuring and place-

holding) are a special case of recognized tokens in that they are not 

part of the textual content. They are shown as coloured fields and 

their handling is described on p. 266. 

Inserting recognized tokens 

There are several ways to insert recognized tokens (always at the place 

of the cursor in the target segment): 

 Keyboard: Press Ctrl+[comma] or Ctrl+Alt+DownArrow. (Note that the 

last combination – as well as the one for stepping between tokens; 

see below – may result instead in changing the screen. If so, you 

need to deactivate the Windows hotkeys: right-click anywhere on 

the screen, select Graphic options [or the corresponding option in 

your language] > Hot Keys [or Shortcuts] > Disable.) A QuickPlace list 

of the “candidates” in the source segment opens.  

 

Note that for every option that you go to – with DownArrow – the 

affected text in the source segment will be highlighted. Select the 

required option and insert it by pressing Return or tab. 

http://multifarious.filkin.com/2014/11/18/the-future-is-bright-its-not-java/
http://multifarious.filkin.com/2014/11/18/the-future-is-bright-its-not-java/
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32 Automatic  

substitution/localization  

of specific expressions 

You can set up Studio to recognize certain types of expressions and 

treat them as recognized tokens (previously called “placeables”); cf. p. 

259. This means that, during translation, 

a. if the source segment is identical to a TU except for tokens, Studio 

will insert the corresponding target segment as a 100% match with 

the target versions of the tokens inserted; or 

b. if no hit in the TM is found for the source segment, you will still 

be able to insert the token in the simplified way using Quick-Insert 

(see p. 263). 

The types of expressions are: 

 Acronyms  

 URLs 

 Variables 

 Inline tags 

 Dates 

 Times 

 Numbers (in numerals) 

 Measurements 

For the first four of these tokens, which means that the suggested tar-

get is the same as the source. 

The last four of them can be automatically localized according to 

the settings for the target language. If you want automatic localization 

to take place during pre-translation or when applying matches from a 

TM, the Auto-Substitution function must also be enabled – which it is 

by default. This is how you disable it: Depending on whether to do 

this in the default settings, the current project or a specific project 

template (see p. 245), select in the respective dialog box the TM in 

question (not under All Language Pairs), then select Auto-Substitution, 

and deselect the appropriate options: 

32 
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Handling of 

numbers,  

acronyms and 

variables 

 

 (De)activate a recognition (by default they are all activated; normal-

ly there is no reason to deactivate them, but it may happen that e.g. 

number expressions do not follow the rules set out by Microsoft in 

their National Language Support (NLS) API Reference, and then nu-

merous of false QA errors may be reported if these settings are ac-

tive): Select the Translation Memory view; right-click the TM in ques-

tion (it does not have to be open) and select Settings; then select Fields 

and Settings and make any necessary adjustments under Recognize: 

 

More on the handling of numbers, acronyms and variables: 

 Numbers are automatically localized according to the settings for 

the target language. (Note that in particular the word “in” can 

cause problems if preceded by a number – it may be interpreted as 

“in.”, i.e. inches. There is probably a way of avoiding this even if I 

haven’t yet figured out how.) This localization only applies to 

“clean” numbers; not expressions such as A150. 

 Acronyms are identified as consisting of an uppercase letter, fol-

lowed by 1–4 more uppercase letters, or by the & character and by 

a single uppercase letter (e.g. “A&B”). An acronym may not con-

tain a full stop. 

 Variables are set by yourself for a specific TM: Select the Transla-

tion Memory view; right-click the TM in question and select 

Settings; then Language Resources. Select at right Variable list and 

click Edit. Add variables as necessary in the dialog box that opens. 

(Go to the end of the list, double-click and type the new variable. 

If you need to edit an entry, double-click it.) Depending on the 

type of document you are translating, this is potentially a quite 

powerful function. 

Punctuation within variables is not allowed. 

The Variable list can also include comments and headings. Those 

must be directly preceded by the hash symbol (#); e.g. #comment. 

An introduction into the theory and usefulness of variables is 

given by Nora Díaz in her blog post Adding Variables to a Studio 

TM to Increase Leverage. 

http://noradiaz.blogspot.se/2014/01/adding-variables-to-studio-tm-to.html
http://noradiaz.blogspot.se/2014/01/adding-variables-to-studio-tm-to.html
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33 AutoSuggest 

AutoSuggest is a new function whereby Studio, by detecting the first 

few characters that you type, makes suggestions based on expressions 

in the selected termbases and in specific AutoSuggest dictionaries (p. 

279), and on expressions that you have entered into an AutoText list 

(p. 285) for the target language in question. The symbol to the left of 

the suggestion indicates its source (the picture below illustrates an Au-

toText hit). 

The more characters you type, the more specific the suggestions 

will be. 

 

Make your selection with the Up/DownArrow and press Enter. If you 

want to close the list without using any of the suggestions, press 

Right/LeftArrow. Or just go on typing, ignoring the list. 

An AutoSuggest dictionary contains words and phrases extracted 

from a TM. 

You will find a detailed discussion of the uses of AutoText and Au-

toSuggest in Paul Filkin’s SDL blog post Studio 2011 Series: Using Auto-

text and AutoSuggest as well as some detailed discussions of AutoSug-

gest providers – including the use of termbases – in his blog post The 

ins and outs of AutoSuggest. 

Note: A somewhat similar function is offered by the Autocomple-

tion feature (p. 296). The difference is that not only do you have 

to “plan ahead” for the expressions in question, you also have to 

remember the abbreviations that you have programmed. 

Setting up AutoSuggest 

 Enable AutoSuggest and select “providers” of AutoSuggest 

entries: Open File > Options (or Alt/F10, F, T) and select AutoSuggest in 

the navigation pane: 

33 

http://blog.sdl.com/company/studio-2011-series-using-auto-text-and-autosuggest/
http://blog.sdl.com/company/studio-2011-series-using-auto-text-and-autosuggest/
http://multifarious.filkin.com/2015/01/01/autosuggest/
http://multifarious.filkin.com/2015/01/01/autosuggest/
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The provider options Termbases, AutoSuggest Dictionaries and AutoText 

are self-explanatory. The Translation Memory and Automated Translation 

option means you can get matches from TMs, machine translation re-

sources and concordance searches, with these symbols: 

 

This is a new and very useful feature, which is described in detail by 

Nora Díaz in her blog post Studio 2015: AutoSuggest Gets Even better 

(with a video, too). If you want to use it, make sure that the Editor > 

Automation settings (in the File > Options dialog box) has Apply best 

match after successful lookup deselected (it is selected by default); also 

your settings of the minimum match values for TM lookup and con-

cordance lookup (p. 233 and 237, respectively) should be set suffi-

ciently low for hits to appear. 

As for the settings of which number of suggestions to show and their 

number of characters, you should experiment. But you probably do 

not want a large number of suggestions – which might happen, even if 

the suggestions are based on the source context –, nor will you want 

very short expressions to be suggested. 

 Hide suggestions which have already been used means “used before in 

the current segment”; i.e. the word/phrase already exists in the 

current target segment. 

 Case sensitive – if you uncheck this, AutoSuggest will not only find 

results regardless of case, it will also adapt the hits accordingly (i.e. 

if the term you start to type starts with a lower-case letter, then the 

hits will do the same regardless of whether they are listed like that 

in the sources). 

http://noradiaz.blogspot.se/2015/06/studio-2015-autosuggest-gets-even-better.html
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Settings 

34 Auto-propagation 

Auto-propagation means that the translation of a segment is copied to 

all other target segments with identical source content in the same 

document. It takes place when you confirm the translation. A target 

segment which is translated via auto-propagation will be given this 

status: , and the colour – which does not change if the transla-

tion is confirmed – indicates the difference from a “normal” 100% 

match ( ). And since auto-propagation does not require a TM, it 

can be used even if no TM is specified. 

Open File > Options (or Alt/F10, F, T). Select Editor in the navigation tree 

and then Auto-Propagation. Make settings as follows (the figure shows 

the default settings): 

 

Explanations: 

 Enable/disable: Under General: Select/unselect the check-box 

Enable Auto-propagation. 

 Matching requirement: Under General: Select a 100% minimum 

match value or lower (hardly advisable). Note that you do not 

have the choice of “context match”, i.e. 101%. 

Note that you can select a specific background colour for autopropa-

gated segments; see p. 191. 

34 
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 Auto-propagate exact matches to confirmed segments: If 

you make a change to a target segment with matching source text 

elsewhere in the document, the change will be propagated also to 

those segments which are already translated and confirmed. In my 

experience, this is a very useful option. 

 Confirm segment after auto-propagating an exact match will 

probably save time. If you have set the matching requirement – see 

above – to less than 100%, any such propagated “lesser matches” 

will not be confirmed. 

 The whole document or only “below” the current segment: 

Select as Starting Position either First segment or Next segment in 

document. (Obviously, you cannot propagate “upwards” only.) 

 Prompt for confirmation: Select whether you want to be warned 

for every segment to which the translation or change is propagated 

(Always), or not at all (Never), or conditionally when the matching 

segment has been translated differently, and/or the matching segment has 

no translation, and/or the matching segment is confirmed. The latter op-

tion is of course available only when auto-propagation to con-

firmed segments has been selected. The warning looks like this: 

 

Note 1: Auto-propagated segments with tags missing from the tar-

get segments will get a ‘missing tag’ penalty. 

Note 2: The Auto-propagation function can sometimes be tricky 

and may give unwanted results with numbers. Discussions in 

TW_users (see p. 20) indicate that some experimenting with the 

settings may be required to get satisfactory results. One particular 

problem is that when a numerical range is given using the en dash 

instead of the “short dash” (often called hyphen-minus), e.g. 350–

500 instead of 350-500 – which is very common in many lan-

guages – the Auto-progagation does not recognise this but auto-

propagates only the first number; also it substitutes the short dash 

for the en dash. 

Note 3: If you use the filtering function (p. 207), it may happen 

that the auto-propagation function does not work properly. There-

fore, it is probably safer not to combine them. 

 

https://groups.yahoo.com/neo/groups/TW_users/info
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37 Autocorrection and  

autocompletion 

Studio 2019 has an AutoCorrect function which works the same as in Mi-

crosoft Word. All its settings are found in File > Options > Editor > Auto-

Correct (the Options window is most easily opened with Alt/F10, F, T): 

 

This is just like in Word except for the “smart quotes”, which means 

that the quotation marks are adjusted to the language in question, so 

that for instance in a German text, you will automatically get  „ . . . “.  

The Exceptions button gives access to these options: 

37 
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 

 

 

And just as in Word, you can use the Replace text as you type function 

to set up shortcuts for longer words or expressions. 

You can export and import settings, which get the extension .auto-

Correct. You cannot import a corresponding Word list (or a Studio 

list into Word) since the formats are different. However, an .auto-

Correct file is editable in some text editors (not NotePad), e.g. Atom 

(https://atom.io), which means that you can export a Word list and 

make it conform with the .autoCorrect format. There is a Word mac-

ro for that, provided courtesy of Spiros Doikas (read more about it at 

http://www.translatum.gr/forum/index.php?topic=399434.0): 

Sub AutocorrectTabsReverse() 

 Dim a As AutoCorrectEntry 

 For Each a In Application.AutoCorrect.Entries 

 Selection.TypeText a.Value & Chr(9) & a.Name & vbCr 

 Next 

End Sub  

Insert the macro in Word as described below (p. 300), select the 

Word target language as desired and run the macro. The resulting list 

is to be pasted in the exported .autoCorrect file below the row 

<AutoCorrectEntries>. Note, however, that this part of the file must not 

contain duplicates or it cannot be imported back into Studio. In prac-

tice, this means that you must replace the whole existing Auto-

CorrectEntries list with the corresponding Word list. The alternate 

solution is to refrain from using the Word list and just edit the origi-

nal AutoCorrectEntries list as appropriate. 

When you export the settings, the resulting file is in .xml format, 

which makes it hard to inspect and edit except as described above. 

Paul Filkin has written a blog post describing how to transform such a 

file into Excel format (for editing) and then transforming it back into 

.xml format for importing again. Read about it here: correcting auto-

correct!. 

https://atom.io/
https://atom.io/
http://www.translatum.gr/forum/index.php?topic=399434.0
https://multifarious.filkin.com/2016/09/20/correcting-autocorrect/
https://multifarious.filkin.com/2016/09/20/correcting-autocorrect/
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44 Bilingual Word files, 

.pdf, .ttx and Excel files  

in Studio 

There are some file “types” which are more common than others and 

the handling of which in Studio is not completely straight-forward. I 

will take a look at .pdf and .ttx files and, most particularly, the handling of 

bilingual Word files – it seems to be quite common that clients want 

to receive an “uncleaned” Word file of the same format as the old 

Trados used to deliver. 

Handling bilingual Word files 

Users of “old” Trados (and also Wordfast, Déjà Vu and some other 

CAT tools) will recognize the bilingual Word file format which is the 

result – directly or indirectly – of translation in those tools. Such a 

document typically looks like this: 

 

I.e. source segments (here: blue) and target segments (green) separ-

ated and enclosed by “Trados tags” (violet). 

The 2009 version of Studio could neither handle nor produce such 

documents, to the chagrin of many users whose clients demanded re-

sults delivered in that format. Workaround processes were soon de-

veloped, but those are no longer needed. You can import a bilingual 

Word document (in .doc format; not in .rtf format) – also complex 

ones, with footnotes and other sub-segments such as index entries – 

directly into Studio, work on it and export it (with Shift+F12 [SDLX: 

Ctrl+Shift+F12] or File > Save Target As [or Alt/F10, F, G]) to the same bi-

lingual format. As for delivering “normal” translations (i.e. where the 

source document is not a bilingual file), see The SDLXLIFF to Legacy 

Converter below. Paul Filkin gives us a general discussion of the han-

dling of bilingual Word documents in his SDL blog post Studio 2011 

Series: The Return of the Bilingual Word File Type. 
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http://blog.sdl.com/company/studio-2011-series-the-return-of-the-bilingual-word-file-type/
http://blog.sdl.com/company/studio-2011-series-the-return-of-the-bilingual-word-file-type/
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Handling .pdf files 

Delivery of a file converted to Word 

While SDL Trados claims that Studio is able to handle .pdf files, the 

result sometimes is less satisfying. The text may be cluttered with so 

many tags that it is impossible to work with. But if you are going to 

use this facility, don’t forget to explore the possibilities to make ap-

propriate file type settings in File Types > PDF in the Options or Project 

Settings dialog box. 

So, the basic rule still stands: If at all possible, do not base the job 

on .pdf files but demand the files in the format on which the .pdf 

conversion was based. 

Still, it should be pointed out that Studio 2015 includes a function 

for converting the .pdf to Word format with in many cases quite satis-

fying results; in particular it handles “scanned” .pdf content, i.e. con-

tent which is in the form of images, not text characters. These are the 

settings available under Options > File Types > PDF > Converter: 

 

The above are the default settings, which usually are the preferable 

ones. 

Of particular interest is the bottom option, IRIS technology. It 

supports 134 languages including several Asian languages, Arabic, 

Hebrew and many others which otherwise are difficult or impossible 

to handle here. Paul Filkin gives an in-depth presentation in his blog 

post Iris Optical Character Recognition. (And when you select this op-

https://multifarious.filkin.com/2017/08/17/iris-ocr/
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47 Handling legacy  

(old format) TMs 

Migrating non-Studio format TMs into Studio 

There are a number of non-Studio format TMs, and the way they can 

be migrated into Studio TM format, and what can be migrated, varies. 

See also the Trados Migration Guide (p. 13) for very detailed infor-

mation. The section designations refer to the subheadings on pp. 

383–391. 

There is an extensive guide for working in legacy workflows, writ-

ten by SDL’s Daniel Brockmann and Paul Filkin: TTX/Bilingual 

DOC(X) Compatibility Guide for SDL Trados 2014 Users.   

Source program Format Method System 
fields 

Custom 
fields 

Segmen-
tation rules 

Language 
resources

1
 

Tags See 
section 

Trados 7.x, 2006 
and 2007 

TMW Upgrade Yes Yes Yes
 2

 
5 

Yes D 

Trados 7.x, 2006 
and 2007 

TMX 1.4b Upgrade Yes Yes
 3

 – 
5 

Yes D 

Trados 7.x, 2006 
and 2007 

TMX 1.4b Import Yes Yes – 
5 

Yes C 

Trados 7.x, 2006 
and 2007 

TXT Upgrade Yes Yes – 
5 

Yes D 

SDLX 2005, 
2006, and 2007 

MDB Upgrade Yes Yes Yes 
6 

Yes D 

SDLX 2005, 
2006, and 2007 

TMX 1.4b Import Yes Yes – 
6 

Yes C 

Other programs TMX 1.4b 
or earlier 

Upgrade Yes Possibly – – Pos-
sibly 

D 

Other programs TMX 1.4b 
or earlier 

Import Yes Possibly – – Pos-
sibly 

C 

Trados Studio SDLXLIFF 
bilingual 

Import – – – – Yes – 

Trados 2007 TTX biling. Import – – – – Yes A 

Trados 2007 DOC biling. Import – – – – – B 

Trados 2007 RTF biling. Import – – – – – B 

SDLX 2007 ITD biling. Import – – – – Yes A 

Trados 2007 INI Import – – Yes – Yes
 4

 E 

Trados 2006 INI Import – – Yes – Yes
 4

 E 
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SDLX 2007 ANL Import – – Yes – – E 

1

 These settings include segmentation rules, abbreviations list, ordinal 

followers list, and variable list; see p. 375 and footnotes below.  

2 

If you migrate the Trados 2007 segmentation rules, they will totally 

replace the Studio ones. 

3

 With some restrictions. 

4

 Formatting. 

5

 Segmentation rules: only Trados 2007. The lists: only if they are user-

defined. 

6

 Only segmentation rules. 

Except for the Word formats (.doc and .rtf), TMs that are based on 

bilingual formats have the added advantage of including context 

match information which makes possible both Context Match and 

Perfect Match analysis (see p. 158), which may make it more advan-

tageous to import such files than to upgrade the corresponding .tmx 

files, if you have the choice. On the other hand, bilingual files do not 

contain custom fields. 

Note 1: As the table shows, .tmx files can be either imported into 

existing Studio TMs, or upgraded into new Studio TMs. In the 

former case, the imported file is not scanned for custom fields, but 

you can choose to import/ignore those. When importing, you may 

also filter out unwanted TUs and define what custom field values 

to apply to the imported TUs (if the target TM contains custom 

fields). During upgrade, custom fields which do not contain any 

values will not be included in the process. 

Note 2: There is an AppStore plug-in for the use of SDLX TMs, 

SDLX Translation Memory Plug-in for SDL Trados Studio. It sup-

ports all three types of SDLX TMs: file-based TMs in .mbd for-

mat; server-based TMs on a Microsoft SQL server; and server-

based TMs in SDL .tms. See also p. 386. 

 

Importing files into an existing Studio TM 

A: Importing .ttx, .itd and .sdlxliff bilingual files 

Supported bilingual formats for import are Trados 2007 .ttx and SDLX 

2007 .itd and Studio .sdlxliff.  

 In the Translation Memories view, right-click the desired TM and se-

lect Import, or select the TM and then File > Import. The Import wizard 

opens with the Import Files page. 

 Depending on whether you are going to import a file or a folder (with 

several TM files), click the Add Files or Add Folder button. Select the 

file(s) to import. The Import – Bilingual Document Import Options page 

opens: 

http://www.translationzone.com/en/openexchange/
https://appstore.sdl.com/language/app/sdlx-translation-memory-plug-in-for-sdl-trados-studio/28/#86247
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 Select confirmation (i.e. status) levels for the TUs to be imported. 

(Draft corresponds to Fuzzy Match or Machine Translated in .ttx; 

Translated corresponds to 100% Match or Manually translated in .ttx 

and Confirmed in ITD; Translation approved corresponds to Context 

Match and PerfectMatch in .ttx and Unconfirmed in ITD.) The other 

options pertain to the review process; see p. 348. Click Next. The 

General Import Options page opens. 

 

 Apply Field Values permits specification of which custom field values 

(p. 373) shall be assigned to the imported TUs, if the importing TM 

has such fields (the bilingual files do not). 

The other options are self-explanatory.  Here it is important to 

consider whether to import TUs as plain text, in which case all tags 

(including formatting) – which may not be relevant – are ignored. If 

several target languages are included in the source material, you may 

also wish to exclude some of them. 
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48 Producing new TMs 

from translated  

documents: Alignment 

You can “align” the source and the target file of a translation to pro-

duce a translation memory. The alignment tool was new in Studio 

2014 and replaces the old Trados WinAlign tool. It produces a set of 

TUs which can then be imported into a new or existing TM for use 

directly in Studio. There is also the option of producing an inter-

mediate file in the new .sdlalign format for editing before import into 

the TM. 

Note: You still have access to WinAlign here: C:\Program files 

(x86)\Common Files\SDL\T2007\TT\Winalign.exe. And WinAlign 

has its own Help functions. 

The alignment function supports all file formats which are supported 

by Studio. If necessary, you can create new file types as appropriate 

before starting the actual alignment process. And in general, it is not 

necessary that the target and source files have the same formats. 

There are extensive instructions in the Help, of course (available 

also here: Aligning Existing Translated Files). You can align one or 

several file pairs, and you can do it with or without “review” of an in-

termediate .sdlalign file, i.e. with or without editing the resulting TU:s 

before they are sent to the selected TM. Or you can send them there 

directly, in which case no intermediate .sdlalign file is produced.  

You can also open the alignment result (the .sdlalign file) for 

(re)editing at a later time. 

Note: When later you use the aligned TUs during translation, any 

hits in such TUs will have a 1% penalty, so that they will never be 

100%. (This can of course be changed; see p. 235 about the 

Penalties pane.) They will be signified in the Translation Results 

window with a  symbol, and the origin will be given as Auto-

matically Aligned (when you point to the Status field). 

There are also other ways to edit the alignment results. After they 

have been imported into a TM, you can edit them there in the Trans-

lation Memory view. You can also export the .sdlalign file into 

.sdlxliff format and edit that in the usual Editor view. 

If you have a Word document which contains a table with the 

source text in one column and the target text in another (with one 
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One file pair 

row for each pair of source and target text), it is of course quite easy 

to split it into two documents and then use the Alignment function. 

However, Roger Sjölander has written a macro which uses the table as 

it is and converts it into a TM file in text format. The macro and 

more instructions can be found in this Tradosstudiomanual blog post: 

Creating a TM file from a Word table with source + target. 

Not surprisingly, Paul Filkin has written a blog post, Working with 

Studio Alignment, about this. It includes a 17 minutes long video tu-

torial! 

A few other tips: Before alignment, open source and target docu-

ments and compare to make sure there are no amendments in the lat-

ter which will throw the whole thing out of kilt. Remove all images 

and formatting (if you want to be really certain of getting rid of pos-

sibly disturbing elements, save both files in .txt format). 

Alignment with or without review 

By default every alignment ends with the resulting .sdlalign file being  

 saved with the name of [name of source file]_[name of target 

file].sdlalign (however, sometimes the default name, inexplicably, is 

just [name of source file].sdlalign); you can of course assign another 

name,  

 saved in %UserProfile%/My Document/Studio 2015/Alignment Re-

sults, but you can change that address at the start of the alignment 

process (see below), 

 opened in the Alignment view. 

Alignment with review 

If you have only one file pair to align, the Align Single File Pair is slightly 

quicker to set up than the alternative Align Multiple Files, which can of 

course be used also for the alignment of a single pair. 

 Align Single File Pair: In any view, press Ctrl+Shift+M (the corre-

sponding button is found on the Home tab in the Welcome view, the 

Translation Memories view and the Alignment view). The Align 

Documents wizard starts with the Select a translation memory and the 

documents to align dialog box. 

http://tradosstudiomanual.com/?p=555
http://multifarious.filkin.com/2014/05/21/studio_aligning/
http://multifarious.filkin.com/2014/05/21/studio_aligning/
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49 Translation Units 

maintenance 

The Translation Memories view 

Ribbons 

The Home and View ribbons are – as always – specific (some of the op-

tions are not visible until you have opened a TM):  

 

 

 

Description 

The Translation Memories view is where you edit the TUs stored in 

your TMs; i.e. change texts, formatting, field values, etc. – in fact 

much like you work with the segments when translating; one differ-

ence being that you can also edit the source segments; another that 

you also have field values to manipulate (if you have defined custom 

fields). The view typically looks like this (as usual, you can customize 

it by moving any pane which has a  symbol in its title 

list; see p. 36). (Note that the Field Values and System 

Fields pane is not shown until  you click the vertical Field 

Values tab far right in the view.) 
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Navigation pane Menus and groups Search Details pane 

 

 

TM side-by-side editor Field Values and System Fields pane 

 Custom Fields (in the Field Values pane) are fields which are not 

standard (system) fields but have been added by a user.  

 System Fields are automatically generated, e.g. creation and modifi-

cation dates (p. 365). 

 Open a TM: Double-click its name in the Navigation pane (or use 

Alt+Shift+O, but then of course you have to locate it in the usual Open 

window). You can have several TMs open, but only one can be active. 

If you have several TMs open, you go between them by clicking the 

tabs on top of the Editor pane. If you have really many open, you can 

use the  symbol in the top right-hand corner; a list of all the open 

TMs is shown. 

If you have a .tmx file that you need to edit, there is now an 

AppStore application, File type definition for TMX, which makes it 

possible for you to open it as a translatable file without converting it 

into an .sdltm. 

 Close a TM: As usual, click the × in top right hand corner of the Edi-

tor pane. If you have made any (pending) changes (see p. 412), you 

will be asked whether to commit them or discard them. 

 Remove a TM: In the navigation pane, right-click the TM to be re-

moved and select Remove From List.  

 

 

https://appstore.sdl.com/language/app/file-type-definition-for-tmx/317/#95840
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The side-by-side Editor pane 

TM name tabs Source language segments Target language segments 

  

TU status Document structure 
(not visible here) 

Custom field 
values 

(Note that the document structure and custom field values columns 

are visible only when at least one TU contains such information.) A 

TM will normally take up several pages in the Editor pane. The num-

ber of TUs per page is set in the box on the Home ribbon (Alt/F10, H, 

T2) and can be up to 1000. The default number is set with File > 

Options (or Alt/F10, F, T), select Translation Memories view and then set 

the Number of translation units per page as necessary. To go between 

pages, press Alt + Right/Left arrow, or click the Home > Navigation icons. 

You can also go to a specific page in the Page: box (or press Alt/F10, H, 

Z). 

Some explanations: 

 TU status: 

 

Edited: Some change(s) has been made 

 

To be deleted 

 

Invalid: Some error (e.g. one segment is empty) was detected 

during verification (when the cursor was moved to another 

TU) 

The status is also reflected in the background colours of the TU: 

 White or gray: No pending changes. 

 Yellow: Pending changes. 

 Pink: Marked for deletion. 

 Blue: Currently selected. 

These colours may be customized; see p. 190. 

 Document structure: The same as for segments in the translation 

editor pane; see Annex E. 

 Custom field values: Reflects the field values shown in the Custom 

Fields pane (where you make any changes). 
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52 MultiTerm 

and termbases 

The use of MultiTerm is integrated in the use of Studio, where you 

can search for, edit and create termbase entries. For more radical 

termbase management – such as advanced searches, and the creation 

of new termbases – you have to start and use MultiTerm itself. Here I 

will just cover the basic uses plus the basic settings and the shortcuts 

(see Annexes N–R). As with Studio, you may find that it pays to study 

them in order to get a view of the functions available. For the rest, I 

refer to the quite extensive Help function and SDL Trados’ own resources, 

at www.translationzone.com/en/translator-products/sdlmultitermdesktop. 

There is also an interesting blog post by Paul Filkin, Is MultiTerm really 

that hard to learn? in his multifarious blog. And another one, Multi-

tudinous terminology!, where he explains the reasons for the com-

plexities of this application. 

MultiTerm 2019 supports termbases created in MultiTerm 6.x to 

2007, and termbases created in MultiTerm 2009, 2011, 2014, 2015, 

and 2017 are completely compatible with MultiTerm 2019 termbases. 

However, it may happen when you open a 2011 termbase that you 

are told that it needs to be reorganised. How to do this is well ex-

plained by Nora Díaz in her blog post Studio 2014: Termbase Needs 

to be Reorganized, but How?. 

An interesting addition to the MultiTerm termbase function is the 

possibility to use simple Excel glossaries (with up to three columns) 

directly in Studio, i.e. accessible via Studios interface. This is possible 

with the AppStore plug-in TermExcelerator; see below on p. 452. 

Note: There is a standalone AppStore application, Tb-Scout, which 

allows you to make searches in various ways – i.a. for duplicate en-

tries – which is not possible in MultiTerm (or in the Studio inter-

face) and which may be useful in situations when you need to look 

up relevant termbase entries without opening MultiTerm. See p. 

453.  

The basic settings 

The basic settings available via File > Options (or Alt/F10, F, T) are quite 

few and easily illustrated by screenshots: 
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http://www.translationzone.com/en/translator-products/sdlmultitermdesktop/
http://multifarious.filkin.com/2013/01/30/imrthtl/
http://multifarious.filkin.com/2013/01/30/imrthtl/
http://multifarious.filkin.com/
http://multifarious.filkin.com/2014/03/04/multitudinous/
http://multifarious.filkin.com/2014/03/04/multitudinous/
http://noradiaz.blogspot.se/2013/09/studio-2014-termbase-needs-to-be.html
http://noradiaz.blogspot.se/2013/09/studio-2014-termbase-needs-to-be.html
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The MultiTerm window 

The ribbons can be customised in the same way as in Studio (see p. 

30). 

The Terms view – ribbons 
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The Terms view – window 

This is a typical MultiTerm window with the Hitlist view activated. 

Navigation pane Entry pane Ribbons and groups 

 

In the Terms view, you work with terms and termbase entries. In the 

corresponding Navigation pane, there are three tabs: 

 Browse, with the terms from the selected database shown in alpha-

betical order. 

 

 Hitlist, where you work with the termbase search results. 

 

 Termbases, where you select, in the list of open termbases, which 

termbase (the default termbase) to view in the Browse pane (click 

that termbase), and exclude termbases from searches. There are al-

so other actions to perform; right-click a termbase name and they 

all become available. 
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53 Machine translation – 

basic information 

The default options for machine translation (MT) in Studio are these: 

 Google Cloud Translation API,  

 SDL BeGlobal Enterprise (see p. 463), and  

 SDL Language Cloud (see p. 472). 

But there are a large number of other, optional resources, and they 

are proliferating as we speak. The main ones are described below. 

The use of any MT services is recorded in the .sdlxliff bilingual file 

during translation. Segments where MT is used are indicated with the 

 icon in the status column, but you should note that the AT icon 

is also used to indicate a translation based on an existing TU where 

some parts (such as dates) have been auto-substituted (see p. 271). 

And don’t forget: If you use MT, you can set the AutoSuggest func-

tion (p. 277) so that it presents you with any fragment (sub-segment) 

hits it finds in the MT provider’s data; just check the Translation 

Memory and Automated Translation option. 

And if you want a state-of-the-art description of MT, you can hardly 

do better than reading the book Machine Translation, edited by Jörg 

Porsiel; I have written a review of it here. Even though it is not free 

(€49 for 260 pages), I would say it is indispensable for anyone looking to 

use MT in the future. 

General discussions on MT 

The use of Google Cloud Translation API, MyMemory (see p. 485) 

and Microsoft Translator Text API – or similar online translation ser-

vices – may violate the non-disclosure agreement (if any) that you 

have with your client. However, the privacy declaration made by 

Google Cloud Translation API (see p. 463) may be enough for most 

confidentiality requirements. Microsoft Translator Text API also gives 

a guarantee with regard to confidentiality; see below. I have written 

an expose on this topic, discussing mainly the confidentiality/privacy 

of the various paid services on offer – see this blog post at the manu-

al’s home page. Furthermore, if you do jobs for countries in the Eu-

ropean Union, and they contain any kind of personal data, you have 

to take into account EU’s new General Data Protection Regulation, 

GDPR. (I touch upon this as well in the blog post.) 
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SDL certifies that they do not make public any material they re-

ceive/send, nor can it be retrieved without their knowledge. As for 

SDL Language Cloud and BeGlobal Enterprise, no target text is ever 

sent back, and the source text is only held in memory long enough for 

a translation to be provided; then it is discarded. (“SDL Language 

Cloud Machine Translation never stores or shares your source mate-

rial, and translates over a secure, encrypted connection ensuring com-

plete confidentiality.” See SDL Language Cloud Machine Translation.) 

The translations, however, are sent back to MyMemory, and Mi-

crosoft Translator, only if you expressly allow that. As for Google 

Cloud Translation API, I can only say that the Update TM option can-

not be selected. 

And whatever security is promised by the provider of the machine 

translation, it does not change the fact that whatever you send or re-

ceive via the internet may be compromised during that process. 

As you can see below, one method of improving the confidentiality is 

to pre-edit the text sent for translation, and such a feature is built-in 

in a few of the plugins. The AppStore plugin RyS Translation Work-

flow Automation Package 2018 – which I haven’t yet tried – includes 

that feature which is said to work with any MT provider. Because of 

its many other features (see also pp. 435 and 217), it is fairly expen-

sive – $180 (with a 15 days free trial). And again, note the observation 

concerning user instructions and payment for the RyS plugins (see p. 469). 

This is the settings pane for pre- and post-editing. It may give you some 

idea of the functionalities involved. 

 

A more comprehensive way of protecting data during translation – wheth-

er MT is used or not – is offered by the AppStore plugin projectAnonymiz-

er. Here, you can convert sensitive data into tags before the translation 

starts. During and after the translation, the thus anonymised segments are 

stored in your TM. When everything is finalised, you “unprotect” your 

target files before sending them to the client. The respective commands are 

found on the Batch Tasks list. But don’t miss reading the instruction on the 

SDL Community wiki. 

http://www.sdl.com/software-and-services/translation-software/machine-translation/language-cloud/
https://appstore.sdl.com/language/app/rys-term-extractor-translation-tweaker-and-batch-search-replace/822/
https://appstore.sdl.com/language/app/rys-term-extractor-translation-tweaker-and-batch-search-replace/822/
https://appstore.sdl.com/language/app/projectanonymizer/895/
https://appstore.sdl.com/language/app/projectanonymizer/895/
https://community.sdl.com/product-groups/translationproductivity/w/customer-experience/3199.sdl-project-anonymizer
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Neural 

machine 

translation 

(NMT) 

It may help you to abide by the GDPR requirements if you anonymise the 

TU system field data, such as your name (Created by) and even the Win-

dows domain you were logged into when translating the segment. Such 

anonymization functions are offered by the AppStore plugin TM Anony-

mizer, which is placed on the View navigation field after installation. Using 

the app for one file at a time is free; for multiple files (in one go) you 

need to buy a license. 

 

And from the same developer (Localix) comes the AppStore plugin 

SDLXLIFF Anonymizer, providing the same service for .sdlxliff files: 

 

Again, for multiple files in one go you need to buy a license. 

Paul Filkin has written about the matter of data protection and confi-

dentiality in his blog post Data Protection, where he also mentions the 

three applications above as well as SDLTmConvert (see also p. 370). 

You should also keep an eye open for a soon-to-be-available AppStore 

plugin called SDLTMAnonymizer, which allows you to search for 

personal information in TMs, based on regular expressions, and then 

replace it with tags. Since GDPR makes requirements also on your ex-

isting (old) data, this function may be particularly useful. 

Nowadays, there is a lot of talk (and a lot of hype) about Neural Machine 

Translation (NMT) as opposed to the previous Rule-based (RBMT) and 

Statistical (SMT) – or its subcategory Phrase-Based (statistical) machine 

translation (PBMT). This is not the place to discuss such more theoretical 

aspects (read this brief article by Arle Lommel for a good description of 

NMT),  but since several applications offer the choice between NMT and 

SMT (or PBMT) as a first lookup instance, I think the following re-

flection by Jost Zetzsche (in his Tool Box Journal, issue 278, Septem-

ber 2017) is very much worth considering: 

“I have long maintained that the most effective way of using MT 

for the majority of applicable projects is to use it as a repository for 

fragments rather than suggestions for whole segments that can and 

need to be edited. Especially in the statistical phrase-based machine 

translation scenario, the individual fragments or phrases are actually 

made up of translations that you and I have delivered over the years. 

They might be wrongly chosen by the machine translation program 

for the purpose of the current translation, but if they fit, they fit -- 

and potentially save you from a lot of typing. 

https://appstore.sdl.com/language/app/tm-anonymizer/898/
https://appstore.sdl.com/language/app/tm-anonymizer/898/
https://appstore.sdl.com/language/app/sdlxliff-anonymizer/580/
https://multifarious.filkin.com/2018/05/27/data-protection/
http://www.tcworld.info/e-magazine/translation-and-localization/article/neural-machine-translation-offers-significant-advances-with-remaining-challenges/
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"ProZ", 20 

(AppStore) TM Lifting, 259 

.autoCorrect files, edit, 297 

.csv and tab delimited text documents 

source file comments in, 306 

.doc to .docx files, batch conversion, 302 

.lng (filetype), 488 

.mtf.xml (file format), 442 

.pdf converter, 354 

.pdf file, deliver .pdf translation as, 355 

.sdlretrofit file, open, 343 

:AdaptiveTM… what’s the score? (blog post), 

474, 479 

:Text to speech proofreading: worth a try! (blog 

post), 338 

“Open Document"… or did you mean “Create a 

single file Project" (blog post), 179 

…and the winner is? (blog post), 435 

100% match 

definition, 232 

ignore during spell checking, 291 

A 
 

A clean editing environment? (blog post), 268 

A Collection of Regular Expressions for the 

Regex Match AutoSuggest Provider (blog 

post), 284 

A competitive edge (blog post), 488 

A couple of little known gems in SDL Trados 

Studio (blog post), 488 

A few bilingual TBX resources (blog post), 451 

abbreviation list, 378 

About Translation (blog), 21 

accept all tracked changes in document, 351 

accept tracked change 

and go to next, 351 

but do not go to next one, 351 

Access Rights (translation memories), 379 

account information (Language Cloud), 483 

acronyms 

definition, 272 

substitution of, 272 

Action (word check in QA Checker), 322 

Actions (Batch Edit Script page), 414 

Actions on segments (in Community Advanced 

Display Filter), 212 

Activate option (for character display during TM 

display), 231 

activate translate to fuzzy, 203 

Active Document Settings 

Languages dialog, 198 

Active segment background color (Editor pane), 

190 

Active Spell Checker, 291 

Adapt 

font sizes, 191 

text colors, 191 

adaptive engines, manage, 478 

AdaptiveMT, 478 

add 

all project files in a folder, 93 

as new translation, 63 

AutoText entries, 284 

comment, 302 

customers, 95 

File-based TMs (Input Translation 

Memories), 387 

File-based TMs from Folder (Input 

Translation Memories), 387 

files to the current project, 117 

files/folders to project, 117 

folders to the current project, 117 

individual project files, 92 

new batch script for TM, 414 

new folder to the project (in Files view), 117 

new target languages to projects, 119 

New Term, 255 

new term post in Concordance Search pane, 

255 

new translation units (in Translation Memory 

Updates), 150, 248 

project to projects list, 117 

Segmentation Rule window, 376 

server connection (for server-based TMs), 421 

server-based TM, 422, 423 

spell checking dictionary, 293 

target language, 92 

termbase entry, 447 

termbases, 119 

TMs in projects, 119 

translation as duplicate, 203 

translation memory (TMX Import Options), 

384 

word check action in QA Checker, 322 

Add AutoText Entry dialog, 284 

Add Comment dialog, 302 

Add Condition dialog (filtering TUs), 417 

Add Condition pane (for filtering), 236 

Add Condition window (new AutoSuggest 

dictionary), 281 

Add Copy (edit termbase entry), 444 

add cross-references (in termbase entry), 448 

Add Filter dialog, 235 

add hyperlink to termbase entry, 448 

Add more button (for termbase creation), 433 
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