Contents at a glance

PART I – INTRODUCTORY MATERIAL
About this manual 2
1 SDL Trados Studio – a presentation 3
2 Help 9
3 OpenExchange 15

PART II – BASICS
4 User interface overview 20
5 Keyboard shortcuts 31
6 Specific Studio concepts 34

PART III – QUICK GUIDE
7 Basic use 38
8 Workflow 39
9 Creating a project 40
10 Translation memory handling 46
11 Translating a single file which is not part of an existing project 51
12 Translating 53
13 The (p)review process 70
14 Saving documents; generating translated documents

PART IV – GENERAL FUNCTIONS
15 User Profile 76
16 Language pairs 77
17 Language resource templates 79
18 Projects 81
19 Project templates 109
20 Levels for settings – document/project/project template 113
21 Project packages 115
22 File types; file type handling; file administration 120
23 Batch Processes 135
24 Project and file statistics; reports 143

PART V – EDITING/TRANSLATING
25 Starting the editing/translation process 158
26 The Editor view 164
27 Segment handling 178
28 Advanced manipulation of .sdlxliff files and segments with the SDLXLIFF Toolkit and SDL XLIFF Split/Merge 189
29 Using TMs 193
30 Looking up terms 209
31 Recognized tokens 218
32 Automatic substitution/localization of specific expressions 229
33 AutoSuggest 235
34 Auto-propagation 246
35 Spell checking 248
36 Grammar checking 252
Contents in detail

PART I – INTRODUCTORY MATERIAL

About this manual........................................................................................................2
1 SDL Trados Studio – a presentation..............................................................................3
   Changes in the 2015 version ..........................................................................................3
   Studio setup..................................................................................................................5
   On the use of Studio for the translation of running, non-repetitive text (e.g. books) .......6
   My license is lost – what do I do? ...............................................................................6
   Transfer Studio to a new computer ............................................................................ 7
   Working together over the net .....................................................................................7
   Jobs posted at ProZ – plug in for ............................................................................. 8
   Final tip .................................................................................................................... 8

2 Help..................................................................................................................... 9

3 OpenExchange ........................................................................................................15

PART II – BASICS

4 User interface overview ..........................................................................................20
   The views; the ribbon ...............................................................................................20
   The Add-Ins ribbon ................................................................................................25
   The Welcome view ..................................................................................................26
   Ribbons ..................................................................................................................26
   Work pane functions .............................................................................................27
   Customising the work pane options .....................................................................27
   Customising the navigation pane .........................................................................28
   The main Studio window .......................................................................................28
   Customizing the views ..........................................................................................29
   Rearranging the work panes ..................................................................................29

5 Keyboard shortcuts .................................................................................................31

6 Specific Studio concepts........................................................................................34
   The “Project” concept ............................................................................................34
   The “Project template” concept ............................................................................35
   The “User profile” concept ..................................................................................35
   The “Project package” concept ............................................................................35

PART III – QUICK GUIDE

7 Basic use ..............................................................................................................38

8 Workflow................................................................................................................39
   One source file only, no initial creation of a project ..................................................39
   Several source files, with project creation ...............................................................39

9 Creating a project .....................................................................................................40
   Project without centralised resources ....................................................................40
   Project with centralised resources via SDL WorldServer .......................................45

10 Translation memory handling ................................................................................46
   Creating a TM .........................................................................................................46
   Importing a legacy (old format) TM into an existing Studio TM .............................48
   Upgrading a legacy (old format) TM to Studio format .............................................50

11 Translating a single file which is not part of an existing project .............................51

12 Translating ...........................................................................................................53
   Opening a previously saved file (or files) .............................................................53
   Editing ....................................................................................................................54
28 Advanced manipulation of .sdlxliff files and segments
with the SDLXLIFF Toolkit and SDL XLIFF Split/Merge.................. 189
   The SDLXLIFF Toolkit ................................................................ 189
   SDL XLIFF Split/Merge ................................................................. 191
29 Using TMs .............................................................. 193
   Opening, creating and deactivating TMs during translation .......... 193
   Project translation memories ....................................................... 193
   Specific “fuzzy match” threshold for the project TM creation .......... 194
   TM lookups ............................................................................... 195
   Customizing the Translation Results pane .................................. 197
   Handling TM lookup results ....................................................... 198
   Types of TM matches ................................................................ 199
   PerfectMatches .......................................................................... 199
   TM lookup settings ................................................................. 200
   Editing/deleting TUs in the Translation Results pane ................. 203
   Concordance search ................................................................... 204
   Updating the TM ......................................................................... 206
   Automatic update during translation – settings ......................... 206
   Manual update of the TM(s) during or after translation ............. 207
30 Looking up terms .................................................... 209
   Termbase search (terminology lookup) ...................................... 209
   The Termbase Viewer .................................................................. 213
   Looking up external termbases .................................................. 215
   Web Lookup! ............................................................................. 215
   The SDL MultiTerm Widget ....................................................... 215
   The Dictionary Provider ............................................................ 216
   IntelliWebSearch ....................................................................... 217
31 Recognized tokens ............................................. 218
   “Recognized tokens” (including tags); special characters;
   whitespace characters ................................................................ 218
   Inserting recognized tokens ...................................................... 219
   Special characters – two simple ways to provide character inserts 223
   Special characters with QuickInsert .......................................... 224
   Whitespace characters ................................................................ 225
   Tag handling .............................................................................. 225
   Ghost tags ............................................................................... 228
   Overdose of tags .................................................................... 228
   Translatable and non-translatable tags ...................................... 228
32 Automatic substitution/localization of specific expressions ..... 229
33 AutoSuggest ..................................................................... 235
   Setting up AutoSuggest ............................................................ 235
   Generating/adding an AutoSuggest dictionary ......................... 237
   Creating AutoText entries ......................................................... 242
   TermInjector and auto-insertion ............................................... 244
34 Auto-propagation .................................................. 246
35 Spell checking .......................................................... 248
   Checking the spelling ............................................................... 248
   Spell checking settings ............................................................ 249
   Managing dictionaries .............................................................. 249
36 Grammar checking .................................................. 252
37 Autocorrection and autocompletion ............................. 254
   Third party solutions .............................................................. 255
   AutoHotkey ............................................................................ 256
   Text replacement ...................................................................... 257
   Remapping of keyboard keys .................................................. 258
   Script Showcase ...................................................................... 258
PhraseExpress ................................................................. 258
Text replacement (with Autotext) ........................................... 259
AutoCorrect ........................................................................ 260
Text suggestions (AutoComplete) .......................................... 261
Import an external phrase file ............................................... 262
Enable/disable a phrase folder ............................................. 262
Clipboard manager ............................................................ 262
Macros .............................................................................. 262

38 Comments ..................................................................... 263
Export comments ............................................................... 265
Working with source file comments in Microsoft Office and .pdf documents .................................................. 266
Working with source file comments in .csv and tab delimited text documents .................................................. 267

39 Changes in source documents ....................................... 268
Tracked changes in source documents .................................. 268
Editing source segments .................................................... 270

40 Verification/quality control ............................................ 272
Translation Quality Assessment (TQA) ................................. 273
Verifying the translation ....................................................... 274
Automatic verification (verification during translation) ............ 274
Verifying a project (normally after translation) ....................... 275
QA Checker settings .......................................................... 278
Terminology Verifier .......................................................... 285
Tag Verification ................................................................ 286
XML validation ................................................................... 286
Use of quality metrics and productivity data in the Qualitivity plugin .......................................................... 287

41 Preview .......................................................................... 289
Previewing as you translate ................................................ 289
Previewing in original file format ......................................... 291
Exporting/printing the preview ............................................. 291
Printing the preview via Studio ............................................ 291
Exporting the bilingual preview as a Word document .......... 292
Importing changes from a monolingual target document ("retrofit") .......................................................... 297
Retrofitting an open .sdlxliff file ......................................... 297
Retrofitting a project ......................................................... 298
Opening an .sdleretrofit file ................................................. 298
Comparing .sdlxliff files .................................................... 298

42 Saving documents and updating TMs; generating translated documents .................................................. 299
Saving the bilingual and source documents ......................... 299
Updating the TMs .............................................................. 300
Generating a translated document ....................................... 300
Finalizing the translation .................................................... 300
Exporting files .................................................................. 301
Marking a project as complete ........................................... 301

43 Review and sign-off ....................................................... 302
The review process .......................................................... 302
Tracking changes in target segments (as in Microsoft Word) .............................................................................. 303
Making changes .................................................................. 305
Reviewing tracked changes ............................................... 305
The sign-off process ......................................................... 306

44 Bilingual Word files, .pdf, .ttx and Excel files in Studio ........................................................................ 307
Handling bilingual Word files ............................................. 307
Handling .pdf files ............................................................ 308
Handling .ttx files ............................................................. 309
The SDLXLIFF to Legacy Converter ................................... 309
PART VI – TRANSLATION MEMORIES

46 Handling Studio translation memories .......................................................... 316
  Translation units – description ....................................................................... 316
  Creating a new TM ......................................................................................... 317
  Exporting/importing a Studio TM ................................................................. 320
    Exporting a TM into other file formats (conversion) .................................. 322
    Repairing a Studio TM ................................................................................. 322
  TM settings ..................................................................................................... 323
    Editing the TM description ............................................................................ 323
    Creating/editing Custom Fields .................................................................... 324
  Language Resources settings ......................................................................... 326
    Segmentation rules ....................................................................................... 327
    Variable list ................................................................................................. 329
    Abbreviation list ......................................................................................... 330
    Ordinal followers .......................................................................................... 330
  Other TM settings .......................................................................................... 330
    Access Rights – Passwords .......................................................................... 330
    Fuzzy Index statistics ................................................................................... 330
    Re-index the TM ........................................................................................... 331
    Advanced tuning of the TM .......................................................................... 331

47 Handling legacy (old format) TMs ................................................................. 332
  Migrating non-Studio format TMs into Studio ................................................. 332
  Importing files into an existing Studio TM ....................................................... 333
    A: Importing .txl, .ltx and .sdlxliff bilingual files ........................................... 333
    B: Importing .doc and .rtf bilingual files ......................................................... 335
    C: Importing .tmx files .................................................................................. 335
  D: Upgrading legacy (old format) TMs ............................................................ 337
    Upgrading one file only ................................................................................ 338
    Upgrading one or more files ......................................................................... 338
  E: .ini and .ani files ......................................................................................... 342
    Creating a TM from a termbase ..................................................................... 342

48 Producing new TMs from translated documents: Alignment .................... 343
  Alignment with or without review ................................................................... 344
    Alignment with review .................................................................................. 344
    Alignment without review ............................................................................. 347
  The Alignment editor ..................................................................................... 349
    The ribbons ................................................................................................. 349
    The editing pane ........................................................................................... 350
    Quality and rating ....................................................................................... 352
    Editing an alignment file .............................................................................. 352
    Importing an alignment file into a TM .......................................................... 355
    Saving an alignment file in .sdlxliff format .................................................. 358
    Aligning a “retrofitted” file .......................................................................... 358

49 Translation Units maintenance ................................................................. 360
  The Translation Memories view ....................................................................... 360
    Ribbons ......................................................................................................... 360
    Description ................................................................................................... 360
    The side-by-side Editor pane .......................................................................... 362
    Customizing the Translation Memories view ............................................... 363
  Editing individual TUs .................................................................................... 363
    Deleting several TUs at the same time (batch delete) .................................. 364
    Editing several TUs at the same time (batch edit) ........................................ 365
Searching for duplicates .................................................................................. 367
Filtering TUs .................................................................................................... 368
Maintenance using Studio’s QA functions ......................................................... 370
Optimizing Trados 2007 TMs ......................................................................... 370
50 Reversing languages in a TM ...................................................................... 371
51 Using server-based TMs ............................................................................ 372
  Managing servers ............................................................................................ 372
  Adding a server connection ........................................................................... 372
  Creating a server-based TM ........................................................................... 373
  Opening a server-based TM .......................................................................... 374
  Batch-handling server-based TMs ................................................................. 375

PART VII – TERMBASE HANDLING
52 MultiTerm and termbases .......................................................................... 378
  The basic settings ........................................................................................... 378
  The MultiTerm window ................................................................................... 379
  The Terms view – ribbons .............................................................................. 379
  The Terms view – window ............................................................................. 379
  The Termbase Management view – ribbons .................................................. 381
  The Termbase Management view – window .................................................. 381
  Opening termbases ........................................................................................ 382
  Creating a termbase ....................................................................................... 383
  Extracting a source termbase using the Word Cloud plugin ......................... 386
  Importing/exporting a termbase ................................................................... 386
    Importing a termbase .................................................................................. 386
    Exporting a termbase .................................................................................. 387
  Converting a termbase from non-MT format ................................................ 388
    Glossary Plugin and Glossary Converter .................................................... 388
    SDL MultiTerm 2015 Convert ...................................................................... 391
  Converting a termbase into non-MT format ................................................... 392
  Searching the termbase ............................................................................... 392
  Search filter – defining and using ................................................................. 394
  Adding, editing and deleting termbase entries ............................................. 396
  The IATE termbase – some suggestions ....................................................... 397

PART VIII – AUTOMATED TRANSLATION
53 Automated translation – basic information ............................................. 400
  Connecting to an Automated Translation Server (ATS) ............................. 401
    Connecting to an existing server connection ............................................ 401
  SDL Language Cloud .................................................................................... 406
    The Language Cloud services .................................................................. 408
    Your Language Cloud account ................................................................. 412
  Usefulness of automated translation ............................................................. 413
  Using automated translation during pre-translation .................................. 414
  Other ATS settings ....................................................................................... 415
  Related OpenExchange applications ........................................................... 415

PART IX – REGULAR EXPRESSIONS
54 Regular expressions – an introduction ..................................................... 418

ANNEXES
Annex A
  Keyboard shortcuts – All views ................................................................. 422
Annex B
  Keyboard shortcuts – Editor ........................................................................ 424
Annex C ........................................................................................................ 427
Annex D
Keyboard shortcuts – Editor > QuickInsert Toolbar (or, in fact, group) ...............427
Annex E
Keyboard shortcuts – Editor > TM and Concordance Window .........................428
Annex F
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex G
Keyboard shortcuts – Welcome view ................................................................430
Keyboard shortcuts – Help ................................................................................430
Annex H
Keyboard shortcuts – Editor > TM and Concordance Window .........................428
Annex I
Keyboard shortcuts – Editor > TM and Concordance Window .........................428
Annex J
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex K
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex L
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex M
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex N
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex O
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex P
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex Q
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex R
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex S
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex T
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex U
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex V
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex W
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex X
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex Y
Keyboard shortcuts – Editor > Track Changes ..................................................429
Annex Z
Keyboard shortcuts – Editor > Track Changes ..................................................429

INDEX

457
There are many ways to get help with the use of Studio. SDL offers a large number of different help facilities to the freelance translator. Most of them are collected on the Help ribbon, available in all views:

- **In the SDL TranslationZone**, under the heading *Resources*, you will find under *Downloads*, in particular, a large number of very useful items, plus a lot of documents under *Documentation*.
- The **SDL Knowledge Base** (KB) contains an enormous amount of information (solutions to problems, FAQs, etc.). You can reach it easily via the **SDL Solution Finder** button in the Client Services view and furthermore search the KB in a special search field. In that same view, you can also subscribe to all KB updates on Twitter.
- Under the **Support > Support resources** at SDL TranslationZone, you will find – among lots of other things – both Tips and Tricks for Studio as well as MultiTerm. Under **Support > Support Services** are a large number of FAQs as well as licensing and other useful information.
- Note the new **Customer Feedback** button. It will open the Customer Experience Feedback Options dialog box, intended to “help improve the quality, reliability and performance of SDL software”. You can declare whether you want to participate or not (“not” is the default).
- **Welcome view**: The Welcome view gives you access to various assistance facilities under three of its four different tabs. The fourth, HOME, is a starting point for work and also includes links to videos for those starting points (*New Project*, *Translate Single Document*, *Open Package*, *Open GroupShare Project*, and *Language Cloud*)
- The **GET STARTED** tab gives access to three quick start guides and (eventually) five “Getting Started Videos” for Studio 2015 and MultiTerm 2015.
The **MORE RESOURCES** tab shows links to Release Notes, Help System, SDL Trados Migration Guide, and SDL OpenExchange. (As you see, some of the facilities have links everywhere.)

And the **LATEST NEWS** tab shows ... well, the latest news.

**Documentation:** The *SDL Trados Studio Migration Guide* (see above) is an introduction to Studio for those who are familiar with the “old” Trados (as well as others) and does a quite good job of it. There are also three Quick Start Guides (*Translating and Reviewing*, *Translation Memory Management*, and *Project Management*). All three are accessible in the *Welcome* view under the GET STARTED tab.

**Other supportive facilities:**

- A very rich overview of the SDL support is given by Paul Filkin in a *multifarious* blog post: *SDL sustenance*.
- The *SDL Community* (community.sdl.com/) gives access to a large number of resources. Note in particular the links to videos and communities (discussion groups) at right.

---

![SDL Community](image_url)
The OpenExchange (OE) feature is by now such an established and valuable resource that it rates its own chapter in this manual even though the specific applications are not included in the Studio package. But the Software Development Kit (SDK) is, and if you feel like contributing, check out the Developer Program section of the OpenExchange site (www.translationzone.com/openexchange/developer), where you will find lots of information. And Romulus Crisan, in his blog, runs an excellent series of posts for OE developers: OpenExchange: Age of developers.

The OpenExchange homepage (links all over the place in the Studio user interface) is where users can offer their own enhancement applications and, of course, download them.

In addition, there is a special section in the SDL Community for discussing the OpenExchange applications called, of course, OpenExchange Applications (community.sdl.com/appsupport).

If your OpenExchange applications (134 of them as of April, 2015) are developed by SDL, you will find them (and some others, too) in the navigation pane of the Welcome view. (And under Start > All programs > SDL > SDL Trados Studio 2014 > OpenExchange Apps.) Other OE applications may end up elsewhere (such as Glossary Converter, which is placed in Start > All programs > SDL OpenExchange). Those which are really plugged-in into the Studio user interface – meaning that they get their own icons in a ribbon (p. 20), or in a context menu, or as file type in the project settings – can be found in the list of custom plug-ins in the Plug-ins list on the Add-Ins ribbon. Those which are not are normally placed on the desktop, with their own icons. You can simplify their access with the OE application Menu Maker (p. 28), with which you can add their names to the list in the navigation pane in the Welcome view.

The Plug-Ins list is also the default way of temporarily deactivating a plug-in without uninstalling it (but you will need to re-start Studio to have the deactivation – or activation, as the case may be – take place.)

Note: The default location for the plugin installations is
C:\Users\<username>\AppData\Roaming\SDL\SDL Trados Studio\12\Plugins\Packages\ or sometimes
C:\Users\<username>\AppData\Local\SDL\SDL Trados Studio\12\Plugins\Packages\
or
C:\ProgramData\SDL\SDL Trados Studio\12\Plugins\Packages\

You will also find some of them on the Start menu, such as:

You will also find some of them on the Start menu, such as:

However, even though the OE page has functions for searching for applications in six different categories, the number of applications makes it pretty cumbersome to look through the search results. For that reason, I have made an overview list on the manual’s home page, where you can sort by name, category, app version, Studio version, price, and developer. There are also links directly to the app’s presentation on the OE site as well as links to the developer’s home page (if there is one). This list is updated at least once a month, and it’s here: tradosstudiomanual.com/?page_id=777.

And Tuomas Kostiainen, in a presentation at the ATA 2014 conference, gave “an overview of the types of apps available and provides users with the information they need in order to be able to utilize them in their own work as translators or project managers”. The presentation is called The Wild West of Trados Studio OpenExchange Apps.

Note: Some of the OE applications have not been adapted to the 2015 version (and some of them clearly don’t need to be since they don’t interact with Studio). If you look under Latest releases, it’s obvious; for the other applications just check the version year.

Are the OE applications safe to use? It is not obvious that they would be, and if you want to know more about their safety, Paul Filkin’s multifarious blog entry SDL OpenExchange Application Security is a good place to look. There is even a special OpenExchange application called SDL OpenX Hash Generator, which makes it possible to double-check that the OE application you download is the same as the one checked and published by OpenExchange. And if you want to know more about who may contribute to OE – and who may not, and why – then Paul Filkin’s multifarious blog post You only need a key! is informative.

Some of the OE applications are of the .msi filetype. It happens that the computer requires them to be opened with Administrator
Keyboard shortcuts

Keyboard shortcuts are ergonomic and should be used as much as possible. And Trados lets you customize the shortcuts.

There are shortcuts for the following categories:

- **All Views** (shortcuts common to all views)
- **Category Window** (don't know what this is for)
- **Editor**
  - **Editor: QuickInsert Toolbar** (which is really the QuickInsert group; for formatting and some special characters; see p. 222)
  - **Editor: TM Window** (for handling search results and TM matches)
- **Files** (file handling; default state: no shortcuts)
- **Projects**
- **Reports**
- **Translation Memories**

The shortcuts depend on which user profile (p. 76) you are using. There are slight differences between the default and the SDL Trados profile shortcuts; considerably more between the default and the SDLX shortcuts. In this manual, those differences are noted wherever they occur; they are also reflected in the shortcut lists in the annexes.

- **View shortcuts**: There are two ways to do this:
  - In the Welcome view, go to Home > Show shortcuts (or Alt/F10, H, H). A window opens where you can scroll through all shortcuts, and for each one the corresponding icon is shown. You can also print this list. (And you can copy it into Word for easy searching.)
  - Open File > Options (or Alt/F10, F, T) and expand Keyboard Shortcuts. **Note**: Any shortcuts (or shortcut possibilities) included in your OpenExchange applications are also shown.

- **Change, delete or create a shortcut**: Open the shortcut window (File > Options (or Alt/F10, F, T) > Keyboard Shortcuts) and select the desired category. Locate the action in question and change/delete the existing key combination or add a new one. If you try to assign a shortcut which is already in use, the row will be highlighted in red and you will have to try another one. If you point to the red area, you will be told to which action that shortcut is assigned. (It is alright to use the same shortcut in different categories except for conflicts with All Views or conflicts between the three Editor tables.)
Note: The specific shortcuts, using the Alt and F10 keys, for navigation among the commands on the function ribbons (p. 24), are not listed in the Keyboard Shortcuts list that you open via Options (see above). This means that the combinations Alt/F10 plus the figures 1–4 and the letters A, D, E, F, H, R, and V, although they can be assigned, will not be functional for anything but these defaults.

Reset shortcuts: Click the Reset to Defaults button. This applies only to the category that is open.

Specifically, the shortcut to close Studio is Alt+F4.

In Annexes A–R you will find lists, sorted according to the above categories, of all functions to which shortcuts may be (or are) assigned, and with the default values given. You should in fact study these lists, because you are likely to find functions there that you did not even know existed. (Annex G lists all shortcuts already used in All views and the Editor view, which means that they are not immediately available if you want to create new shortcuts or change existing ones.)

And if, like me, you prefer the shortcuts Ctrl+Del, Ctrl+Insert and Shift+Insert for cutting, copying and pasting, respectively (normally available in all Windows-based applications), then that can of course be arranged by changing them as described above – except that for no known reason it is not possible to assign Shift+Insert. However, Paul Filkin figured out how; you can read about it in the Trados studio-manual blog post Ctrl/Shift shortcuts for cut, copy and paste.

Note: Because of Windows quirkiness, Ctrl+Alt works like AltGr. This means that certain Ctrl+Alt combinations will give strange results if you assign them as shortcuts. Here are some common combinations that you should avoid, because (a) such a shortcut will result both in the required action and insertion of the corresponding AltGr character, and (b) trying to insert the AltGr character in question will also initiate the option associated with the corresponding Ctrl+Alt shortcut.

<table>
<thead>
<tr>
<th>Ctrl+Alt-character</th>
<th>AltGr-character</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>7</td>
<td>{</td>
</tr>
<tr>
<td>8</td>
<td>}</td>
</tr>
<tr>
<td>9</td>
<td>]</td>
</tr>
<tr>
<td>0</td>
<td>}</td>
</tr>
<tr>
<td>local key*</td>
<td>\</td>
</tr>
<tr>
<td>local key*</td>
<td>@</td>
</tr>
<tr>
<td>local key*</td>
<td>€</td>
</tr>
<tr>
<td>local key*</td>
<td>~</td>
</tr>
<tr>
<td>&lt;</td>
<td>]</td>
</tr>
</tbody>
</table>
The Editor view

Terminology

There is some confusion regarding the terminology in the Editor view in Studio. This is what I try to stick to:

- A segment is either a source string or a target (translated) string. The short form is simply “source” and “target”.
- A row is what you work with in the Editor pane, consisting of a source segment, its corresponding target segment, a row number, status indicator, and a structure designation; see p. 168. (Hence the term often used for numbering, “segment number”, really ought to be called “row number”).
- A translation unit (TU) is the combination of source segment, target segment and all associated information, such as field data. TUs occur only in translation memories.

Overview: The Editor view

Ribbons

In the Editor view, there are four specific ribbons: Home, Review, Advanced, and View.
**Description**

This is a typical example of the Editor view.

- **Navigation pane**
- **Home ribbon**
- **Termbase viewer tab**
- **Editor pane**
- **Function-specific panes**
- **Preview tab**
The Editor view Overview

The left-hand function-specific pane by default shows the Translation Results, i.e. the results of the automatic lookup in the TM(s); see p. 196. Note that the same pane can also show the results of the Concordance Search (p. 204), any Comments (p. 263), and Messages (p. 274). Use the tabs at the bottom of the pane. Like the in the “old” Trados, the Concordance pane is updated with possible hits in the TM when a new source segment is opened. The Translation Results pane shows not only the best TM hit (if any), but also all other hits above the threshold (see p. 201) you have set. It may be a good idea to move either of those panes in order to make it bigger; see below.

The right-hand function-specific pane by default shows the Term Recognition, i.e. the results of lookups – automatic or manual – in the termbase(s). The same pane can also show the Termbase Search facility (p. 212).

Note: Many Studio users testify to the fact that Find & Replace as well as Auto-propagation in big files works much faster if the term recognition is turned off. In the Term Recognition pane, click the Project Termbase Settings icon and uncheck the Enabled box(es) in the Project Settings dialog box that opens.

You can switch between the panes and the open documents with Ctrl+Tab and Ctrl+Shift+Tab, which opens this window (with the first command you step downwards in the window, with the second upwards):

You may want to shuffle the panes around (see p. 29). For one thing, it may be practical to have the Concordance Search pane open all the time, if you have the space for it (a big screen, or two screens). In fact, if you have the space you may find it practical to move also the Translation Results pane and the Term Recognition pane, thus freeing a lot of space in the Studio window for viewing the source and target documents. (It is easy to change back.) If you need more space, you can also minimize the navigation pane.

You can expand the Editor pane to the whole screen – with the other panes represented by tabs – using F11. To go back, press F11 again.

With the Windows key together with the arrow keys, you can cycle the Studio window through different positions on your screen(s).

On the far right is the Preview tab (see p. 290).

Note: When you close the last file which is open in the Editor view, that view closes and you return to the Files view.
At the bottom right is the status bar, where you can see:

- the active display filter (see p. 184); here: All segments
- writing mode: **INS**ert or **OVR** (overwrite); as usual you select this with the **Insert** key
- the last expression (if any) searched for in the filtering function; here: “rights”
- the percentage of non-translated words (or characters, or segments; see below)
- the percentage of draft translations (words, characters, or segments; see below)
- the percentage of confirmed translations (words, characters, or segments; see below)
- the number of characters in the target segment (sorry – no corresponding function for the source segment)
- accumulated penalty points compared to the number of penalty points allowed in the Translation Quality Assessment (TQA) configuration (see p. 273)
- source and target languages (by pointing to them, you will see the complete language name, i.e. including language variant).

The measurement of the amount of non-translated/translated text can be customized: Double-click either and the **Display Settings** dialog box opens:

- **Display Units** are: Words, Characters or Segments.
- **Display Values** are: Count, Percentage or Both.

The character count includes recognized tokens but not tags or spaces.

**Customizing the Editor pane**

This is the **Editor** pane:
## Segment handling

### Segment navigation and manipulation

You can quickly get access to many commands for segment handling by right-clicking in the segment. This gives you the following options (note also the shortcuts).

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>QuickPlace</td>
<td>Ctrl+Alt+Down</td>
</tr>
<tr>
<td>Activate Row</td>
<td>Alt+Home</td>
</tr>
<tr>
<td>Confirm and Move to Next Unconfirmed Segment</td>
<td>Ctrl+Enter</td>
</tr>
<tr>
<td>Change Segment Status</td>
<td></td>
</tr>
<tr>
<td>Concordance Search</td>
<td>F3</td>
</tr>
<tr>
<td>Copy Source to Target</td>
<td>Ctrl+Ins</td>
</tr>
<tr>
<td>Clear Target Segment</td>
<td>Alt+Del</td>
</tr>
<tr>
<td>Edit Source</td>
<td>Alt+F2</td>
</tr>
<tr>
<td>Restore Tags</td>
<td>Ctrl+Shift+G</td>
</tr>
<tr>
<td>Add New Term</td>
<td>Ctrl+F2</td>
</tr>
<tr>
<td>Quick Add New Term</td>
<td>Ctrl+Shift+F2</td>
</tr>
<tr>
<td>Add Comment</td>
<td></td>
</tr>
<tr>
<td>Edit Comment</td>
<td></td>
</tr>
<tr>
<td>Accept Change</td>
<td>Ctrl+Shift+F9</td>
</tr>
<tr>
<td>Reject Change</td>
<td>Alt+Shift+F9</td>
</tr>
<tr>
<td>Add Bookmark</td>
<td></td>
</tr>
<tr>
<td>Split Segments</td>
<td>Alt+Shift+T</td>
</tr>
<tr>
<td>Merge Segments</td>
<td>Ctrl+Alt+S</td>
</tr>
<tr>
<td>Lock Segments</td>
<td>Ctrl+L</td>
</tr>
</tbody>
</table>

The basic editing functions familiar from Word and other Office programs have the same shortcuts in Studio; e.g. Cut/Copy/Paste, cursor movement, select/delete a word, change case (Ctrl+F3 [SDLX: Ctrl+F11] for: all minor case, capitalization of first character, all capitals), select
text until end of paragraph/segment (use Ctrl+Shift+Down), select text until beginning of paragraph/segment (use Ctrl+Shift+Up), etc. See also the Edit menu and the shortcut lists in Annex A and Annex B.

As for Cut/Copy/Paste: If you prefer the alternative standard shortcuts using the Ctrl and Shift keys, you will discover that – inexplicably – it is not possible to assign the Shift+Insert combination (used for Paste). There is a solution, however; see my blog post Ctrl/Shift shortcuts for cut, copy and paste at tradosstudiomanual.com.

☐ Copy source to target: Press Ctrl+Insert or Alt+Ins [SDLX: F4]. Any text in the target segment will be overwritten.

☐ Copy all sources to targets: Press Alt+Shift+Insert [SDLX: Shift+F4]. Only empty target segments are affected. Note that you can elect to have this done every time you open a document for the first time. Go to File > Options > Editor. In the right-hand pane, there is this option:

This option should be used with care, however. For instance, if you are translating a WorldServer (p. 403) document which contains already translated segments, this option will overwrite those segments with the corresponding source content.

☐ Clear the target segment: Press Alt+Del.

☐ Clear all target segments: Select all segments (see below) and press Alt+Del.

☐ Clear draft segments: Press Alt+Shift+Del.


☐ Delete to end of row: Press Ctrl+D.

☐ Delete to next tag: Press Ctrl+Shift+D.

☐ Lock segment: One segment: Press Ctrl+L. A locked segment cannot be changed in any way. (The same command unlocks a locked segment.) Several segments: Select them – see below – and press Ctrl+L. They all get the same locked/unlocked status, determined by the last selected segment: if it is unlocked, all selected segments will be locked, and vice versa. This is regardless of whatever status the individual segments have.

A translated segment is confirmed when you finalize it with Ctrl+Enter [SDL Trados: Alt+(num)+]. The translation unit is then entered into the TM and the next unconfirmed segment is activated. (All locked segments are ignored regardless of translation source.) The confirmed status is indicated in the status column by the symbol, but the match percentage indication remains what it was. (If you go to next row by simply pressing the down arrow key, the translation will remain unconfirmed and nothing will be entered into the TM.)

Sometimes you need to confirm the translation and just go to the next segment. If so, press Ctrl+Alt+Enter. (It may happen that the ribbon shortcut letters and digits are activated, which may cause prob-
problems. You can avoid that by using AltGr+Enter instead – cf. p. 32 – or by pressing either Ctrl or Alt slightly before the other.)

You can also confirm the translation and stay in the same segment: press Ctrl+Alt+Shift+Enter.

If for some reason you have a segment pair which needs to be there but you don’t want to add to your TM (e.g. if the source sentence must remain split in an unattractive way), the obvious action is to avoid confirming it.

You “unconfirm” a translation by right-clicking in the row, selecting Change Segment Status and then selecting the appropriate status. Note, however, that the corresponding TU in the TM does not change even if you apply the status Not translated.

You can deactivate the TM update upon manual confirmation: Go to File > Options (Alt/F10, F, T); select Editor and its Automation option; de-select Update translation memory under After Confirming Segments Manually.

You can make a note to yourself that a particular translation needs to be checked by leaving the segment with Draft status.

Sometimes the first activation of a segment in a document results – after a long time of searching the TM – in this error message: “An error has occurred whilst using the translation provider [TM]: The translation memory data file engine returned an error: The database file is locked. Database is locked.” A possible solution to this problem is given in the Tradosstudiomanual blog post Database is locked. (Why not here? Because I don’t want to use space on what is after all not a common problem.)

This is how you confirm all translated segments in one go:

1. Go to row (segment) 1 (Ctrl+Home), then DownArrow.
2. Go to the last row (segment) using the Shift key (Ctrl+Shift+End).
3. Press Ctrl-Enter.

This is how you confirm all segments from a particular row until the end of the document:

1. Go to the last row (segment) using the Shift key (Ctrl+Shift+End).
2. Press Ctrl-Enter.

Note: It seems this function and the one before – which are not documented in the Studio help – are more or less standard Windows shortcuts, and chances are that you will find even more such undocumented shortcut functions if you play around a bit.

“Translate to fuzzy” is a function well-known to users of the “old” Trados. It means that the program steps through each row – including confirmed ones (except PerfectMatches) – inserting every 100% target match until it comes to a non-100% match (a “fuzzy” match, which may of course be 0%). If the TM hit is different from an existing target segment text, the process stops so you can edit if necessary. (About types of TM matches, see p. 199.)

Confirm and translate until next fuzzy match: Press Ctrl+Alt+F.

Stopping the translate to fuzzy process: Press Esc.
More on this can be found in Paul Filkin’s SDL blog post *Studio 2011 Series: Translate to Fuzzy.*

When you confirm a translation, and there is already a TU with the same source text but a different target text, the new translation will overwrite the existing one. If instead you want to *add* the current translation as a duplicate of the existing one, press **Ctrl+Shift+U** [SDL Trados: **Ctrl+Alt+Up**] before you confirm the translation.

When you place the cursor in a row, it automatically becomes *active*, which is indicated by a light blue-grey colour (which, like all colours, may be changed; see p. 169).

You can disable this “implicit row activation”. Open **File > Options** (or **Alt/F10, F, T**) and select **Editor**. In the **Side-by-side Editor** area you will see the option **Enable implicit row activation**. If this function is disabled, and you want to activate a row by clicking in it, you can manually activate it with **Alt+Home**.

**Navigation commands:**

**Go to** functions:
- **Beginning of target segment:** Press **Ctrl+PageUp**
- **End of target segment:** Press **Ctrl+PageDown**
- **Next row** (without confirmation of the current one): Press **DownArrow**
- **Previous row** (without confirmation of the current target segment): Press **UpArrow**
- **Next unconfirmed target segment** (without confirmation of the current target segment): **Ctrl+DownArrow**
- **Previous unconfirmed target segment** (without confirmation of the current target segment): **Ctrl+UpArrow**
- **Specific row:** Open the **Go To** dialog box with **Ctrl+G**: The **Go To** command can be repeated with **Ctrl+J** [SDLX: **Ctrl+Shift+G**].

Navigate via the navigation pane: With some source documents (e.g. Word), the navigation panel will show a structured view of all segments (at right), and by clicking on an item you will activate the corresponding row in the **Editor** pane.

**Select rows**
- **Select next row(s):** **Alt+Shift+Down**
“Recognized tokens” (including tags); special characters; whitespace characters

A recognized token – previously called “placeable” – is “a short piece of text, enclosed in a segment, that a TM treats as a single word because it is a defined format”. The following are simply inserted into the target segment just as they are, provided you have enabled the corresponding auto-substitution; see p. 229:

- Inline tags
- Acronyms
- URLs
- Alphanumeric strings
- Variables

Alphanumeric strings are any strings made up of combinations of letters, number, underscores, dashes, and full stops; e.g. NAME_4001a. They must not start or end with underscores, dashes or full stops, must not contain both dashes and full stops, and must contain at least one number and one letter. But you can handle also those alphanumeric strings which do not follow these rules by using the OpenExchange plugin *Regex Match AutoSuggest Provider*; see p. 242.

**Note 1:** The recognition of alphanumeric strings is activated by default. You can deactivate it in the *Project Settings* window under *Language Pairs* > [the language pair in question] > *Translation Memory and Automated Translation* > *Auto-substitution* and check *Alphanumeric strings*.

**Note 2:** For existing TMs you need first to enable the corresponding setting. In the *Translation Memories* view, select the TM in question and press Alt, H, G (or go to *Home > Tasks > Settings*, or right-click the TM name and select *Settings*). In the *Translation Memory Settings* windows which opens, select, in the right-hand pane, the *Alphanumeric strings* option. After that, you need to re-index the TM: In the same *Settings* window, select (in the left-hand pane) *Performance and Tuning* and click the *Re-index Translation Memory* button. (However, if you have many TMs where this needs to be done, it can take some time. For this reason, the SDL Community Developers have provided the very practical OpenExchange application *Reindex TMs*, which sits on your desktop.)
You simply drag the files to be reindexed into the top half of its interface window and press the Re-index button. (Instead of dragging the files, you can load all TMs which are open in the Translation Memories pane in the Translation Memories view; to do that you just select the Load Studio TMs checkbox at the bottom of the window.) In the bottom half you can follow the progress.

Before starting the reindexing, you should close Studio, since the changes to the TMs are normally not effected until upon restart.

You can read more about this feature in Paul Filkin’s blog post *The future is bright… it’s not Java!*, under the heading “Automatic recognition of Alphanumeric characters”.

Some may be easily “transformed” (localized) to the target segment according to specific rules. They are indicated either by being colored or by a blue square-bracket underline. They, too require enabling of auto-substitution (p. 229) and are as follows:

- Dates
- Times
- Numbers (in numerals)
- Measurements

As for the localization of the tokens, again see p. 229.

Tags (containing information about formatting, structuring and placeholder) are a special case of recognized tokens in that they are not part of the textual content. They are shown as colored fields and their handling is described on p. 225.

**Inserting recognized tokens**

There are several ways to insert recognized tokens (always at the place of the cursor in the target segment):

- **Keyboard**: Press Ctrl+[comma] or > or Ctrl+Alt+DownArrow. (Note that the last combination – as well as the one for stepping between tokens; see below – may result instead in changing the screen. If so, you need to deactivate the Windows hotkeys: right-click anywhere on the screen, select Graphic options [or the corresponding option in your language] > Hot Keys > Disable.) A QuickPlace list of the “candidates” in the source segment opens.
Note that for every option that you go to – with DownArrow – the affected text in the source segment will be highlighted. Select the required option and insert it by pressing Return or tab.

Pressing < gives the same result except that noting in the source segment will be highlighted (and if you close the list with Left/RightArrow instead of another key, the < will stay).

By pressing Ctrl+Alt+RightArrow/LeftArrow, you step between the recognized tokens (but not the numbers) in the source segment, forwards or backwards; each token is highlighted in turn. When you let up the keys, the selected token is inserted in the target segment (but it is still highlighted, so you need to press RightArrow before you start typing again, or it will be replaced by the next character). For some reason, the RightArrow always starts with the first token – and the LeftArrow always with the last – regardless of which one was the last inserted. Irritating, but there you are.

Note: It may happen that instead of this result when you press this key combination, the screen goes black and then, when it shows again, is rotated. This is probably because you have updated the Intel Video driver. The solution is to inactivate its shortcuts: right-click the screen, select Graphics Options > Shortcuts > Inactivate.

You can apply a particular tag pair from the source segment to a word or words in the target segment by selecting those words and then use one of the above methods. See also about Ghost tags, p. 228.

If you don’t like long lists of numbers (as sometimes happens; see the figure above) – which are useful only when the numbers are really big – you should be able to get rid of them by de-selecting the Recognize numbers and/or Recognize measurements options in the Fields and Settings dialog box: click the Project Settings tab above the Translation Results pane, select the TM in question, click the Settings tab above the TM list, select Fields and Settings in the new dialog box, and make the desired changes. (Can’t promise it works, though; it seems a bit erratic. And in particular, if you use a server TM from a translation provider, you need to be authorised for this.)

Note 1: There are numerous shortcuts for the QuickInsert/QuickPlace options; see Annex C (or simply point to the group’s buttons).

Note 2: You close the list/dialog box without insertion of an entry with Right/LeftArrow.

Note 3: As for Studio’s ability to correctly recognise numbers etc., it is based on conventions for each (sub)language based on their representations as defined by Microsoft in their National Language Support (NLS) API Reference. Hence the source text must follow these conventions, or Studio will not be able to perform recognition correctly.

Note 4: For such items as are not recognised by Studio but are similar to these (such as the transformation of numeric dates),
You can set up Studio to recognize certain types of expressions and treat them as **recognized tokens** (previously called “placeables”); cf. p. 218. This means that, during translation,

a. if the source segment is identical to a TU except for tokens, Studio will insert the corresponding target segment as a 100% match with the target versions of the tokens inserted; or

b. if no hit in the TM is found for the source segment, you will still be able to insert the token in the simplified way using Quick-Insert (see p. 222).

The types of expressions are:

- Acronyms
- URLs
- Variables
- Inline tags
- Dates
- Times
- Numbers (in numerals)
- Measurements

For the first four of these tokens, which means that the suggested target is the same as the source.

The last four of them can be automatically **localized** according to the settings for the target language. If you want automatic localization to take place **during pre-translation or when applying matches from a TM**, the Auto-Substitution function must also be enabled – which it is by default. This is how you disable it: Depending on whether to do this in the default settings, the current project or a specific project template (see p. 113), select in the respective dialog box the TM in question (not under **All Language Pairs**), then select **Auto-Substitution**, and deselect the appropriate options:
(De)activate a recognition (by default they are all activated; normally there is no reason to deactivate them, but it may happen that e.g. number expressions do not follow the rules set out by Microsoft in their National Language Support (NLS) API Reference, and then numerous of false QA errors may be reported if these settings are active): Select the Translation Memory view; right-click the TM in question (it does not have to be open) and select Settings; then select Fields and Settings and make any necessary adjustments under Recognize:

More on the handling of numbers, acronyms and variables:

- **Numbers** are automatically localized according to the settings for the target language. (Note that in particular the word “in” can cause problems if preceded by a number – it may be interpreted as “in.”, i.e. inches. There is probably a way of avoiding this even if I haven’t yet figured out how.) This localization only applies to “clean” numbers; not expressions such as A150.

- **Acronyms** are identified as consisting of an uppercase letter, followed by 1–4 more uppercase letters, or by the & character and by a single uppercase letter (e.g. “A&B”). An acronym may not contain a full stop.

- **Variables** are set by yourself for a specific TM: Select the Translation Memory view; right-click the TM in question and select Settings; then Language Resources. Select at right Variable list and click Edit. Add variables as necessary in the dialog box that opens. (Go to the end of the list, double-click and type the new variable. If you need to edit an entry, double-click it.) Depending on the type of document you are translating, this is potentially a quite powerful function.

  Punctuation within variables is not allowed.

The Variable list can also include comments and headings. Those must be directly preceded by the hash symbol (#); e.g. #comment.
AutoSuggest

AutoSuggest is a new function whereby Studio, by detecting the first few characters that you type, makes suggestions based on expressions in the selected termbases and in specific AutoSuggest dictionaries (p. 237), and on expressions that you have entered into an AutoText list (p. 243) for the target language in question. The symbol to the left of the suggestion indicates its source (the picture below illustrates an AutoText hit).

The more characters you type, the more specific the suggestions will be.

Make your selection with the Up/DownArrow and press Enter. If you want to close the list without using any of the suggestions, press Right/LeftArrow. Or just go on typing, ignoring the list.

An AutoSuggest dictionary contains words and phrases extracted from a TM.

You will find a detailed discussion of the uses of AutoText and AutoSuggest in Paul Filkin’s SDL blog post Studio 2011 Series: Using AutoText and AutoSuggest as well as some detailed discussions of AutoSuggest providers – including the use of termbases – in his multifarious blog post The ins and outs of AutoSuggest.

Setting up AutoSuggest

Enable AutoSuggest and select “providers” of AutoSuggest entries: Open File > Options (or Alt/F10, F, T) and select AutoSuggest in the navigation pane:
The provider options Termbases, AutoSuggest Dictionaries and AutoText are self-explanatory. The Translation Memory and Automated Translation option means you can get matches from TMs, machine translation resources and concordance searches, with these symbols:

- **TM** for exact TM match
- **FP** for fuzzy TM match
- **AI** for machine translation
- **AC** for concordance match

This is a new and very useful feature, which is described in detail by Nora Díaz in her blog post, Studio 2015: AutoSuggest Gets Even better (with a video, too). If you want to use it, make sure that the Editor > Automation settings (in the File > Options dialog box) has Apply best match after successful lookup deselected (it is selected by default); also your settings of the minimum match values for TM lookup and concordance lookup (p. 200 and 204, respectively) should be set sufficiently low for hits to appear.

As for the settings of which number of suggestions to show and their number of characters, you should experiment. But you probably do not want a large number of suggestions – which might happen, even if the suggestions are based on the source context –, nor will you want very short expressions to be suggested.

- **Hide suggestions which have already been used** means “used before in the current segment”; i.e. the word/phrase already exists in the current target segment.

- **Case sensitive** – if you uncheck this, AutoSuggest will not only find results regardless of case, it will also adapt the hits accordingly (i.e. if the term you start to type starts with a lower-case letter, then the
Auto-propagation means that the translation of a segment is copied to all other target segments with identical source content in the same document. It takes place when you confirm the translation. A target segment which is translated via auto-propagation will be given this status: \( \text{100\%} \), and the colour – which does not change if the translation is confirmed – indicates the difference from a “normal” 100% match (\( \text{100\%} \)). And since auto-propagation does not require a TM, it can be used even if no TM is specified.

Open File > Options (or Alt/F10, F, T). Select Editor in the navigation tree and then Auto-Propagation. Make settings as follows (the figure shows the default settings):

Explanations:

- **Enable/disable**: Under General: Select/unselect the check-box Enable Auto-propagation.

- **Matching requirement**: Under General: Select a 100% minimum match value or lower (hardly advisable). Note that you do not have the choice of “context match”, i.e. 101%.

Note that you can select a specific background colour for autopropagated segments; see p. 170.
Auto-propagation

- **Auto-propagate exact matches to confirmed segments**: If you make a change to a target segment with matching source text elsewhere in the document, the change will be propagated also to those segments which are already translated and confirmed. In my experience, this is a very useful option.

- **Confirm segment after auto-propagating an exact match** will probably save time. If you have set the matching requirement – see above – to less than 100%, any such propagated “lesser matches” will not be confirmed.

- **The whole document or only “below” the current segment**: Select as **Starting Position** either First segment or Next segment in document. (Obviously, you cannot propagate “upwards” only.)

- **Prompt for confirmation**: Select whether you want to be warned for every segment to which the translation or change is propagated (Always), or not at all (Never), or conditionally when the matching segment has been translated differently, and/or the matching segment has no translation, and/or the matching segment is confirmed. The latter option is of course available only when auto-propagation to confirmed segments has been selected. The warning looks like this:

**Note 1**: Auto-propagated segments with tags missing from the target segments will get a ‘missing tag’ penalty.

**Note 2**: The Auto-propagation function can sometimes be tricky and may give unwanted results with numbers. Discussions in TW_users (see p. 12) indicate that some experimenting with the settings may be required to get satisfactory results. One particular problem is that when a numerical range is given using the en dash instead of the “short dash” (often called hyphen-minus), e.g. 350–500 instead of 350–500 – which is very common in many languages – the Auto-propagation does not recognise this but auto-propagates only the first number; also it substitutes the short dash for the en dash.

**Note 3**: If you use the filtering function (p. 184), it may happen that the auto-propagation function does not work properly. Therefore, it is probably safer not to combine them.
Autocorrection and autocompletion

Studio 2015 has an AutoCorrect function which works the same as in Microsoft Word. All its settings are found in **File > Options > Editor > AutoCorrect** (the **Options** window is most easily opened with Alt/F10, F, T):

The **Exceptions** button gives access to these options:
And just as in Word, you can use the Replace text as you type function to set up shortcuts for longer words or expressions.

You can export and import settings, which get the extension .autoCorrect. You cannot import a corresponding Word list (or a Studio list into Word) since the formats are different. However, an .autoCorrect file is editable in some text editors (not NotePad), e.g. Atom (https://atom.io), which means that you can export a Word list and make it conform with the .autoCorrect format. There is a Word macro for that, provided courtesy of Spiros Doikas (read more about it at http://www.translatum.gr/forum/index.php?topic=399434.0):

```
Sub AutocorrectTabsReverse()
    Dim a As AutoCorrectEntry
    For Each a In Application.AutoCorrect.Entries
        Selection.TypeText a.Value & Chr(9) & a.Name & vbCr
    Next
End Sub
```

Insert the macro in Word as described below (p. 257), select the Word target language as desired and run the macro. The resulting list is to be pasted in the exported .autoCorrect file below the row `<AutoCorrectEntries>`. Note, however, that this part of the file must not contain duplicates or it cannot be imported back into Studio. In practice, this means that you must replace the whole existing AutoCorrectEntries list with the corresponding Word list. The alternate solution is to refrain from using the Word list and just edit the original AutoCorrectEntries list as appropriate.

**Third party solutions**

In previous versions of Studio there was no AutoCorrect function, and because of that I described two applications which not only cater to this need but offer a lot of other useful functions: AutoHotkey and
### Handling bilingual Word files

Users of “old” Trados (and also Wordfast, Déjà Vu and some other CAT tools) will recognize the bilingual Word file format which is the result – directly or indirectly – of translation in those tools. Such a document typically looks like this:

![Bilingual Word file example](image)

I.e. source segments (here: blue) and target segments (green) separated and enclosed by “Trados tags” (violet).

The 2009 version of Studio could neither handle nor produce such documents, to the chagrin of many users whose clients demanded results delivered in that format. Workaround processes were soon developed, but those are no longer needed. You can import a bilingual Word document (in .doc format; not in .rtf format) – also complex ones, with footnotes and other sub-segments such as index entries – directly into Studio, work on it and export it (with Shift+F12 [SDLX: Ctrl+Shift+F12] or File > Save Target As [or Alt/F10, F, G]) to the same bilingual format. As for delivering “normal” translations (i.e. where the source document is not a bilingual file), see The SDLXLIFF to Legacy Converter below. Paul Filkin gives us a general discussion of the handling of bilingual Word documents in his SDL blog entry Studio 2011 Series: The Return of the Bilingual Word File Type.
Handling .pdf files

While SDL Trados claims that Studio is able to handle .pdf files, the result sometimes is less satisfying. The text may be cluttered with so many tags that it is impossible to work with. But if you are going to use this facility, don’t forget to explore the possibilities to make appropriate file type settings in File Types > PDF in the Options or Project Settings dialog box.

So, the basic rule still stands: If at all possible, do not base the job on .pdf files but demand the files in the format on which the .pdf conversion was based.

Still, it should be pointed out that Studio 2015 includes a function for converting the .pdf to Word format with in many cases quite satisfying results; in particular it handles “scanned” .pdf content, i.e. content which is in the form of images, not text characters. These are the settings available under Options > File Types > PDF > Converter:

The above are the default settings, which usually are the preferable ones.

Once you have made this conversion and opened the file in the Editor view, you should copy all source to target and then preview the target file in Word (Ctrl+Shift+P [SDLX: Ctrl+Alt+Shift+T]) to check if the result is acceptable. (The results may vary very much, from quite good to totally unacceptable. Jost Zetzsche has made an interesting experiment comparing the results of five different OCR tools including Studio; see issue 253 of his Tool Box Journal.
Handling legacy (old format) TMs

Migrating non-Studio format TMs into Studio

There are a number of non-Studio format TMs, and the way they can be migrated into Studio TM format, and what can be migrated, varies. See also the Trados Studio Migration Guide (p. 10) for very detailed information. The section designations refer to the subheadings on pp. 334–342.

There is an extensive guide for working in legacy workflows, written by SDL’s Daniel Brockmann and Paul Filkin: TTX/Bilingual DOC(X) Compatibility Guide for SDL Trados 2014 Users.

<table>
<thead>
<tr>
<th>Source program</th>
<th>Format</th>
<th>Method</th>
<th>System fields</th>
<th>Custom fields</th>
<th>Segmentation rules</th>
<th>Language resources</th>
<th>Tags</th>
<th>See section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trados 7.x, 2006 and 2007</td>
<td>TMW</td>
<td>Upgrade</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes 2</td>
<td>5</td>
<td>Yes</td>
<td>D</td>
</tr>
<tr>
<td>Trados 7.x, 2006 and 2007</td>
<td>TMX 1.4b</td>
<td>Upgrade</td>
<td>Yes</td>
<td>Yes 3</td>
<td>–</td>
<td>5</td>
<td>Yes</td>
<td>D</td>
</tr>
<tr>
<td>Trados 7.x, 2006 and 2007</td>
<td>TMX 1.4b</td>
<td>Import</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>5</td>
<td>Yes</td>
<td>C</td>
</tr>
<tr>
<td>Trados 7.x, 2006 and 2007</td>
<td>TXT</td>
<td>Upgrade</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>5</td>
<td>Yes</td>
<td>D</td>
</tr>
<tr>
<td>SDLX 2005, 2006, and 2007</td>
<td>MDB</td>
<td>Upgrade</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes 6</td>
<td>–</td>
<td>Yes</td>
<td>D</td>
</tr>
<tr>
<td>SDLX 2005, 2006, and 2007</td>
<td>TMX 1.4b</td>
<td>Import</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>6</td>
<td>Yes</td>
<td>C</td>
</tr>
<tr>
<td>Other programs</td>
<td>TMX 1.4b</td>
<td>Upgrade</td>
<td>Yes</td>
<td>Possibly</td>
<td>–</td>
<td>–</td>
<td>Possibly</td>
<td>D</td>
</tr>
<tr>
<td>Other programs</td>
<td>TMX 1.4b</td>
<td>Import</td>
<td>Yes</td>
<td>Possibly</td>
<td>–</td>
<td>–</td>
<td>Possibly</td>
<td>C</td>
</tr>
<tr>
<td>Trados Studio SDLXLIFF bilingual</td>
<td>Import</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
</tr>
<tr>
<td>Trados 2007 TTX biling.</td>
<td>Import</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>Yes</td>
<td>A</td>
</tr>
<tr>
<td>Trados 2007 DOC biling.</td>
<td>Import</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>B</td>
</tr>
<tr>
<td>Trados 2007 RTF biling.</td>
<td>Import</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>B</td>
</tr>
<tr>
<td>SDLX 2007 ITD biling.</td>
<td>Import</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
<td>A</td>
</tr>
<tr>
<td>Trados 2007 INI</td>
<td>Import</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>Yes 4</td>
<td>–</td>
<td>E</td>
</tr>
</tbody>
</table>
Handling legacy TMs  Migrate non-Studio format TMs into Studio

<table>
<thead>
<tr>
<th>Trados 2006</th>
<th>INI</th>
<th>Import</th>
<th>–</th>
<th>–</th>
<th>Yes</th>
<th>–</th>
<th>Yes 4</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>SDLX 2007</td>
<td>ANL</td>
<td>Import</td>
<td>–</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>E</td>
</tr>
</tbody>
</table>

1 These settings include segmentation rules, abbreviations list, ordinal followers list, and variable list; see p. 327 and footnotes below.

2 If you migrate the Trados 2007 segmentation rules, they will totally replace the Studio ones.

3 With some restrictions.

4 Formatting.

5 Segmentation rules: only Trados 2007. The lists: only if they are user-defined.

6 Only segmentation rules.

Except for the Word formats (.doc and .rtf), TMs that are based on bilingual formats have the added advantage of including context match information which makes possible both Context Match and Perfect Match analysis (see p. 146), which may make it more advantageous to import such files than to upgrade the corresponding .txm files, if you have the choice. On the other hand, bilingual files do not contain custom fields.

**Note 1:** As the table shows, .txm files can be either imported into existing Studio TMs, or upgraded into new Studio TMs. In the former case, the imported file is not scanned for custom fields, but you can choose to import/ignore those. When importing, you may also filter out unwanted TUs and define what custom field values to apply to the imported TUs (if the target TM contains custom fields). During upgrade, custom fields which do not contain any values will not be included in the process.

**Note 2:** There is an OpenExchange plug-in for the use of SDLX TMs, [SDLX Translation Memory Plug-in for SDL Trados Studio](#). It supports all three types of SDLX TMs: file-based TMs in .mbd format; server-based TMs on a Microsoft SQL server; and server-based TMs in SDL .tms. See also p. 337.

---

**Importing files into an existing Studio TM**

**A: Importing .ttx, .itd and .sdlxliff bilingual files**

Supported bilingual formats for import are Trados 2007 .ttx and SDLX 2007 .itd and Studio .sdlxliff.

1 In the *Translation Memories* view, right-click the desired TM and select **Import**, or select the TM and then **File > Import**. The **Import** wizard opens with the **Import Files** page.

2 Depending on whether you are going to import a file or a folder (with several TM files), click the **Add Files** or **Add Folder** button. Select the
Handling legacy TMs

Importing files into an existing Studio TM

file(s) to import. The Import – Bilingual Document Import Options page opens:

Select confirmation (i.e. status) levels for the TUs to be imported. (Draft corresponds to Fuzzy Match or Machine Translated in .ttx; Translated corresponds to 100% Match or Manually translated in .ttx and Confirmed in ITD; Translation approved corresponds to Context Match and PerfectMatch in .ttx and Unconfirmed in ITD.) The other options pertain to the review process; see p. 302. Click Next. The General Import Options page opens.

Apply Field Values permits specification of which custom field values (p. 325) shall be assigned to the imported TUs, if the importing TM has such fields (the bilingual files do not).

The other options are self-explanatory. Here it is important to consider whether to import TUs as plain text, in which case all tags (including formatting) – which may not be relevant – are ignored. If
You can “align” the source and the target file of a translation to produce a translation memory. The alignment tool is new in Studio 2014 and replaces the old Trados WinAlign tool. It produces a set of TUs which can then be imported into a new or existing TM for use directly in Studio. There is also the option of producing an intermediate file in the new .sdlalign format for editing before import into the TM.

**Note:** You still have access to WinAlign here: C:\Program files (x86)\Common Files\SDL\T2007\TT\Winalign.exe. And WinAlign has its own Help functions.

The alignment function supports all file formats which are supported by Studio. If necessary, you can create new file types as appropriate before starting the actual alignment process. And in general, it is not necessary that the target and source files have the same formats.

There are extensive instructions in the Help, of course (available also here: Aligning Existing Translated Files). You can align one or several file pairs, and you can do it with or without “review” of an intermediate .sdlalign file, i.e. with or without editing the resulting TUs before they are sent to the selected TM. Or you can send them there directly, in which case no intermediate .sdlalign file is produced.

You can also open the alignment result (the .sdlalign file) for (re)editing at a later time.

**Note:** When later you use the aligned TUs during translation, any hits in such TUs will have a 1% penalty, so that they will never be 100%. (This can of course be changed; see p. 202 about the Penalties pane.) They will be signified in the Translation Results window with a [0%] symbol, and the origin will be given as Automatically Aligned (when you point to the Status field).

There are also other ways to edit the alignment results. After they have been imported into a TM, you can edit them there in the Translation Memory view. You can also export the .sdlalign file into .sdlxliff format and edit that in the usual Editor view.

If you have a Word document which contains a table with the source text in one column and the target text in another (with one
row for each pair of source and target text), it is of course quite easy to split it into two documents and then use the Alignment function. However, Roger Sjölander has written a macro which uses the table as it is and converts it into a TM file in text format. The macro and more instructions can be found in this Tradosstudiomanual blog entry: *Creating a TM file from a Word table with source + target.*

Not surprisingly, Paul Filkin has written a multifarious blog post, *Working with Studio Alignment*, about this. It includes a 17 minutes long video tutorial!

**Alignment with or without review**

By default every alignment ends with the resulting .sdlalign file being

- saved with the name of `[name of source file]_[name of target file].sdlalign` (however, sometimes the default name, inexplicably, is just `[name of source file].sdlalign`); you can of course assign another name,

- saved in `%UserProfile%/My Document/Studio 2014/Alignment Results`, but you can change that address at the start of the alignment process (see below),

- opened in the Alignment view.

**Alignment with review**

If you have only one file pair to align, the **Align Single File Pair** is slightly quicker to set up than the alternative **Align Multiple Files**, which can of course be used also for the alignment of a single pair.

**Align Single File Pair:** In any view, press `Ctrl+Shift+M` (the corresponding button is found on the **Home** tab in the **Welcome** view, the **Translation Memories** view and the **Alignment** view). The **Align Documents** wizard starts with the **Select a translation memory and the documents to align** dialog box.
Translation Units maintenance

The Translation Memories view

Ribbons

The Home and View ribbons are – as always – specific:

Description

The Translation Memories view is where you edit the TUs stored in your TM; i.e. change texts, formatting, field values, etc. – in fact much like you work with the segments when translating; one difference being that you can also edit the source segments; another that you also have field values to manipulate (if you have defined custom fields). The view typically looks like this (as usual, you can customize it by moving any pane which has a symbol in its title list; see p. 29):
Translation Units maintenance

The Translation Memories view

- Custom Fields (in the Field Values pane) are fields which are not standard (system) fields but have been added by a user.
- System Fields are automatically generated, e.g. creation and modification dates (p. 317).

- Open a TM: Double-click its name in the Navigation pane (or use Alt+Shift+O, but then of course you have to locate it in the usual Open window). You can have several TMs open, but only one can be active. If you have several TMs open, you go between them by clicking the tabs on top of the Editor pane. If you have really many open, you can use the ▼ symbol in the top right-hand corner; a list of all the open TMs is shown.

If you have a .tmx file that you need to edit, there is now an OpenExchange application, File type definition for TMX, which makes it possible for you to open it as a translatable file without converting it into an .sdltm.

- Close a TM: As usual, click the × in top right hand corner of the Editor pane. If you have made any (pending) changes (see p. 363), you will be asked whether to commit them or discard them.

- Remove a TM: In the navigation pane, right-click the TM to be removed and select Remove From List.
Translation Units maintenance

The Translation Memories view

The side-by-side Editor pane

![Diagram of the side-by-side Editor pane with columns for TM name tabs, Source language segments, Target language segments, TU status, Document structure, and Custom field values.]

(Note that the document structure and custom field values columns are visible only when at least one TU contains such information.) A TM will normally take up several pages in the Editor pane. The number of TUs per page is set with File > Options (or Alt/F10, F, T), select Translation Memories view and then set the Number of translation units per page as necessary. (To go between pages, press Alt + Right/Left arrow, or click the Home > Navigation icons.)

Some explanations:

○ **TU status:**

- **Edited:** Some change(s) has been made
- **To be deleted**
- **Invalid:** Some error (e.g., one segment is empty) was detected during verification (when the cursor was moved to another TU)

The status is also reflected in the background colors of the TU:

- **White or gray:** No pending changes.
- **Yellow:** Pending changes.
- **Pink:** Marked for deletion.
- **Blue:** Currently selected.

These colors may be customized; see p. 169.

○ **Document structure:** The same as for segments in the translation editor pane; see Annex E.

○ **Custom field values:** Reflects the field values shown in the Custom Fields pane (where you make any changes).
MultiTerm and termbases

The use of MultiTerm is integrated in the use of Studio, where you can search for, edit and create termbase entries. For more radical termbase management – such as advanced searches, and the creation of new termbases – you have to start and use MultiTerm itself. Here I will just cover the basic uses plus the basic settings and the shortcuts (see Annexes N–R). As with Studio, you may find that it pays to study them in order to get a view of the functions available. For the rest, I refer to the quite extensive Help function and SDL Trados’ own resources, at www.translationzone.com/en/translator-products/sdlmultitermdesktop. There is also an interesting multifarious blog post by Paul Filkin, Is MultiTerm really that hard to learn? in his multifarious blog. And another one, Multitudinous terminology!, where he explains the reasons for the complexities of this application.

MultiTerm 2014 supports termbases created in MultiTerm 6.x to 2007, and termbases created in MultiTerm 2009 and 2011 are completely compatible with MultiTerm 2014 termbases.

However, it may happen when you open a 2011 that you are told that the termbase needs to be reorganised. How to do this is well explained by Nora Díaz in her blog post Studio 2014: Termbase Needs to be Reorganized, but How?

The basic settings

The basic settings available via File > Options (or Alt/F10, F, T) are quite few and easily illustrated by screenshots:
The MultiTerm window

The ribbons can be customised in the same way as in Studio (see p. 22).

The Terms view – ribbons

This is a typical MultiTerm window with the Hitlist view activated.
In the *Terms* view, you work with terms and termbase entries. In the corresponding *Navigation* pane, there are three tabs:

- **Browse**, with the terms from the selected database shown in alphabetical order.

- **Hitlist**, where you work with the termbase search results.

- **Termbases**, where you select, in the list of open termbases, which termbase (the default termbase) to view in the *Browse* pane (click that termbase), and exclude termbases from searches. There are also other actions to perform; right-click a termbase name and they all become available.

There are also other actions to perform; right-click a termbase name and they all become available: